`multipass find` expected images

I have multipass 1.0.0, running on macOS 10.14.6 (Mojave) and installed via brew cask.

What is the expected output of multipass find? Even with --show-unsupported, I only see two LTS images and two Snapcraft builders:

$ multipass find --show-unsupported
Image                   Aliases           Version          Description
snapcraft:core          core16            20191219         Snapcraft builder for Core 16
snapcraft:core18                          20191219         Snapcraft builder for Core 18
16.04                   xenial            20191217         Ubuntu 16.04 LTS
18.04                   bionic,lts        20191218         Ubuntu 18.04 LTS

The multipass find docs mention dailies and a devel alias, but neither works:

$ multipass find daily:
find failed: daily is not a supported remote. Please use `multipass find` for list of supported images.
$ multipass find devel
find failed: Unable to find an image matching "devel"

The github repo readme also suggests that I should be seeing several more images:

$ multipass find
Image                   Aliases           Version          Description
core                    core16            20190424         Ubuntu Core 16
core18                                    20190213         Ubuntu Core 18
16.04                   xenial            20190628         Ubuntu 16.04 LTS
18.04                   bionic,lts        20190627.1       Ubuntu 18.04 LTS
18.10                   cosmic            20190628         Ubuntu 18.10
19.04                   disco             20190628         Ubuntu 19.04
daily:19.10             devel,eoan        20190623         Ubuntu 19.10

Is this expected behavior? I feel like I’m missing something fundamental but don’t know what.

1 Like

Hi @garrett, thanks for asking.

We can only currently support the “short” list outside of Linux, but we’re working on enabling more. Stay tuned!

We will also clear it up in our documentation.

Hello,

I’ve got multipass 1.1.0+mac running on my… well mac. I did a multipass find. The image I was interested in was listed as “daily:20.04”. You see I want to start testing the upcoming ubuntu focal server.

So I started typing my “multipass launch” command while looking at the help for that command. That took a couple of minutes. I was being carful and all. Anyway this is what I got once I executed my carefully crafted command:

" launch failed: daily is not a supported remote. Please use multipass find for supported images."

Sure enough running another multipass find didn’t find the focal image anymore. Now I figure one of two things must have happened. Either y’all are messing with the newbie or they took the image down while I was fussing in terminal.

So my question: is there anyway to create my own image that I can install a new multipass vm from? I tried that with the daily focal .iso but no joy. Multipass says that http and file images aren’t supported. That likely answers my question right there.

I can (and did) create a focal vm with VirtualBox so I’m not blocked on testing but Multipass just seems cooler than VirtualBox. I’ll keep checking with multipass find to see if they do put another focal image up but if anyone has insight into what’s going on I’d appreciate it.

Thanks!

Hello again,

I tried running Multipass from Ubuntu Eoan installed natively on an older MacBook Pro. The ‘find’ command does see the remote daily:20.04 install image, even though ‘multipass find’ on macOS Catalina still does not. It also easily launches a new Focal vm.

I’m wondering if this is expected behavior. By that I mean, should Multipass running natively on Ubuntu see more/different remote install images than Multipass running natively on MacOS? I’m also still wondering if there is a means to create local Multipass install images. I didn’t find any documentation that addresses it.

If anyone on the multipass team would like to point me to specs or even just answer some questions about this, I’d be happy to write up docs for it. I spent a decade or so as a technical product manager for various Microsoft products. Doing this is in my wheelhouse. Or was anyway.

Thanks

Hi @mike-actual as I said two posts above, we can only support the LTS versions of Ubuntu on Windows and macOS, we’re working on enabling more.

1 Like

Any chance 20.04 will be released soon? I am still only seeing 16.04 and 18.04 on macOS and would love to start using 20.04. Thank you.

Hey @smokinggun!

Version 1.2.1 is supposed to allow 20.04. Do you have this version? If so, it seems something may be wrong, so could you please submit a bug report at https://github.com/CanonicalLtd/multipass/issues/new?

Thanks!

1 Like

Perfect – that did the trick. I had just upgraded to 1.2.0 on the 28th, and didn’t realize there was an update. Thank you!