Mouse clicks are not getting detected Ubuntu

I have recently done a dual boot of Windows 10 and Ubuntu 20.04 LTS version. After failing to install Ubuntu twice, when I finally installed Ubuntu, it looked like everything was fine. But after some time, the mouse’s left click does not register. I tried running the following commands:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

And it seemed to fix the problem, but only for some time. It also works (for the entire session, until I logout or sleep (sleep as in suspend) or power off) when I press Alt + Ctrl + F1 and Alt + Ctrl + F8. I also tried changing my GPU (A Nvidia GeForce)'s driver, after which it asked me to configure Secure Boot (I had it enabled). I set up a password and rebooted. It then entered a Perform MOK Management Screen and gave me three options:

  1. Continue Boot
  2. Enroll MOK
  3. Enroll key from Disk
  4. Enroll hash from Disk

I left it alone for sometime to see the exact process to follow on another computer, but then it automatically booted. After booting into Ubuntu, I noticed the problem again. I pressed the Alt + Ctrl + F7 and Alt + Ctrl + F7 keys again, and it worked. I suspended Ubuntu and left it. Today, I opened it again and the same problem occurs.
I have gone online and tried out almost every solution, except some. What should I do now?

  1. Should I run the commands mentioned on this reddit post about adding a ppa:raof/aubergine repository to fix it?
  2. Should I try re-installing the Gnome Desktop Environment using sudo apt get install --reinstall gnome-shell ubuntu-gnome-desktop?

Or should I just do something else? Also, is this a well known bug in Ubuntu 20.04 (because I got this bug every time I tried to install Ubuntu)?

Edit: I am not able to reply to this post, I don’t know why. The reply button isn’t showing up:

It sounds like bug #1899206. Awaiting a fix for everyone, you can fix it for yourself by installing the mutter packages from this PPA.