Mir News: 5th April 2019

Mir snaps and Ubuntu Core 18

I’ve spent some time with the Mir snaps and core18 this week

Our Mir-related snaps have been built with base: core18 for a while now, but running them on Ubuntu Core 18 is something I have had trouble with.

Starting Ubuntu Core 18

I’ve had a problem for a while that I couldn’t get Ubuntu Core 18 to start on my RPi3. As Ubuntu Core 16 was working for me I’d not considered it urgent. But this week I finally tracked it down to a problem with HDMI: I’ve a portable 7" screen connected to the RPi3 and while it works with Ubuntu Core 16 it fails with Ubuntu Core 18. Plugging in a different monitor worked around this problem.

Having got Ubuntu Core 18 to start I’ve also figured out how to hack the Ubuntu Core 18 image to work with the 7" screen. After mounting the microSD card on my desktop the following needs adding to /media/alan/system-boot/config.txt:

# Force mode for 7" display
hdmi_cvt=1024 600 60 6

This is very specific to my screen so YMMV.

Starting mir-kiosk

Then I rediscovered a problem reported a month ago: mir-kiosk not starting on a Raspberry Pi 3 running Core 18 and tracked that down to a change in the image setup. I’ve PR’d Enable mir-kiosk to start on Ubuntu Core 18/RPi 3 to fix that, and also worked around the problem in mir-kiosk: Workaround for Mir not starting if the gadget snap sets ‘vt.handoff’

The latter workaround has landed and is now on mir-kiosk stable.

More Ubuntu Core 18/RPi3 woes

Another problem that has been reported is Mouse offset from image on Raspberry Pi 3 with Ubuntu Core 18 which says:

When running on a Raspberry Pi 3 (Ubuntu Core 18) the mouse is offset from the image, meaning that the lower and right part of the screen is not reachable as well as the mouse pointer being offset from the image that is displayed. For instance if you try to click on a link/button you have to offset (left and above) the mouse from the element.

I was able to confirm this and, although I have no solution yet, I did find a workaround:

snap set mir-kiosk cursor=software

Trying the same on a couple of other devices didn’t show a problem, so it seems to be core18+RPi3 specific issue with hardware overlays.

Broken mir-kiosk-apps

While testing various things I discovered that our mir-kiosk-apps snap defaults to a demo app that no longer works: “photoviewer” app doesn’t show any photos. This appears to be because of a change to the behaviour of a flickr API. Anyway, we’re updating the demo to offer apps that actually work.


Wayland protocol extensions for Mir based servers

I’ve continued my work on allowing servers to support additional Wayland protocol extensions and have for comment: prototyping more support for bespoke Wayland extensions up for review. There are a few comments I need to address before completing this work, but it covers the final piece of functionality I think is needed.

Wayland Conformance Test Suite

Last month @raof was experimenting with using wlcs with Weston:

Following on from this experience he’s been making some changes to make the integration process easier and that work has completed. We’ve got a few other items to clear, but we are looking forward to releasing wlcs soon.

Wayland debugging

Last year @sophie-w reported on his new Wayland debugging tool:

This has seen some use by other developers which has led to some improvements and fixes.

Wayland “layer-shell” extension protocol

@sophie-w has also been reworking the layer-shell support he’s introduced into MATE and Mir (Implement anchored surfaces for layer shell) with a view to landing “production code” into both projects. Not much for the end user to see this week but also “coming soon”.