Lxc console vga error

OS: Almalinux 9.2.
Installed virt-viewer package (dnf install virt-viewer).
LXD installed using Snap

lxc console myVM --type=vga 

returns me a dialog saying

“unsupported graphics type spice”

And this in console

(remote-viewer:1351949): IBUS-WARNING **: 21:56:08.781: Unable to connect to ibus: Exhausted all available authentication mechanisms (tried: EXTERNAL) (available: EXTERNAL)

Any chance to get this working?

Maybe try with spice-gtk-client instead?

I’m tried to find such package or equivalent to this in Almalinux 9.2, but no result. The only related thing I’ve found is this:
I don’t know if this is relevant for this, but… Anyone?

So because this issue, LXD cannot be used in RHL9 and derived, at least not if you need to access a VGA console (installing a VM from an ISO using a GUI installer, Windows or Linux…).
I’ve been not able to make it work. It works in Fedora because they have all the spice packages, but Almalinux or Rockylinux don’t have them :frowning:

I’m not sure about how this is implemented, but have you tried using the UI?

That one includes a graphical console as well, so it might be an alternative.

1 Like

Hello again.

Yes, I tested it some months ago, and reported a keyboard issue (https://github.com/canonical/lxd-ui/issues/348).
But it could be a good workaround: I can install using the ui, then set up some remote access method like vnc/xpra/rdp and continue working using it.
Thank you.

1 Like