Linux-firmware competing with linux-firmware-raspi2 on ubuntu 21.04

trying to update my packages today and hit this:

0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 153 MB of archives.
After this operation, 668 MB of additional disk space will be used.
Get:1 hirsute/main arm64 linux-firmware all 1.195 [153 MB]
Fetched 153 MB in 25s (6,163 kB/s)
Selecting previously unselected package linux-firmware.
(Reading database ... 193611 files and directories currently installed.)
Preparing to unpack .../linux-firmware_1.195_all.deb ...
Unpacking linux-firmware (1.195) ...
dpkg: error processing archive /var/cache/apt/archives/linux-firmware_1.195_all.deb (--unpack):
 trying to overwrite '/lib/firmware/brcm/brcmfmac43455-sdio.clm_blob', which is also in package linux-firmware-raspi2 3-0ubuntu2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Not sure what the best course of action is here. I tried a dpkg --reconfigure, forcibly uninstalled linux-firmware with apt remove --purge / clean but no avail. Reinstalling still encounters the same error.

Reluctant to remove /lib/firmware/brcm…blob or the raspi firmware package.

any suggestions? thanks!

edit: let me know if this should be reported elsewhere and I will file a bug. Might be fallout from a failed update yesterday.

update! the problem seems to have fixed itself.

life on the dev branch is pretty wild.