Keyboard layout switching problems and poll

Using Elementary OS 5.0 and having all the same problems. Solution mentioned by @Norbert does not work (as he said earlier) because Pantheon DE is based on GNOME.

This is just unbelievable how it is possible in real life - not to fix this SERIOUS bug for 14+ years. Because handling key combinations on key press is totally incorrect, even every web developer know this. Because Ctrl+Shift and Ctrl+Shift+F is two different key combinations which simply must not and should not be conflicting in any way.

Workaround mentioned by @solarpatrol does not work either, because pantheon’s key shortcuts can’t be set using gnome-tweak tools.

As @Norbert said in xorg865 bug thread. 14 years of doing nothing…
How can even anyone hope about any *nix distro becoming mainstream, if such critical bugs aren’t fixed for DECADES


Please somebody tell us whether using MATE with fore-mentioned patch still suffer from such problem: using ctrl-shift-smth combinations works as expected but ALSO switch layout?
This happens with me in GNOME after patch from kyak so Ubuntu is still remains almost unusable((

Finally I checked this myself: On MATE desktop everything works ok.


I had the same problem
Appeared at the first screen lock. On the locked screen, the keyboard does not switch the layout at all. Just the mouse. But after unlocking the combination Shift-Alt is installed instead of Alt-Shift

While disabled lock, but the blocking feature is a useful thing.

LTS release is approaching. Is there a chance that this critical bug will be addressed?

1 Like

Personally I’m ready. I have tested packages from my PPA on opcoming 20.04 LTS -

But it will not work on GNOME, so I’ll recommend to ignore GNOME and switch to other DE like Xfce , MATE or KDE.

1 Like

Personally I think that you should switch the distro, not just the DE. I think that the Devuan or Slackware communities deserve your valuable input.

That’s the beauty of open source: you can freely go wherever you want to.

I guess the answer to this question is no, the critical bug won’t be addressed… ((

1 Like

2021 is ending up now. And this childish bug is still there. I’m just wondering, if Windows would have had such kind of bugs, would it be so popular.

BTW, has anybody managed to make Pointer Location function not to interrupt other Ctrl-based key combinations? Because, I find this function useless if it prevents all other combinations from running. But I use it much on my work computer but it has Windows installed on it.

1 Like

Today Ctrl+Shift+N suddenly stopped creating a new folder but instead it opens another one window with the current directory. Very inconvenient. It’s shame. No wonder why open-source and/or free software is almost not used for business. It’s much cheaper to pay for a product and be sure that it will work as expected than get it for free and then get everything broken or messed.

1 Like

Simply do not use GNOMEs Hell! Remove it by using this Q&A and do not install it in next time.

Install MATE (or Cinnamon, or KDE, or Xfce, or Unity) and add my PPA to the system as described in


Thank you, Norbert! I’ll definitely change the DE but later. Cannot do it now because of lack of time and I’m afraid there are chances the something will go wrong and I’ll have to spend a day for installing everything from scratch.

1 Like

It suddenly struck me that Linux is presented as highly customizable :rofl: One can customize everything except the most critical (for oneself) stuff :laughing:

1 Like

Hmmm… Ctrl+Shift+N again creates folders… Even don’t know what to say.

@buggy-shortcut, the pointer location bug is being tracked in launchpad, so please subscribe to that bug and discuss it there.

As for Ctrl+Shift+N, it sounds like your Shift key is sometimes not being detected as pressed so try a different keyboard (or any USB keyboard).

Remember this site is not for reporting or discussing bugs. That should be done on Launchpad.

OK. Thank you, Vanvugt!

P.S.: I’m using a USB keyboard.

Of course not, because if the case of modifier keys as the shortcut (Shift+Alt), the desktop should wait until the keys are released to take shortcut action, other it can’t really be sure the user won’t be actually typing, say, Shift+Alt+something.

Windows does this, it’s very intuitive to use.

I’m a stupid user, I want the desktop to adapt to me, not the other way around.


I use Ctrl+Shift to switch the input language because both, Ctrl and Shift are leftmost keys on all keyboards I’ve seen so far. While Alt, e.g., may be 3rd (on PC keyboards) or 4th (on laptops). Thus, if I used Alt+something, instead of simple switching the language, I would had have to distract my attention from my task and to think what keyboard I’m using at the moment, and only then press the combination. Moreover, I use Ctrl cursor location quite often at my work PC (which is running Windows). But, on Linux, I cannot use it, since it blocks the rest of Ctrl-based shortcuts.

There is indeed a problem in Linux with this…

Please vote for this bug:, I really hope they fix it. This is a stopper for me moving to Linux.

I don’t switch keyboard layouts, Ubuntu does it for me as and when it feels like it.
I actually only have one language installed and the shortcut is supposed to be disabled.

However my laptop very badly wants me to type in US English layout for some reason.
Would like any advise as to how to remove the hidden US English layout or fix the keyboard layout switching behaviour.