Keyboard layout switching problems and poll

No, it does not. I switched to ubuntu-mate because of this problem. I do not think I will ever come back to ubuntu main distro.

2 Likes

Thank you @Norbert for reporting this issue and for providing a solution. I have noticed the same issue on Ubuntu 18.04 Unity and I’m going to try your patches.

1 Like

Unfortunately, @Norbert’s solution doesn’t fix my problem with the language switching shortcuts on Ubuntu 18.04 Unity.

1 Like

@kkomelin I can reproduce your issue on clean Ubuntu 18.04 LTS with Unity (ubuntu-unity-desktop) desktop. Thanks for testing!
I’m not an author of the patch. I just packaged it.

So we need some official reaction from Unity developers (and from GNOME too).

As I wrote above I can’t do more (with all respect to the Unity team).

I have a similar problem: after upgrading 16.04 to 18.04, custom keyboard shortcuts no longer work, also language layout switch shortcut doesn’t work. I have several keyboard shortcuts to launch certain programs, they are set up in Keyboard > Shortcuts > Custom Shortcuts and completely ignored currently. For language layout switching, I tried “tweaks” app, also the solution with custom ppa above, nothing seems to help :frowning: it’s really disheartening.

I’m using Unity, not the default GNOME - the header takes up room for no reason in gnome and there’s no way to get rid of it, so I’m sticking with Unity… I really hope the keyboard shortcuts can be fixed.

One weird thing I noticed is that when I click on current language indicator in the top bar and then Keyboard Layout Chart, the keyboard layout window changes Shift background to orange when I press it, and Alt background to orange when I press Alt, but when I press Alt and then Shift (the way I switch between languages), the orange background disappears on Alt after pressing Shift. For Ctrl+Shift it works as expected - i.e. both are highlighted, but Alt+Shift shows no highlight… I will really appreciate help fixing the shortcuts, I can’t really work without them and I’m considering downgrading back to 16.04 (I keep asking myself why I upgraded, everything worked perfectly!)

This seems to be a request for support rather than a contribution to the development of Ubuntu. I’d recommend that you ask a question at Ask Ubuntu or at some other of the available support resources.

The original question was of the same nature…

Anyway, I solved the problem by disabling Commands in CompizConfig Settings Manager.

1 Like

You (developers of Ubuntu, GNOME, whatever) break things and make life of users harder.

We (users) want you (developers) to fix all errors on system-wide level by coordination of your efforts here.

I can’t understand how and where we (users) can ask you (developers) for the support with success.
On Launchpad the triaging process is slow, here you do not want to react, on IRC you do not react.
Where should we write our opinions and complains about this case (keyboard layout switching)?
Did you misunderstood something - we are using commercially supported Linux distribution, not bleeding edge self-breaking ArchLinux or LFS. We expect that things will be fixed here in Ubuntu or in upstream.


AskUbuntu is an resource for posting quick fixes and solutions. According to its reputation leagues 0.6 million of its users (96.3%) are newbies. Are you sure that they can fix such issues?
On AskUbuntu such questions will be marked as off-topic very likely and very fast (they will consider such questions as bug-report).

We already have my high-rated answer on AskUbuntu about current problem.
But it is a hack, and it can’t heal keyboard problems in GNOME sHell and beloved Unity.

5 Likes

Great that you found a solution, @leschinsky.

@Norbert: You are aware of the difference between support and bug fixing/development, aren’t you? The Xorg issue you highlighted higher up in this thread is a valid feature request which you have called the developers’ attention to both via bug reports and here. But please note that there are a lot of keyboard shortcut and layout switching issues which are not related to that. Often a helping hand in some support forum is sufficient. There are a lot of such questions/answers at Ask Ubuntu, for instance.

2 Likes

Unfortunately this fix only works until reboot :frowning: Currently I have to manually do this (launch CompizConfig Settings Manager and enable/disable Commands or any other feature - it reloads the top bar and the Dash, and keyboard shortcuts work after that. Another way is to run compiz --replace from Terminal - but again, this has to be done manually, I spent hours trying to make this automatic on reboot by adding to startup application or other places, but nothing seems to work - when executed from startup applications, it actually breaks the UI, there’s no header and no dash after executing this way. Why is that, any ideas? I also tried adding a shortcut to desktop, but double-clicking it on desktop has the same effect - broken UI. If, on the other hand, I run the same command by double-clicking from Files (Nautilus), it works! Why? It’s so frustrating…

Even after “fixing” it by running compiz --replace, it’s still not perfect - in WebStorm I cannot use my Alt+Shift+F7 shortcut anymore - the language switches, I guess because I pressed Alt+Shift, and F7 is ignored.

I really shouldn’t have upgraded… I need some painkillers now :wink:

1 Like

Sorry to hear that, but please understand that this is not the place to get help with the configuration of your machine.

I completely can’t understand for whom GNOME and Canonical develops / breaks GNU/Linux desktops.
Every computer for real work (not entertainment and gaming) has keyboard, the end-user uses it (with pre-installed and configured favorite shortcuts), but keyboard is broken (this thread as example).
If developers do not suppose Ubuntu to be real desktop system (to compete with RedHat or SuSe) - then it is not “The leading operating system for PCs, IoT devices, servers and the cloud | Ubuntu”, then it is OS for servers and for containers (not for end-users with GUI).
With such usability flaws I can recommend to remove and ignore GNOME (and beloved Unity too).
Currently only MATE DE can provide stable non-changing LTS user-experience without bells-and-whistles (thanks a lot, @Wimpress).

The universal remediation to fix current bug - do not use both GNOME sHell and Unity

and purge them with commands below:

sudo apt-get purge gnome-shell ubuntu-gnome-desktop \
ubuntu-desktop ubuntu-unity-desktop unity-session

sudo apt-get autoremove

but use Cinnamon, KDE, MATE (my favorite) or Xfce instead with packages from my PPA:

#Choose your favorite desktop 
#sudo apt-get install cinnamon-desktop
#sudo apt-get install kubuntu-desktop 
sudo apt-get install ubuntu-mate-desktop
#sudo apt-get instal xubuntu-desktop 

#Add my PPA
sudo add-apt-repository ppa:nrbrtx/xorg-hotkeys
sudo apt-get update
sudo apt-get dist-upgrade

#Reboot and enjoy
sudo reboot

Optionally pin (lock/hold) related packages to prevent their upgrade with:

cat <<EOF | sudo tee /etc/apt/preferences.d/pin-xorg-hotkeys
Package: *
Pin: release o=LP-PPA-nrbrtx-xorg-hotkeys
Pin-Priority: 1337
EOF

If you are not satisfied with obtained results - write a letter to Mark Shuttleworth / Xorg / GNOME / all bug-trackers / all IRCs / all LoCos / all treads of Ubuntu-Forums / Bill Gates about your problem and then execute:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:nrbrtx/xorg-hotkeys
sudo rm /etc/apt/preferences.d/pin-xorg-hotkeys
7 Likes

Thanks a lot Norbert, I’ll try MATE - I love Unity, I don’t understand why it’s discontinued, GNOME is buggy (I cannot mirror my 4K monitor to 4K TV and set scale to 200% on gnome, thankfully it works on Unity) and inefficient - both the top bar, AND current window title bar, AND the menu are displayed at the top of the screen taking way too much space there, which is a clear step backwards. I’ll report the bug on proper resources too, thank you for explanation and for trying to help. I literally wasted 10 hours yesterday, so frustrating. Спасибо :slight_smile:

1 Like

The custom keyboard shortcuts bug is in unity-settings-daemon. But very hard to reproduce. It has some connection with the bug in this thread, key press vs key release. If I downgrade xorg everything works fine.

How do you downgrade xorg? Please pretty please, I’m so annoyed by this :slight_smile: Everything else is smooth and great now, this stupid keyboard thing is the last glitch that if I fix it, I’ll be a happy Linux user once again :slight_smile:

2 Likes

Thanks! Works well:
Release Linux Mint 19 Tara 64-bit
Kernel Linux 4.15.0-36-generic x86_64
MATE 1.20.1

1 Like

Faced the same issue in Unity after upgrading from 16.04 to 18.04. Have the same question: how do I downgrade Xorg to fix this?

1 Like

Found a partial solution for GNOME but not for Unity yet.

Man, you’re a hero! I’ll buy you a beer :slight_smile:
Thanks a lot!

1 Like

What an asshole :frowning:

The bug itself and the way it is being ignored look like a huge shame of the whole Ubuntu developers community.

2 Likes