Issue with `application-create` in ams-sdk: "manifest.yaml is required" Error

Hello everyone,

I am currently working with the ams-sdk and facing an issue when trying to use the application-create example. Even when running the provided example in the SDK, I receive the following error:

Error: manifest.yaml is required

I have ensured that the manifest.yaml file exists and is located in the correct directory as specified by the documentation.

I’ve tried the following steps to troubleshoot:

  1. Double-checking the presence of the manifest.yaml file in the application directory.
  2. Ensuring the manifest.yaml file has the correct format as per the SDK documentation.
  3. Verifying the permissions of the manifest.yaml file to ensure it is readable by the SDK.

Despite these efforts, I continue to encounter the same error. It seems like the server is not recognizing the manifest.yaml file inside the uploaded application package for some reason.

This is really strange because using the UI the application is successfully created.

Has anyone else faced this issue? Any insights or suggestions on what might be going wrong or what I could try next would be greatly appreciated.


  • same error also from CLI if using an archive (zip, or tar)
  • CLI works if using a directory …

maybe there is something wrong when the archive is extracted ?

Thank you in advance for your help!

Best regards,

Hey kernelmode
Would you mind showing us the layout of the taball file, the manifest.yaml file must exist in the top level of the tarball rather than the nested under the app-folder. For instance,

$ tar tf app.tar.bz2  


oook got it the archive must be created without the folder :man_facepalming:

@gary-wzl77 my bad tnx !!!