Installing just one extension makes Ubuntu Eoan to fail

Linux users like to explore, otherwise they wouldn’t have tried a Linux distro. Now that Ubuntu’s main DE is Gnome, you just cannot demand that the user never looked in Gnome shell extensions and installed a few.

@popey, @didrocks, @3v1n0, @willcooke
Adding just one extension make Gnome 3.34 to fail in Ubuntu. I’ve been telling this for sometime. I tried it in 3 other distros with Gnome 3.34, and the gnome shell didn’t fail in them. When this extension is installed, clicking on Show Applications button makes it to fail in Ubuntu Eoan.

It doesn’t fail in Fedora 30, Arch with Gnome and OpenSuse with Gnome. Checked live and installed.

It is the Desktop Icons NG extension that gives drag and drop ability to and fro from the desktop screen to folders.

The default system desktop icons extension is useless in terms of drag and drop. (The first one is linked to Ubuntu’s system extension.) Maybe, some of our guys would say, oh we don’t need this feature, we can live without it and so on, but that is not the case for any newcomers to Ubuntu. All other Ubuntu derivatives have this feature.

It is the standard feature in Android, MacOS and Windows, after all. It was once in Ubuntu too.

In a few days, Ubuntu Eoan would be released. It would be pity to hear that it is a flawed one in outside reviews, one that cannot handle a solitary extension, when others can. There’ll be “15 things to do after installing Ubuntu Eoan” articles in the few available Linux/Ubuntu related web sites. Don’t use this extension in Ubuntu, they might say, and if you want drag and drop, choose another distro. Would not be nice to hear/see that, wouldn’t it?

It looks like the Ubuntu base can’t handle Gnome 3.34. This extension works quite well with earlier Ubuntu, for example, 19.04.

Not asking to believe me on this, just try those distros to see.

@memeplex, @frederik-f and others, I don’t want to argue on this.

(Btw, Fedora has a nice way to install it directly from the web site called Fedora Media Writer for Windows and MacOS users, which simply downloads and burns the iso to the USB stick. No hassle, at all. It even says, Once you are hooked, installing it to your hard drive is a matter of clicking a few buttons.

This sounds like you’re reporting a bug. I’d recommend reporting it as all other bugs are reported. On a system which has this problem, run the command:

ubuntu-bug gnome-shell

Login to launchpad and detail the specific steps required to reproduce the issue, what happens and what you expect to happen.