Inkscape broken due to Gnome Shell issue

Please go through this bug, where the live preview is always blocked by the options window.

Talking to Ted, the break on Ubuntu/Gnome shell is Gnome shells’ fault. He wants Inkscape to be broken to remind gnome shell developers that they need to fix it.

I am not sure whether to report it to Gnome or here. The last time I tried talking to Gnome about something, they mentioned the support period was over for the version and directed me to talk to my distro which in this case is Ubuntu 20.04 and related to Inkscape 1.0.2.

If the team can do anything, it will be very helpful for many 20.04 users.

Open GNOME Tweaks, go to Windows section and turn off “Attach Modal Dialogues”. Does that not help?


Yes, it works :+1:

Nice to know there is a fix. When I turn ON Attach Modal Dialogues, the bug comes back. So it is definitely the setting that is influencing this behaviour. Thanks. :slight_smile:

1 Like

Just checking the Inkscape source code, Ubuntu 20.04 already has the fix for that bug. That fix has been there for 2 years but I can still see a point of contention…

This appears to be a bug in Inkscape. If you never want your app window blocked by a dialog then that dialog should never be set to modal. Please open a new bug with Inkscape. Maybe it needs to just be set transient instead.

If anyone really thinks this is a bug in gnome-shell then they should report it to gnome-shell. Either way, it shouldn’t be discussed here.