Individuals are trying to upgrade from 20.04 to 22.04..? BUG

strong textUpgrade from 20.04 to 22.04 does not work.
Errors: Could not calculate the upgrade. ie. . : ‘ubuntu-bug ubuntu-release-upgrader-core’
status confirmed…# 4 individuals and my self… + 1
Questions on __
Would any one look into why the current upgrade from 20.04 to 22.04 does not work (failed)… ??
Previously reported with attached duplicate bugs…

Could this be due to the new Kernel Update on …Ubuntu 22.04 that was not included on the Upgraded for Ubuntu 20.04… Target for an upgrade ?? Any way Upgrade failed.
Could some one on the Desktop Team. look into this Bug. ?
Thank You : from all that are here for an early upgrade…To 22.04 LTS
1 Like

I have an individual that tried the upgrade to 22.04 with a
broken system… Quote: “Yes, and if I were able to revert to 20.04, that would be comforting. But I’m not. I’m stuck with a broken, half-upgraded system.”
Wow I address this question and the current bug report?
Fix the Upgrade from 20.04 t0 22.04…

It looks like this is more of a Foundations question than Desktop. I wonder if it’s possible to move the topic to Foundations?

1 Like

I hope your correct, we have 5 now 6 individuals either filing bug reports I keep linking to the original report.
Could everyone team up and fix the Upgrade together…
I will keep combining the bugs together.
I would like to thank everyone for their hard work and support and dedication for Ubuntu…!
I have so far 1 individual with an inoperable system that tried to upgrade to Ubuntu 22.04. .

Could some pull the Upgrade from 20.04 to 22.04 until it is
fixed. Please ? [ upgrade manager ]
Individual lost to a broken system…

That particular bug report looks like a classic issue that shows up in AskUbuntu frequently: Folks change their Python version. And then often forget over the years that they did so. The usual community support answer is to uninstall the PPA-supplied version of Python and revert to the version of Python provided in the Ubuntu repositories. Then apt and upgrades usually work again.

Lots of LTS-to-LTS release-upgrade failure support requests pop up during every LTS release. Is it a problem? Sure…but troubleshooting usually reveals lots of self-inflicted problems instead of fixable bugs. Generally, folks “upgraded” their stale old LTS with PPAs and Third Party Sources, some of which then break the release-upgrade.

The output posted in looks like a completely different issue to me. Uncommon, but easy enough for the gurus in the support venues to parse out and look into.


Please do not consolidate bug reports (marking ones as duplicates of others) without carefully examining the main log file and apt terminal log file. Upgrades to a new release of Ubuntu can happen for a wide variety of reasons and not every “I can’t upgrade to 22.04” is the same.

1 Like

Thank You for the information.
I will leave the bugs for the bug master.

Yes, sorry, I made the same mistake deduplicating yesterday before realising that the Foundations team was steadily examining the bug reports.

1 Like

I just finished testing the 20.04 to 22.04 upgrade.
Everything worked excellent.
Upgrade took 4 hours and 35 minutes.

1 Like

You know, folks jumping in and trying to be helpful also happens every two years, too.

Kudos for the thought (it counts!), and keep trying to be helpful.

There might be a lesson here about we-can-all-communicate-better. Or maybe how-to-harness-enthusiasm. Or maybe it’s just a good story for the next party.


That doesn’t sound right for a upgrade, even a 10 year old low end basic dual core with an old slow mechanical hard drive can do it in 30mins or less?

1 Like

does not sound wrong either. if not prepending eatmydata it can be that slow easily if you have like a lot more packages installed (say your average ubuntu install has 1500 packages) … i run a bunch with 5000 packages. and more is easily possible…

1 Like

Did you test this your self ?
I did , 2 core processor 3.6Ghz, 500 GB WD HDD.
The main factor is that the upgrade works with no errors.

We all know that there are lots of factors involved that might make a release-upgrade take longer or shorter.

Especially on lower-end hardware actions like sorting the packages, creating the locales, compiling, rebuilding assorted databases (like man-db), generating initrds for each kernel, etc. can chew up lots and lots and lots of time.

I’ve got one low-spec server upon which generating initrd takes almost 20 minutes for each kernel iteration. So 1-2 hours is not shocking…though 4+ hours does seem a bit of an outlier.

I suspect that we can all agree that’s a great way to look at it!

1 Like

I apologize for having an old slow computer,
low on RAM.

Sounds pretty quick to me! (he says, running an upgrade from focal to jammy on a Raspberry Pi with an SD card that can manage sustained throughput of 10MB/s … :–)


That would explain it, thanks

The only other time i’ve seen user comments on the upgrade taking hours was when someone was doing it via a mobile phone tethering so i did wonder if it was a throughput issue.


Glad you sorted it out and are happy with it. :slight_smile:

1 Like