HWE Kernel 5.8.0 woes

Is it possible that a new kernel version (5.8.0) was shipped recently?

I apt upgraded my machine last night and now I seem to be having some issues with the new kernel.
My wired ethernet stopped working and the Nvidia DKMS driver module won’t build with the message that the headers for 5.8.0 aren’t installed, even though I can see them when listing them with apt.

Anyone else having a similar issue? For reference, I’m running an AMD 3990X cpu on an ASRock Taichi Motherboard with an RTX 3090 gpu on Xubuntu 20.04.

I’ve tried removing the Nvidia drivers and reinstalling to trigger the building of the kernel module, but it seems to fail every time.

Dropping back to 5.4.0-59 fixes everything for now, but I’d like to get things sorted on the newer kernel if possible.

Just to confirm with above comment regarding a recent update to Kernel 5.8.0-38.45 on a 20.04 machine - I updated to this kernel and can confirm my Ethernet network failed to work, tried a restart and also following CLI command

...$ systemctl start NetworkManager-dispatcher.service

but that resulted in nothing activating or no message in CLI. I had to revert to a previously installed kernel 5.4.0-62 to get network card working normally.