How to ouput tty0 to ttyS* by default in ubuntu 17.10


After I enter OS, I can use getty to enable the console output to ttyS4

exec /sbin/getty -L 115200 ttyS4

So, I try to add /etc/init/ttyS4.conf and modify it as below, but it doesn’t work, after system reboot, I still need to execute above command to see the console in putty.

start on stonot-container or=[2345] and (
container CONTAINER=lxc or
container CONTAINER=lxc-libvirt)

stop on runlevel [!2345]

exec /sbin/getty -L 115200 ttyS4 vt102

In ubuntu 14, it should able to set console to ttyS by default, can anyone help me?

My grub file as below,

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="text console=ttyS4,115200n8 ignore_loglevel"
GRUB_CMDLINE_LINUX="console=tty0 console=ttyS4,115200n8"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_SERIAL_COMMAND="serial --speed=115200 --unit=0 --word=8 --parity=no --stop==
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I’d recommend using one of the official support channels listed on the Finding Help page.