French - Belgian Keyboard during 20.04 Server install

installed 20.04 in a VM and could not find the appropriate choice for French - Belgian during set up

I later changed the /etc/default/keyboard value
XKBLAYOUT=“be” (from “fr”)

other variables left unchanged
reboot, working fine

@jld60: It’s not clear to me what you refer to when you say “during set up”. Are you talking about the installer or couldn’t you find the Belgian layout in Settings when logged in?

Since Belgian is easily found in the installer for the hirsute daily build, I suspect that you talk about Settings and that you run into this issue:

Can you please let us know if that’s the case? If it is, please feel free to make some noise on that issue. It deserves more attention IMO.

I can add that if you generate some French locale, the Belgian keyboard layout can be selected from Settings (sorted under French).

Hi gunnarhj,
I re-installed Ubuntu 20.04 server in another new VM to go through the install process

Select language English (UK)
Continue without updating
Keyboard Layout
this time I was a little bit more cautious looking and found Belgian ,
but when using [identify kb] and answering questions it reset KB selection to French
so I passed this [identify kb] after reselecting Belgian/Belgian
But/nevertheless afterwards still had a non be/be keyboard setting during therest of install
After reboot keyboard mapping was ok
I checked content of /etc/default/keyboard and it was set as above.

Ok. I assumed a desktop, since this thread is in the Desktop category. My theory above is not applicable then, of course.

I think you should either file a bug about the server installer, or start a new thread here in the Server category.

P.S. Installers and keyboard layout selection seems to be a fragile area at the moment. As late as yesterday I reopened a similar bug which applies to the desktop installer. :frowning:

Moved this desktop thread hijack to a separate thread in the Support area.