Foundations Team Updates - Thursday 21 July 2022

See also last week - Foundations Team Updates - Thursday 14 July 2022

1 Like
  • subiquity
    • PR: 1353 - cherry-pick fixes for autoinstall and debug shell issues LP: #1974077, LP: #1975629
    • PR: 1354 - fix partition numbering on logical partitions, and some semi-related unit test improvements. Expose information on a gap being usable (or not).
    • PR: 1355 - ubuntu-daily:impish is no longer an image, so this test target must go. :wave:
    • PR: 1356 - add endpoint to view the unmodified storage configuration. For now all that is needed was original partition, but this seemed possibly useful.
    • PR: 1358 / LP: #1978890 - add warning for 3rd party drivers about FIPS and RT kernel.
    • PR: 1363 - fix issue with Guided Reformat offering disks that are too small as possible install targets
    • (no PR yet) - use selected language to pick a better default keyboard and variant
    • Specification reviews
    • Review PR: 1347, 1351, 1352, 1357, 1359, 1360, 1362
  • ubuntu-desktop-installer
    • Help debug issues with usage of guided resize, and kernel installation. Subiquity assumes linux-generic but that’s not the correct default kernel for Desktop.
    • Review PR: 1010, 1021
  • netplan
    • Review PR: 286
  • pygments
    • look at autopkgtest results for pygments, mercurial, snakemake, and conclude that all needed retest for different reasons. Migrated.
  • +1 - working on ffmpeg 5 transition
1 Like

short week (was off last Thursday and Friday).

subiquity / curtin

  • working on making more calls of curtin where each invocation has a specific purpose (i.e. partitioning, source copy, curthooks…).
  • opened draft PR 1362 to reduce number of states reported to the client. This effectively removes the POST_WAIT & POST_RUNNING states. This impacts Subiquity itself but also WSL and ubuntu-desktop-installer ; so requires thorough testing.
  • investigating the possibility to drop more states (e.g., UU_RUNNING & UU_CANCELLING)
  • reviewed potential fixes for running setxkbmap for the desktop installer
  • created spec document for executing hook scripts at the end of a Subiquity install. This is meant to give the desktop installer the opportunity to run commands that have no builtin implementation in subiquity.


  • opened MIR LP: #1980968 for libregexp-wildcards-perl (needed for lintian). Got feedback from MIR team and now assessing if libregexp-shellish-perl would be a better candidate.
1 Like
  • Latest image available here for the VisionFive:

  • Latest image available here for the Nezha:

  • PR to add wpasupplicant to the server seed for riscv

  • PR to ubuntu-manual-tests

  • Kernels for 22.04.1 will unlikely support GPIO_CDEV_V1 so worked on gpiod for the API v2

  • livecd-rootfs sometimes fails to unmount a filesystem and then fails the image build: investigating this issue

  • Slow graphics on the VisionFive: I found a workaround to make XFCE4 work quite well which consists in not using kms_swrast DRI driver and not using xfwm4 window manager (openbox works well). Still investigating why we have slow graphics and why the above workaround works.

  • Tutorials for installing the images

  • Working on the RISC-V download page

1 Like




  • some roadmap/sprint sessions
1 Like


  • LP 1981042 “/etc/localtime symlink not correctly handled when using /etc/writable”

    • Prepped patches for kinetic and jammy
  • LP 1979951 “ removed from loopback interface if you configure extra IPs on lo”

    • Prepped patch for jammy (fix already present in kinetic)
  • LP 1981431 “systemd-resolved: DNSSEC validation failed: incompatible-server”

    • I took another look at this in preparation of a Jammy SRU, but I missed the fact that we do actually have the suggested patch in Jammy. Followed up with the reporter to get more information.
  • LP 1975667 “systemd-resolved does not reset DNS server and search domain list properly after VPN disconnect”

    • Prepped patch for jammy (fix already present in kinetic)
  • Investigated LP 1981622 “mtd device must be supplied (device name is empty)”

    • The recent systemd SRU for jammy introduced this with d990b13612810a296246011ad66a165b30166702. Although I believe the issue is benign, it is causing head aches for users, and is a red herring for users experiencing boot issues.
  • Addressed review comments, and pushed a new version of my ManagedOOMPreference expansion PR.

remainder of last week’s +1

  • python-llfuse autopkgtest regression on armhf (LP 1981741)

    • This was caused by a 32-bit integer overflow in one of the tests. I changed the offending test value to fit in 32-bit, and forwarded the patch upstream.
  • ocrad autopkgtest regressions (LP 1981846)

    • The autopkgtest failures are due to undefined references to symbols in libpng. This package’s autopkgtest is a bit odd because it compiles a new binary called ocradcheck, and uses that to perform the tests. I tried to quick-fix the build in the autopkgtest, but predictably hit other issues. I wasn’t able to push this one over the line, but it seems like the best course would be for this package to have an additional binary package (ocrad-test or ocradcheck) to be used in autopkgtest (I suggested this on
  • Full +1 report:

1 Like

The Ubuntu QA Team’s status can be found here:

1 Like

swtpm (LP #1955114)

  • With release 0.7.1 Debian has followed the upstream packaging into more packages. So for Kinetics the solution is to adopt the new Debian package version.
  • The problem obviously only occurs if installation of the Jammy package is a downgrade from another installation.

Test environment for DPDK, Open vSwitch, SPDK in virtual machines

  • QEMU 7.0 is not available in KInetic
    • Providing an NVMe drive from a Linux 5.19 RISC-V virtual machine with Ubuntu’s QEMU 7.0 to an Ubuntu Kinetic VM leads to a lot of IO timeout errors as shown in the system log. The same does not occur if the QEMU 7.0 is used on x86 to launch a RISC-V virtual machine (without using KVM).
  • Except for the NVMe issue no problems occur running the test scenario.
  • Next steps: Consolidate the different script files into something easily executable.
1 Like



1 Like
  • Working on verification of raspi-config SRU (LP: #1972982)
  • Proposed new ubuntu-settings version to (partially) fix the zswap issue (LP: #1977764)
  • … and proposed a merge to fix the rest of it
  • Gathered some info for Firefox upstream on Pi graphics issue
  • Rebased the merge proposals for the linux-firmware-raspi rename in the respective seeds (jammy and kinetic)
  • Working on bumping lg-gpio packaging to for kinetic (to handle gpiochip API v2 changes); test builds in my lg PPA
  • Worked on missing user groups on the Ubuntu Desktop for Raspberry Pi images (LP: #1923363), targetted for the upcoming point release
  • piwheels discussions
  • Pi meetings
1 Like


I spend most of my time working on Apport. I fixed all autopkgtest failures on armhf and s390x and uploaded apport 2.22.0-0ubuntu4 to kinetic. Then I started working on the SRUs for jammy and focal which meant cherry-picking several changes for the tests to make autopkgtest succeed. The current status is that the SRU for jammy builds and autopkgtest succeeds for all archs except armhf. The armhf autopkgtests are run inside LXC containers and they revealed a problem with Apport (LP: #1982487).

1 Like

Archive Administration

  • Various rounds of NEW package processing, primarily of Debian syncs


  • Triggered rebuilds of ffmpeg reverse-dependencies for new ABIs, to make ffmpeg migratable (with passing tests of reverse-dependencies). This then moved a whole bunch of packages onto the NBS problem list, due to build failures as ffmpeg 5.0 introduces some significant API changes (dropping interfaces that were marked as deprecated for quite a while).
  • aiscm: uploaded, patch forwarded to However, this fix was incomplete so it’s still stuck in -proposed.
  • alsa-plugins: the ffmpeg-dependent alsa plugins were split into a separate source package a decade ago to let ffmpeg be demoted to universe. This rationale hasn’t applied now for many years, and alsa-plugins-extra was not being kept up-to-date. Merged this back into alsa-plugins, fixing the build failure, and added upgrade handling. alsa-plugins itself has been demoted to universe in kinetic so I just merged this directly into the same binary package.
  • audacity: this seems to be fixed upstream but can’t be cherry-picked, distro patches don’t apply cleanly, and there have been questions about audacity adding phone-home code so I don’t want to get involved in packaging a new upstream version. I have a partial patch here but am parking it for now, this might get removed from kinetic until Debian can look at it.
  • blender: was blocked by lack of armhf build. Looking at this in Debian, upstream has regressed 32-bit support and the package has been removed from testing; removed the armhf binary which let this migrate.
  • casparcg-server: package is in multiverse, no maintainer upload in Debian for years, and multiple ftbfs fixes carried as patches in Debian so arguably not a good investment of my time to fix this, but it was fairly easy to port so I wound up uploading and forwarding a patch to
  • ccextractor: non-trivial port, no reverse-depends, so removed from kinetic. Hopefully will make it back via Debian before release.
  • cloudcompare: not ported upstream, but a fairly easy port. Uploaded, forwarded to


  • Driving spec for socket-based activation of openssh to completion
  • Attending Product mid-cycle review this week
1 Like