Firefox Snap missing media controls in GNOME notification area

I noticed that Firefox is missing the media controls in GNOME notification area, but Firefox deb version has it and Chromium snap version as well. Would this be a bug that would be submitted in launchpad.net or snapcraft.io?



(Your post title has “Span” instead of “Snap”.)

Since Mozilla maintains the Firefox snap, http://bugzilla.mozilla.org/?

Thanks I just corrected it.

Looks like the firefox snap doesn’t specify the mpris interface. When filing the bug you likely need to mention this. Chromium does specify the interface.

2 Likes

What @popey wrote. For reference: the chromium bug that tracked the addition of the mpris slot.
When you file an upstream bug, please share the link to it here. Thanks!

1 Like

Here is the bug.

4 Likes

Thanks for the bug report. I submitted a patch upstream, which I confirmed to work locally.

3 Likes

Thank you very much for patching this. I am really on a quest to run all my daily apps as snaps (FF, Thunderbird, Chromium, and VLC), and I do that already and love it.

5 Likes

Me too!
Switched thunderbird already since some weeks and it works flaweslessly.
Only firefox issue i’ve found is this one here :slight_smile:
Numner of debs I use is shrinking constantly

1 Like

I got a lot of snap-only apps (FF, TB, LO, VLC, …) since some reasonable time now.

A lot of small bugs have still to be solved (I reported some of them, but not all!). Example in FF: launch a Jupyter notebook => FF cannot open the local file, you have to Ctrl-click on http://localhost/:wink: . The problem is that some issues seem to be unavoidable from the snap confinement point of view. Example: open FF and another FF window => very choppy scrolling (reported). Example: open LO and try to email your document from LO menu => you just get the file title in email subject. An so on.

Common snaps are way better than before but not perfect from the basic user side compared to deb versions. The startup delay is way better than before too, but may vary. I recently measured, in French Ubuntu forum, some cold starts (Ubuntu Focal, i7 8th gen., SSD NVMe):
firefox 4,387s
chromium 1,111s
thunderbird 6,475s

2 Likes

I added one more snap last night after finding out Brave browser was back in the snap store this time officially.

1 Like

If I may suggest, even if it is a small bug I would submit it, so that the developers are aware. This bug with media controls, has been fixed now and will land in FF 85!

As far as I read about, Snap is not officially supported by Brave.
https://community.brave.com/t/brave-snap-package/42459
Do you have any update?

Few months ago it stated to use the website when you tried to install Brave snap version, but that must have change as now it is actual up-to-date build and the developer is states a Brave themselves.