Dropbear-initramfs in Ubuntu Server 18.04.1

Hi everyone,

I’m trying to setup a dedicated server with an encrypted drive, I’ve found some help online to get that up and runnning but I’m running in some troubles getting dropbear-initramfs to start properly. (tutorial along those lines https://hamy.io/post/0005/remote-unlocking-of-luks-encrypted-root-in-ubuntu-debian/)

So I install the dropbear-initramfs package and get an error that the keys are missing and it won’t work. I add the authorized_keys I configure dropbear to run on a different port and i update initramfs but at boot dropbear doesn’t start and I just get prompted the normal username/password. I’ve tried a couple of things to get that up and running, I tried to dpkg reconfigure the package once the keys are setup properly and I don’t get an error message anymore but dropbear still doesn’t start.

If anyone has any pointer that would be very appreciated :slight_smile:

Best regards

I’ve moved this to the https://community.ubuntu.com/c/support-help-requests category because this site isn’t designed to take tech support questions. Sorry. I’d recommend using one of the official support channels listed on the https://community.ubuntu.com/t/finding-help/712 page.