Desktop Team Update - Monday 21st October 2019

Hi everyone, below you will find the updates from the Desktop team from the last week.

If you’re interested in discussing a topic please start a thread in the Desktop area of Discourse.
We also have our weekly meeting on IRC. We meet on Tuesday at 13:30 UTC in #ubuntu-desktop on Freenode. There will be an “Any Other Business” section at the end where you are welcome to raise topics. These topics might be discussed during the meeting, or afterwards depending on the time, depth of conversation, topic and so on.

Last week’s notes are here: Desktop Team Update - Monday 14th October 2019
Next week’s notes are here: Desktop Team Updates - Monday 28th October 2019

:computer_mouse: Gnome Shell:

:beetle: Release bugs:

:chart_with_downwards_trend: Backlog tracking


libreoffice24-margin libreoffice

GNOME build/plaform-snap

:clipboard: other


Short week (3 days):

1 Like
  • Hyper-V image
    • Worked on 19.10 image, should be sending it to Microsoft this week
  • GNOME build/plaform-snap
    • Helped some gnome-3-34-1804-sdk build issues
  • Debugging reports of the drawing snap crashing, determined it’s common amongst snaps using gnome-3-32-1804 and handed it off to @marcustomlinson
  • USN snap refreshes
  • Reviewed and tested snapcraft and gnome-3-32-1804 PRs to handle snaps using gjs from the platform
1 Like

Off Monday for a holiday but here’s what I spent the rest of the week on:


firefox24 firefox

thunderbird24 thunderbird

  • created a focal branch for thunderbird
  • with upstream’s help, figured out a fix for the regression where external hunspell dictionaries were not being loaded, and uploaded to focal
  • filed bug #1849162 to track the inclusion of lightning in the thunderbird package

chromium22 chromium

  • updated stable to 77.0.3865.120
  • read and answered James’s questions on the discussion about exposing desktop files created by snaps to the DE
  • confirmed and fixed bug #1848080 (missing --temp-profile option)
  • confirmed and fixed bug #1848083 (core dump running chromium --help)
  • wrote on the snapcraft forum to document the requirements to ship man and local man pages in a strictly confined snap
  • tested whether the chromium-browser transitional package in eoan could be made “architecture: all”: the upgrade path works but on unsupported architectures (ppc64el and s390x) a new installation times out after 30min and fails − not a good user experience
  • opened and closed the stable/ubuntu-20.04 channel, and invited Ken to collaborate on the snap
  • updated beta to 78.0.3904.63
  • updating dev to 79.0.3941.4 (there are Widevine changes that require reworking the patches)

libreoffice24-margin libreoffice

  • sponsored 1:6.2.8-0ubuntu0.19.04.1 for Marcus

snapcraft24 snaps

  • Was in London for the week, in the Release Room Of Power
    • We broke the release trying to fix a bug, and then fixed it on release day - which is not ideal.
      • I’m not sure if racy is the right way to describe the problems that resulted or if we just broke some assumptions (deleting /etc/machine-id makes systemd assume that it’s running in first boot mode which might be relevant). It’d be good to understand exactly why things broke the way they did.
      • Also note that the zero-length machine ID (the initial state) is correct to have. We were working around some kind of kernel bug in the first place.
    • Did pair programming with xnox that resulted in a fix to ubiquity to fix some very specific breakage (packages with multiarch relationships on the ISO that weren’t completely satisfied on the ISO i.e. nvidia was missing its :i386 recommends)
      • That was belt and braces for a fix to debian-cd (and subsequent commits) to manually (!!! the real fix is in germinate and other places to support cross-arch relationships) pull in the needed i386 packages for nvidia onto the ISO.
  • Helped out with archive opening - given that we got a name on time we could start opening pretty much immediately.
  • autopkgtest:
    • Some massaging required today; the cloud was not very stable due to the massive load caused by the perl upload.
    • Worked a bit on the new staging environment. Required some firewall changes in the backend. One region is still broken but I’ve got a ticket with IS to get that fixed.
  • Google Summer of Code 2019: Attended the Mentor Summit in Munich.Met with many other mentors and org admins, exchanged experience, presented OpenPrinting’s success with GSoC in a lightning talk and held a discussion session about the future work of OpenPrinting, received invitation to EuroBSDCon conference in Vienna in Sep 2020.
  • Google Code-In 2019: Completed the mentoring org application, lined up sample tasks, proofreading.
  • Catch up with e-mail after vacation and GSoC Mentor Summit
  • cups-filters: Checked progress on debugging of cups-browsed for legacy IPP/CUPS printers (Upstream issues #124, #163, and #167).
  • Bugs.
1 Like

Most week in discussions for technical and design aspects at the GNOME Shell Hackfest, plus…

  • Written reports and issues based on the hackfest results
  • Review and proposed a change on Daniels’ mutter !575
  • Opened various design issues, including Shell commands palette [issue]
  • Shell search code cleanups [MR, merged]
  • Merged the big boy refactor branch [MR, merged]
  • Shell refactor, use GLib.DateTime everywhere [MR]
  • Merged mutter and shell changes to remove deprecated APIs [MR, merged]
  • Merged mutter branch to avoid sending key-focus events to destroyed actors [MR, merged]
  • Some work to improve the windows search to show designers
  • One day off
  • Joined the gnome-shell hackfest which was great!
  • 19.10 ISO testing
  • Update our gsettings override to drop the compromised sks server (following upstream gcr)
  • Backported a fix from Robert for the background settings segfautling
  • Sponsored again the pulseaudio/bionic SRU (with fixed changelog to remove extra bug reference)
  • Debugged a bit a tracker segfault with upstream
  • Reuploaded the unity-control-center version which was made to use their own schemas, that was supposed to have landed but the billeto copy failed without error
  • Errors and launchpad bugs triaging, looked at the post release feedback online