Creating Images on Ubuntu Core Raspberry Pi 3?

Hey everyone! I’m new to the Ubuntu Core system. I have been working on developing a project using the Raspberry Pi 3 and Ubuntu Core 16 with ROS Kinetic installed. I just wanted to test creating an image. Tried using this tutorial…
https://docs.ubuntu.com/core/en/guides/build-device/image-building

Talks about how to use the ubuntu-image tool to create the image. When I run snap install --beta --devmode ubuntu-image I get this error…

error: snap “ubuntu-image” is not available on beta for this architecture (armhf) but exists on
other architectures (amd64, i386).

Can someone tell me what is going on please? I would assume this should work because Core does say it supports raspberry pi and I haven’t done anything funny to my Pi yet. I did install snap classic environment but I believe I’m supposed to be in that environment anyways. I tried typing sudo before the command to install ubuntu-image but same error.

Thanks in advance!

You’re seeing that error because the ubuntu-image tool is not packaged for the Raspberry Pi’s armhf architecture. It’s meant to be used to create an Ubuntu Core image on a desktop machine so it’s packaged for those.

The typical workflow is to use ubuntu-image on your desktop machine to create an Ubuntu Core image for the Raspberry Pi (or whatever your target device) and to use dd to copy that image to an SD card or USB drive and boot from it.

As a side note, this sort of question is probably best sent to the Snapcraft forum where experts on all things Ubuntu Core/Snapcraft can be found.