Cosmic Cuttlefish (18.10) RC Testing

Hi testers,

As Adam announced on ubuntu-devel-announce Cosmic as entered Final Freeze.

Ubuntu 18.10 (aka Cosmic Cuittlefish) and its flavours are going to be released this week (Oct. 18th) and now is a good time to test the ISOs to make sure that installation and core functionalities are working correctly.

Never tested an image before? Checkout the information on the wiki. You can sharpen your skills right now by testing the daily image. If you encounter any issues please don’t hesitate to ask. Don’t forget, you can talk in realtime on IRC on freenode @ #ubuntu-quality.

RC images are availalable on the ISO Tracker. Synchronize your ISOs, test, report results, rince, wash, repeat until it’s ready to release.

Testing on VMs is great but if you have spare hardware or a free partition, testing on hardware is a great source of information.

Happy testing!

1 Like

Got the daily image yesterday and testing it out currently. So far so good. I will submit any bugs I run into.

I am using the Cosmic base with other DEs (Unity, Kubuntu and DDE) and with only a WM. Works quite well.

Would use the next 19.04 base as soon as it appears (~ November 8th), whatever its name.

RC builds started popping on the Cosmic Final milestone page on the ISO tracker. These builds are not final. We’re still waiting on a few more fixes, a few things to migrate, etc. The Release Team has intentionally not updated base-files or the ISO labels to reflect the release status (so please don’t file bugs about those).

What there are, however, are “close enough” for people to be testing in anger, filing bugs, fixing bugs, iterating image builds, and testing all over again. So, please, don’t wait until Wednesday night to test, testing just before release is TOO LATE to get anything fixed. Get out there, grab your favourite ISO, beat it up, report bugs, escalate bugs, get things fixed, respin (if you’re a flavour lead with access), and test, test… And test.

1 Like

Great to hear, thanks for your help.

Maybe, you should write here ( too for someone to react. That testing bed is pretty silent for sometime.

New images (20181017) are available on the ISO tracker and ready for testing.

Main fixes on this image are:

  • bug 1794280: gdm which didn’t always start on boot.
  • bug 1796260 which resulted in non-bootable machine when doing an UEFI installation alongside a BIOS installation.
  • bug 1797579: ubiquity removes packages for non-en_US english locales.
  • bug 1798005: a ubiquity crash during installation.

Time to sync your images and test it.

One last image has been published. It contains a single fix of gnome-initial-setup 3.30.0-1ubuntu3 to populate featured snaps from ubuntu-firstrun category.

It doesn’t invalidate previous runs and smoke testing the images to ensure nothing broke is enough. Of course gnome-initial-setup fix must also be verified.

We’re almost there and in good shape for a release tomorrow.

1 Like

Been running the beta since late late September and keeping up with updates daily.

It’s been working fine, until Oct 16 (it may have been an update on Oct 15 and I noticed it later).

This is a 3rd gen Ivy Bridge quad i7. kidle_inject is constantly running.

It boots up fine, actually. But as soon as anything makes the CPU spike, kidle_inject starts doing its thing and it just won’t stop.

Even after 1 hour of idling, with low temperatures, no fan, it’s still making this computer unresponsive.

I decided to run with intel_pstate=disable. cpupower says it worked:

analyzing CPU 0:
  driver: acpi-cpufreq

But it still behaves the same way. As soon as I do anything that uses the CPU even for a bit, kidle_inject turns the session unusable.

I know that thermald is running. I may try to disable it and try again.

Also, dmesg extract:

[36758.642634] powercap intel-rapl:0: package locked by BIOS, monitoring only
[36762.646567] intel_powerclamp: Start idle injection to reduce power
[36766.778858] CPU5: Core temperature above threshold, cpu clock throttled (total events = 1)
[36766.778859] CPU1: Core temperature above threshold, cpu clock throttled (total events = 1)
[36766.778861] CPU0: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.778863] CPU3: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.778865] CPU6: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.778866] CPU4: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.778870] CPU7: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.778871] CPU2: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.778872] CPU1: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.778880] CPU5: Package temperature above threshold, cpu clock throttled (total events = 1)
[36766.779858] CPU5: Core temperature/speed normal
[36766.779859] CPU1: Core temperature/speed normal
[36766.779861] CPU2: Package temperature/speed normal
[36766.779862] CPU6: Package temperature/speed normal
[36766.779864] CPU7: Package temperature/speed normal
[36766.779865] CPU3: Package temperature/speed normal
[36766.779867] CPU0: Package temperature/speed normal
[36766.779868] CPU4: Package temperature/speed normal
[36766.779868] CPU1: Package temperature/speed normal
[36766.779870] CPU5: Package temperature/speed normal

all this while intel_pstate is supposedly disabled.

P.S. Funny that my blocks are interpreted as SQL by Discourse.

– nachokb

1 Like

@jibel What about this nasty bug which affects 32 bit installs -

@flocculant, unfortunately we don’t have a fix for this bug yet, and it will be a regular system update as soon as a fix is ready.

@nachokb Thanks for reporting this issue. Did you file a bug report on launchpad? If not could you submit one with the command ubuntu-bug linux then the kernel team can have a look.


1 Like

So … We will have a respin of all the images to fix a major issue on some firmware implementations which prevent the system from booting when secure boot is enabled and third party drivers are installed.

I’ll keep you posted once new images are ready to test … stay tuned, the release of Cosmic has never been closer :slight_smile:


Images have been produced during the night and are ready to test. hopefully it’ll be the last one.
Go, go, go testers ! Last run before the release.

1 Like

We (the release team) are trying to determine the scope of bug 1798562 which happens during a side by side installation of Cosmic.

Currently we’ve only been able to reproduce on Cosmic along an existing Cosmic installation. Is anyone able to reproduce with Cosmic alongside something else than Cosmic, for example an earlier release of Ubuntu or a flavour or another distribution or operating system (eg Fedora, Debian, Windows, …) ?

Ubuntu 18.10 and its flavours have been released and I would like to thank everyone who helped testing this release and made it great again!

So THANK YOU TESTERS, it’s been lot of fun and I wish to see you all and even for for next release!


Hear, hear!

And thanks @jibel for heading up the testing.

1 Like


I have the exact same behavior as @nachokb described. I disabled kidle_inject process by creating a file /etc/modprobe.d/blacklist-power.conf with the following content:

blacklist intel_powerclamp
blacklist intel_rapl

Then I restarted computer. Since then, my computer is not unresponsive anymore, and I use it to work all the time.

I opened this bug report.

1 Like

I ran into the same thermal throttling issue after updating. apt remove thermald fixed it for now.

1 Like