Computer will not boot after trying to install Ubuntu Desktop

Hello, this is my first time trying to install Ubuntu onto my laptop. I am trying to install onto my Xiaomi Mi Notebook pro, which has 2 NVME SSDs. One 256gb drive already has windows on it. The other 512gb drive is what I am trying to install Ubuntu desktop onto.

I tried several times to install it, but would always get some error, or one time the installation took over three hours, so I decided to turn it off and try again later. The most recent attempt to install ended with an error that said something along the lines of

the ext4 file system creation in partition failed

Trying to troubleshoot that, I came across a post that recommended I format the drive by running Ubuntu of the ISO drive and using the disc management tool on Ubuntu. When I did that (selecting the “delete all data on drive” option), the process took a while until there was an error pop up that said there was some error deleting the data on that drive. I didn’t look super closely at it before closing the notification window, and then the disc management window didn’t show my 512gb drive anymore.

I thought I would try to restart the computer to see if the drive reappeared, but now the computer will not boot past the “MI” logo screen (the one from the company). I turned it off, unplugged the USB, then tried to start the computer to go back into windows. Same problem. I tried to press the keys to get into the BIOS settings while on the “MI” screen (how I normally get into the boot settings), but I cannot get into the boot menu either.

I haven’t been able to find a post with a problem similar to this, but I will continue looking. Thank you for any and all help, I’m just a college student trying to fix his laptop during finals week.

1 Like

This site is for the co-ordination of the Ubuntu project(s), and not support.

For Ubuntu Support options, please have a look at

Oh, sorry, I misunderstood this forum then

If you find a way, please let us know. Hope you’d succeed.

I too have a 2 in 1 of a different brand with Windows 10 on the main disk and an additional M2, where I was debating, whether to try to install Ubuntu. Good that I never tried that. Didn’t brick a perfectly correctly working device.