Chromium open file dialog

Gents, et al:

Haven’t read through most of the posts here, but I did post on Lubuntu-developer list serve about a “problem I was having in Lu 20.04 getting the open file dialogue window to show contents of the Downloads directory so that I could upload a photo, but could not,” . . . and I got a reply from guiverc?? suggesting it was a “snap thang” . . . he gave me some options and I tried them, but nothing got around the issue. And, it isn’t only in Chromium, I found the problem in Gdebi when I was trying to install the Chromium .deb file as a work-around the “snap tags along when using the Software Center” . . . problem.

It seems like one of the basic features of linux is “open-ness” to everything, and in this case I can’t open a file in my Home files and upload it to the web?? Not ideal. I’m also running U-MATE 20.04 and OpenSUSE TW and found this problem in all three of those systems. I had to boot to an OSX partition to get the job done, a simple job, a job that linux should have handled . . . but, um, could not . . . ??? Thnx for listening.

1 Like

That’s a lot of words. Any chance you can boil it down to a short set of steps, so someone else can reproduce this?

  1. Install foo
  2. Add bar
  3. Click x
  4. Choose y

That kind of thing.

1 Like


This post was posted over on the “testing chromium-browser deb to snap transition” thread, which I guess wasn’t clear that I was reporting on my experience with using Chromium browser to try to upload some photos from my user Downloads directory, and the “open file” dialog window would show the “home” contents, but clicking or selecting the Downloads would show an empty page . . . could not upload obviously. But, it not only affected Chromium, but also Gdebi . . . trying to “open file” would show an empty page.

I posted the situation to Lu Devs page and got a reply saying this was due to “snap” . . . and there were some suggestions to try to work around the problem, I tried them, they didn’t work, I spent a far amount of time trying to get Chromium to upload a photo, but nothing worked. The lead guy at the Lu devs linked me to the “testing chromium-browser” thread, I posted “a lot of words” there . . . it was professionally analyzed and considered “passive-aggressive syndrome” . . . . However, even if that diagnosis is correct, it seems like using snap to “sandbox” personal desktop files is . . . how to say this . . . “not the linux philosophy of open-ness”??? Is that problematic to the devs to hear and process? Seems like it is, but I wasn’t naming names, as I don’t have any . . . just giving a “no” vote to moving from .deb to snap as detrimental to user work flow and functionality . . . .

Basically, the issue is this bug.


Oh wow, that’s old. Looks like it’s actually this one.

1 Like

Alrighty, yes it does look similar . . . seems to just be working its way down to end users such as myself running Lu & U-MATE 20.04 . . . with wxl’s comments I’m starting to get some “understanding” of the problem, but one of the frustrations is that it doesn’t seem to ID the /user/Downloads directory as something like “snap/user/Downloads” . . . so there might be some “clue” about why my files aren’t showing up in what appears to be my home Downloads folder . . . ???

Old, yes, but still relevant, no? Seems to provide a rather poor user experience, especially to someone who doesn’t understand Snap’s sandboxing scheme.

1 Like

I wasn’t saying it’s relevant or not, just that it’s aged well. Yes, it’s clearly a problem, and it would be great if it was fixed. Perhaps continue the conversation on the bug?

1 Like

I think I added a comment on the wxl linked bug, but it does seem like there is more than one bug on this situation??? I flushed a fair amount of time trying to do what I had done possibly a month or two before, i.e., upload a photo to IG via Chromium, had worked well, then this time I’m faced with a “blank” “Downloads” folder . . . and then same thing happened in Gdebi . . . . Haven’t had time to go through all apps, but it created “resistance” to what should be “routine” . . . . Accessing one’s own files in one’s own system shouldn’t need “security” . . . but preventing someone else from accessing said files, OK, I get it.

The only problem is the conversation seems stalled there. The reason @este-el-paz started this on the other thread was to provide feedback regarding the subject at hand: the transition to having Snap-only Chromium. It’s not really a support question or off-topic, but is entirely relevant right there. I would consider this a blocker to doing Snap-only Chromium if it were my choice.

1 Like

The relevant people have been poked.


If no one ever tells you how awesome you are, I just want to let you know that you rock. :slight_smile:

1 Like

Thanks for the poking . . . precerate that . . . .