Bandwidth only 100Mb/s in LXD container

Hi,
I changed it as in documentation:
lxc config device override f3-FTP-ITConnection eth0 limits.egress=190Mbit limits.ingress=660Mbit
later by:
lxc config device set f3-FTP-ITConnection eth0 limits.egress=198Mbit limits.ingress=660Mbit
and the problem is conatiner has suddenly egress speed only 100Mb/s :frowning:

I even removed that parameters by:
lxc config device unset f3-FTP-ITConnection eth0 limits.ingress
lxc config device unset f3-FTP-ITConnection eth0 limits.egress
but still nothing.

Current config on that container is following:
root@ds2:~# lxc config show -e f3-FTP-ITConnection
architecture: x86_64
config:
image.architecture: amd64
image.description: Centos 9-Stream amd64 (20240125_07:08)
image.os: Centos
image.release: 9-Stream
image.serial: “20240125_07:08”
image.type: squashfs
image.variant: default
limits.memory: 2048MB
volatile.base_image: 25e8ca53aeeee7c9db0ad4fbc9a590f50e4f6378b7d04f0b8fb629d1a303a404
volatile.cloud-init.instance-id: f91d2e16-1054-42ac-979f-245397509773
volatile.eth0.host_name: vethfb48afc7
volatile.eth0.hwaddr: 00:16:3e:88:43:7d
volatile.idmap.base: “0”
volatile.idmap.current: ‘[{“Isuid”:true,“Isgid”:false,“Hostid”:1000000,“Nsid”:0,“Maprange”:1000000000},{“Isuid”:false,“Isgid”:true,“Hostid”:1000000,“Nsid”:0,“Maprange”:1000000000}]’
volatile.idmap.next: ‘[{“Isuid”:true,“Isgid”:false,“Hostid”:1000000,“Nsid”:0,“Maprange”:1000000000},{“Isuid”:false,“Isgid”:true,“Hostid”:1000000,“Nsid”:0,“Maprange”:1000000000}]’
volatile.last_state.idmap: ‘[{“Isuid”:true,“Isgid”:false,“Hostid”:1000000,“Nsid”:0,“Maprange”:1000000000},{“Isuid”:false,“Isgid”:true,“Hostid”:1000000,“Nsid”:0,“Maprange”:1000000000}]’
volatile.last_state.power: RUNNING
volatile.uuid: fcfed189-096b-438e-bf57-82c05e624745
volatile.uuid.generation: fcfed189-096b-438e-bf57-82c05e624745
devices:
eth0:
name: eth0
network: lxdbr0
type: nic
root:
path: /
pool: lxdpool
size: 4400GB
type: disk
ephemeral: false
profiles:

  • default
    stateful: false
    description: “”
    root@ds2:~#

Please advise how to fix back egress speed to full ?

Let me mention also that in dmesg on mother server there are these logs:

Fri Mar 29 00:14:28 2024] veth222ca83d: renamed from physwHiCM3
[Fri Mar 29 00:14:28 2024] device veth9cd1ccac left promiscuous mode
[Fri Mar 29 00:14:28 2024] lxdbr0: port 5(veth9cd1ccac) entered disabled state
[Fri Mar 29 00:20:13 2024] HTB: quantum of class 10010 is big. Consider r2q change.
[Fri Mar 29 04:32:11 2024] perf: interrupt took too long (2511 > 2500), lowering kernel.perf_event_max_sample_rate to 79500
[Fri Mar 29 07:51:34 2024] perf: interrupt took too long (3157 > 3138), lowering kernel.perf_event_max_sample_rate to 63250
[Fri Mar 29 10:52:40 2024] perf: interrupt took too long (3952 > 3946), lowering kernel.perf_event_max_sample_rate to 50500
[Fri Mar 29 15:38:39 2024] perf: interrupt took too long (4951 > 4940), lowering kernel.perf_event_max_sample_rate to 40250
[Fri Mar 29 19:53:12 2024] HTB: quantum of class 10010 is big. Consider r2q change.
[Fri Mar 29 23:14:59 2024] HTB: quantum of class 10010 is big. Consider r2q change.
[Sat Mar 30 09:15:17 2024] perf: interrupt took too long (6189 > 6188), lowering kernel.perf_event_max_sample_rate to 32250
[Sat Mar 30 18:48:55 2024] HTB: quantum of class 10010 is big. Consider r2q change.

I don’t if they are important for my case by the way.

Please try to replicate that situation at your side.
From container which I haven’t touched goes about 250Mb/s but from that where I set up ingress and egress values - only 100Mb/s.

I tested bad. Looks like LXD is ok, from other place I got about 200Mb/s from that container so all is ok with it so I’m closing the case.
Thank you.

2 Likes