Armitage setup error

Im a bit new to ubuntu but im loving the hell out of it. I tried installing armitage on my ubuntu 18.40 desktop, but each time i ran it i always gor thos error massage…kKS4LFB

i remeber seeing this error on kali linux but it was solvable with a simple msfdb init command like the pop-up said, but in the case of ubuntu…ive checked every where and i mean EVERY WHERE for the solution…but i guess other ubuntu users have more luck than me installing and using the software. but i found the write up by a guy on linux mint community about this error, whil it was detailed, it didn’t really solve the problem so i kept looking then i found this guys write up on this community not linux mint “winter-is-coming” he pointed me in the right direction…thanks men…you really helped…
The solution was simple 2 files, 1 action;
[+] The database.yml file located in the .msf4 directory in /home/user copy that into the /opt/metasploit-framework/ directory…to give /opt/metasploit-framework/database.yml
[+] A file called “.bashrc” from the /etc/skel/ directory,open it in your text editor & add at the bottom of the script this line;
export MSF_DATABASE_CONFIG=/opt/metasploit-framework/database.yml
[+] Another file called “profile” its in root/etc/ directory, a text file i think, add to the bottom also
export MSF_DATABASE_CONFIG=/opt/metasploit-framework/database.yml
and thats it, restart armitage …you have to run it as root too…“sudo -E armitage” at least forme anyway

thats all you get your active armitage gui… i just started this topic because it was very hard for me to find a solution to this problem on UBUNTU leading linux distro, imagine that…so i want this to be out there so pople who may encounter the sane problem can get the solution without the plenty hassle.
many thanks to wharfrat from the linux mint community and winter-is-coming from ubuntu u guys are great.!

The support gurus in our support venues are awaiting your support question.

Unfortunately, this is not the right place for support. Sorry.