Archlinux, Raspberry and Mir


I know it’s a Ubuntu centric forum, but I don’t know elsewhere I could get any help:
I try to create a standalone webapp on my Raspberry, using ArchLinux and WPE WebKit for Mir Kiosk.

I think everything is installed but I believe I miss a X/Wayland autologin and launch in order to being able to display something.

Could you help me to figure out how to make it work, or at least point me on some useful resources for a wayland/wpe newbie, please ?

(I tried with Raspbian but it did not start either. I also tried with Ubuntu Core + Frame, but it’s very very slow, at least on raspberry)

Thanks, and sorry again for this non-ubuntu post…

You shouldn’t need a user session: Frame and WPE webkit should both run as daemons. Have you followed the documentation here?

Especially, the note that for non-Ubuntu Core systems you need to explicitly set daemon=true:

snap set ubuntu-frame daemon=true
1 Like

Thanks @alan_g !

I was almost sure ubuntu-frame was only available on ubuntu, but it’s not!

sudo snap install ubuntu-frame
snap set ubuntu-frame daemon=true

did the trick, thanks for your help! :+1: