Arabic Font Problem

Hi I am new here and first time using Ubuntu. I installed Arabic fonts but I don’t like the default font and I want to change it. I am finding it hard to do so, trying to follow what has been said above but I don’t want to change the systems from English to Arabic, I just need the Arabic default font to be something nicer than the default one shown here.


Do you want to change Noto Sans Arabic or DejaVu?
The font in screenshot is Noto Sans Arabic which is the default if your OS language is Arabic

The OS language is English, I have installed DejaVu but I just don’t know how to change the default fonts after the installation.
I can change the fonts in Libre Office no issue here.
The default font is everywhere, in YouTube, Facebook basically all the websites which I don’t like and hard to see the dots on the letters.

you can remove the following files:


then restart the session or OS
The font will back to DejaVu

While that is true, it shouldn’t be necessary if the display language is English. So it’s a bit confusing.

@rawsan: Can you please let us know what the locale terminal command outputs. It may explain why it switched to the Noto font in the first place. Btw, are you possibly using some flavor of Ubuntu rather than standard Ubuntu?

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

@xlmnxp, the file was removed, restarted the PC and still I see the same Arabic font :frowning: :roll_eyes:

did you set it as default font in Gedit?
it must be unset as default font for Arabic when you remove the files above

maybe you don’t remove them correctly
can you validate by writing the following in terminal
ls /etc/fonts/{conf.d,conf.avail}/56-language-selector-ar.conf

I did not set anything myself as default

First time I removed using this command: rm -rf

now that you shared with me the other command, here is the result of that one:

ls /etc/fonts/{conf.d,conf.avail}/56-language-selector-ar.conf
ls: cannot access ‘/etc/fonts/conf.d/56-language-selector-ar.conf’: No such file or directory

remove this file too


that was remove too. nothing changed.
Do I need to change anything here?

With that I meant to ask if you are on e.g. Kubuntu or Lubuntu rather than Ubuntu. The lsb_release -a output does not show that.

Please run these commands and let us know the output:


fc-match -a | head -10

First Command - Output:

Second Commna-Output:
DejaVuSans.ttf: “DejaVu Sans” “Book”
DejaVuSans-Bold.ttf: “DejaVu Sans” “Bold”
NimbusSans-Regular.otf: “Nimbus Sans” “Regular”
NimbusSans-Regular.t1: “Nimbus Sans” “Regular”
NimbusSans-Bold.otf: “Nimbus Sans” “Bold”
NimbusSans-Bold.t1: “Nimbus Sans” “Bold”
NimbusSans-Italic.otf: “Nimbus Sans” “Italic”
NimbusSans-Italic.t1: “Nimbus Sans” “Italic”
NimbusSans-BoldItalic.otf: “Nimbus Sans” “Bold Italic”
NimbusSans-BoldItalic.t1: “Nimbus Sans” “Bold Italic”

Thanks. So you are on a standard Ubuntu installation, and your browsers should prefer “DejaVu Sans” by default for displaying Arabic contents. If they don’t, maybe you changed the font settings in respective browser.


That is my Chrome settings.

even the Text Editor is still showing that font. mean the default Arabic font that I don’t like.

That’s an unusual combination. Try to change “Sans-serif font” to either DejaVu Sans or Custom.

Thanks @gunnarhj, and sorry if I am bothering with this again.

I have changed the fonts in Chrome to be :

And when going to YouTube for instance I still see the old font.

you did not change the sans-serif font to one without serifs :wink: but force it to “DejaVu Serif” while you need/want “DejaVu Sans” …

1 Like

this font in screenshot is DejaVu when you asked for change Noto Sans Arabic to DejaVu which is the default

Do you want DejaVu or Noto Sans Arabic as default font for render Arabic characters?