Apt update network unreachable

I am trying to update my OS but it always aborts with unreachable network. I tried this with the latest OS and 16.04 with the same result:

multipass exec ham -- sudo apt-get update
Err:1 http://archive.ubuntu.com/ubuntu xenial InRelease                                      
  Cannot initiate the connection to archive.ubuntu.com:80 (2001:67c:1360:8001::24). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8001::24 80]
Err:2 http://archive.ubuntu.com/ubuntu xenial-updates InRelease

while there are some tools to change the mirror, i don’t have pip for installing them either.

This looks like a technical support request. This site is for the co-ordination of the Ubuntu project(s), and other non-support matters.

For Ubuntu Support options, please have a look at https://community.ubuntu.com/t/finding-help/709

Please note: As Ubuntu 16.04 has completed it’s 5 years of standard support and is now in extended (ESM) support, many sites do not allow support questions for 16.04 any longer.

I had a similar problem this week, as all my existing VMs were broken (without internet access) after Multipass upgraded from 1.6.2 to 1.7.0. I deleted the images and started again from scratch, but still, they lacked internet access, although they were available via ssh from multipass.
What I did to make it work was to setup lxd networks:

sudo apt remove lxd  # remove lxd from system
sudo snap install lxd  # install lxd from snap
sudo snap install multipass  # install multipass from snap (if not already installed)
sudo multipass set local.driver=lxd
sudo snap stop multipass
sudo snap start multipass
multipass networks          # this command should work fine and list networks

sudo lxd init    # note this is /snap/bin/lxd  
# select all default options <enter> <enter>... and select 'dir' instead of 'zfs'
sudo reboot   # network was back only after I reboot system, don't know why

Hope this helps, and if there’s a better solution, I would also love to know.