Using Multipass on Ubuntu with Virtualbox and KVM installed question

I have both Virtualbox and KVM installed on my Ubuntu 20.04 machine. I can’t start Virtualbox when KVM is initialized or KVM when Virtualbox is initialized, which is fine. I recently installed Multipass, and I really like it. Problem is Multipass kinda startsup with my computer already? Apparently it’s possible to switch the backend of it to either KVM or Virtualbox. But as it’s already started when my computer boots, when I go to launch Virtualbox and KVM backend is in use (from boot, I didn’t ran any commands yet), Virtualbox fails to start.

I want multipass to not start unless I told it to.

Hi @eri0, glad you are enjoying it :smile:

Multipass has a daemon at its core, along with two clients: CLI and GUI. This daemon launches on startup. The GUI launches on user-login by default, but you can disable that with multipass set client.gui.autostart=false.

If you want to disable Multipass entirely, until you require it, and assuming you installed it as a snap, you can do snap disable/enable multipass.

You can switch backends with multipass set local.driver=<backend>, but only qemu and libvirt are supported on Linux ATM (virtualbox is supported only on Windows and macOS).

The documentation for set has more details on the commands above.

1 Like

Most importantly, it’s running instances (not Multipass itself) that conflict with VirtualBox.

If you stop instances before shutting down, instances won’t start on boot.

And you can avoid Multipass starting up automatically with this:

systemctl disable snap.multipass.multipassd.service

You can then snap start multipass to kick it to life.

1 Like

Thanks guys! I indeed installed it from a snap. It was the instances starting automatically that bit me.

Also I am using the command line interface and not the GUI, so thanks for teaching me how to disable it. I would argue the no gui behavior should be the default. The GUI doesn’t render correctly (has no text, just empty boxes) in all DEs I tested - I also prefer a nice command line interface because those tend to last longer than GUIs so if I learn a command I can just use it for a long time, while GUIs tend to fall out of fashion quicker and also names and position of things changes way too often.

Just to see if I understood, by using the systemctl disable snap.multipass.multipassd.service it also won’t start the instances I left on before I boot, right?

For the time being I ended up uninstalling it but plan on installing multipass again soon. I like the idea of magically starting clean environments, they are useful to create development environments for me to test ideas for a bit of longer time, just need a bit of free time to learn it. Seriously, keep working on it, it’s shaping up really nice.

Hi @eri0,

The GUI doesn’t render correctly (has no text, just empty boxes) in all DEs I tested

That’s news for us. We’d welcome a bug report with screenshots and environment details :grin:

Just to see if I understood, by using the systemctl disable snap.multipass.multipassd.service it also won’t start the instances I left on before I boot, right?

That is correct.

[…] it’s shaping up really nice.

Thank you for the kind words!