Ubuntu installation on computers with Intel(R) RST enabled

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAV\ should be HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\, and can be confirmed by the accompanying screenshot on the help page.

A post was merged into an existing topic: Intel RST Issues

A post was merged into an existing topic: Intel RST Issues

I tried “active” which is the correct command, but it said something about the volume not being Fixed MBR. So that didn’t work for me either. It should be changed.

1 Like

I found the same thing today. When does the actual webpage get updated?

I found a workaround to boot windows after changing to AHCI easily.
I wasn’t able to make it work (no troubleshooting in the page worked) until I manually setup a safeboot minimal mode with an elevated cmd right after I changed the registry values.

Apparently the regedit changes for the “ RST enabled, Windows installed” scenario were being reset on the first fail cycle, so when entering repair mode they wouldn’t get loaded. I’ve read somewhere that the StartOverride changes only lasts for one boot cycle.

The solution was to set the safe mode (safeboot) manually. Right after the regedit changes:

  • With a cmd with admin rights (windows search: cmd, then right click, run as admin):
    bcdedit /set {current} safeboot minimal
  • Reboot to BIOS.
  • Change from RAID (RST) to ACHI in the BIOS.
  • Reboot.
  • Windows enters safe mode correctly and setups the “new” hardware using the temporarily enabled drivers. New hardware connected sounds and all.
  • Then before restarting, revert the safeboot mode:
    bcdedit /deletevalue {current} safeboot
  • To go back to normal boot.

Tested with a Dell XPS 13 7390 (model P82G)

Also found a typo: The activate diskpart command should be changed to active (and add a note that it might fail with an error message about the volume not being “Fixed MBR”)


That’s a good question. The actual webpage is a static HTML page, which I committed at the request of @igorljubuncic. But there is no good procedure in place yet for maintaining it.

Myself don’t know the topic. Possibly, if you would submit a merge proposal with obvious things like typos, I might be able to merge it (it’s this Bazaar branch). But I have a feeling that the changes you would like to see are bigger than that, and if so they need to be reviewed by somebody with sufficient knowledge.



Unluckily I’ve never used bazaar and it would take too much of the company’s time just to fix two typos.

The change proposal is to manually enable safeboot right after the registry changes, which reset each boot cycle by design, to avoid the failed boot (prior to the repair one) resetting them. Or at least that’s the working theory.

EDIT: Apparently reading further I ended up in this specific guide for my laptop model which does something similar (although not through command line but via the msconfig app)

Maybe the msconfig approach is easier on the user and to add to the RST guide.

Thank you, man!! Thank you very much.
@igorljubuncic can you add this to the post, please?

Happy, I found this right before editing Bcdboot.
Asus ROG Strix G17 G712LWS-WB74 with UEFI, GPT, Intel RST

1 Like

Hi. I just wanted to make you aware that tutorial from this post does not work at all for me (Dell Latitude).

  1. Changing registry in Windows didn’t help (Windows didn’t boot)
  2. While trying to repair Windows: none of bcdedit /deletevalue commands worked. Error:

An error occurred while attempting to delete the specified data element. Element not found.

  1. Bcdboot section: none of the two configurations describe volumes on my device (I’ve got Windows freshly installed, no changes on disk after installation). I’ve got one C volume (with Windows), one volume NFTS 508 MB and one FAT32 100 MB.
  2. None of those volumes contain boot folder I could cd into.

To sum up: hardly any steps from this tutorial worked as expected. Moreover, you’ve got even more outdated version of it here: https://help.ubuntu.com/rst/ (containing non-existent commands like activate). This is the link Ubuntu propose to user when installation fails due to this storage incompatibility.

I suggest you either fix this post or delete it, because it doesn’t help anyone and create confusion to users how want to install Ubuntu.


Worked flawlessly on my Acer A515-55G. Thanks!

Thanks a lot for the info

Is it working if bitlocker is enabled, or does it has to be disabled first?

I read in some other post that it would require to enter the bitlocker recovery key on startup when changed to ahci driver. Is it the case with this config as well (changing the registry)?

worked like a charm! @nitram-mural thank you!

Dell G7 7700

This saved me as well (Dell Optiplex 5090). I’m hoping this addition can make it into the official page soon.
Confirmed: the correct diskpart command is active (and it failed for me as well with the not-a-Fixed-MBR disk or similar)
Confirmed: if you screw up and change your bios back to RST, after a few reboots windows will revert and find its disk like nothing happened (this should definitely be in the notes)
Confirmed: without manually setting the safeboot, this process does not work for me

thank you!

Worked like a charm… I think the same “Safe Boot” can be enabled via msconfig. Also the second step in the main instructions storahci didn’t even exist for me. I only have an internal nvme. All in all, there were only 2 steps inside windows to get everything set to then safely change BIOS to AHCI. Cheers!

Does this mean there is no need to change registry values?

This is a horrendous change. I have a computer with several harddrives, and one RST storage that’s dedicated for Windows. I do not want to use it for Ubuntu, and I have a dedicated SATA drive I want to use for Ubuntu.

Right now the installer is preventing me from installing Ubuntu on my non-RST SATA drive just because it detected RST on the computer.

Please add an advanced option to “install anyway”.


have win installed, rst with optane enabled, but no raid configured, just separate disks
i cant disable rst in bios… how to install?

P.S. Gparted successfuly see and detect free disk i want Ubuntu install to.

1 Like


Please remember that the purpose of this thread is to improve the documentation.

It was not really intended to be a support thread or a complaint thread or a I-found-a-bug thread or a thank-you thread.

Wherever you find your answer, please come back and make specific recommendations to improve the strings and images of the documentation to save other users the hassle you encountered.

1 Like

It worked excellent on my Lenovo IdeaPad S340-15IWL