Ubuntu 24.04 LTS Beta Testing

The VirtualBox issue is Bug #2061118 “Rendering issues in vmware/virtualbox with 3d on (...” : Bugs : open-vm-tools package : Ubuntu

The default terminal is GTK3 so it’s not affected by this issue but many other apps are GTK4 and are affected.


Changing renderer, indeed, fixes the issue. :slightly_smiling_face:

If i choose the FDE-TPM Installation my Lenovo X13 Gen2 AMD tells me to put in the luks recovery key at first reboot after the Installation process. But you first get the recovery key after first boot so i cant boot in. I tested this with the current beta iso and all available daily builds including the newest of 14/04/24. I searched that misbehaviour on other Ubuntu forums and figured out that this is a known bug but i cant find any solutions that helps. Anny ideas? Or will this get fixed in the final release?

I installed Ubuntu Noble in English with Italian keyboard ans system works fine. Then from my 1st user I created a second user with language Italian but the second user remain in English:

Hi Bambus this situation can occur when there are specific BIOS settings toggled on your machine that disrupt the signature verification of the boot process, I would check if something like Absolute is enabled on your device and try disabling it. We are working on better reporting for situations like this but it can be tricky to check such settings from inside the OS.

1 Like

My device is configured properly. Absolute is completely disabled, secure boot enabled and tpm 2.0 also. I tested every option in bios that could affect this with no solution. Windows bitlocker works like it should on the same machine but is not installed, ssd formatted and systemd cryptenroll with fedora worked also. So i think that this kind of problem is not bios or hardware like but a bug in ubuntu. I am not the only one with this problem and there are several reports out there with the same problem on different kinds of hardware. For me tom based encryption is one of the most important top feature of 24.04 so i wikl wait till this is working.

This is also happening to me. I have a Dell G15 5530.
Cleared TPM and Even disabled Absolute and still first boot tries to ask for recovery keys which can not be done since this is the first time booting up after install. I have tried regular beta and even daily beta of 04/15/2024

1 Like

i tried all dailys since April 09 and i also tested the git version of the Installer. Nothing. To be honest i am really disapointed about this because that is a feature from 23.10 and get to be released in a LTS release, but does not work (on most hardware, but lacks of a hardware list and a bios setting list at all). My hardware is not the newest but also not very old and brings all features to use tpm based fde. So i think ubuntu and canonical have alot of work going forward to solve this.


Thanks for the detailed investigation folks. Can I ask that you file this issue in Bugs : ubuntu-desktop-provision

Please include your system specs and the content of /var/log/installer and any crash files from /var/crash which you should be able to find on the 4th partition of the USB key (if you are doing a physical installation). Or drop this information as a reply to an existing bug that covers your issue.

As an experimental feature there is still work to do to expand the FDE functionality for devices that require third party drivers which we are actively working to support within the life of 24.04 LTS.

This is feedback left at https://fridge.ubuntu.com which I don’t plan on approving for visibility… so I’ll re-post it here

I am going to test out the ubuntu mate beta, however testing of the daily image from monday tells me that accessibility support is lacking, the buttons appear to be unlabled in the installer and there’s no audible way of seeing how well the installation is progressing, also, you used to be able to have orca save its settings for you and copy them to the installed system. only option for me going forward is to install ubuntu 24.04 as an upgrade from 22.04 if I want to do a clean install, this isn’t ideal and it looks like the ubuntu team could do with a few more accessibility testers, such as myself

2024/04/13 at 4:26 pm … (other details withheld)


Does 24.04 comes with explicit sync? Thanks

1 Like

Same thing here after 6.8 kernel update. Wifi connects for less than a minute and then vanishes.
If I boot from earlier kernel wifi works fine.

At least the beta images (and daily images) for the pre-installed pi desktop builds seem to have the wrong sources.list still (and no ubuntu.sources). I have not checked the ISO images for this mistake.



# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ports.ubuntu.com/ubuntu-ports/ noble main restricted universe

I’ve been wondering for a while why python3.11 packages were recently removed from Noble’s repositories even though we’re past the feature freeze and wasn’t sure what would be the best place to ask about this. This community post seems to have some visibility so I’m going to try here :slight_smile:

Basically, until April 7, Noble daily builds had working python3.11 packages in its repositories. Then for a few days, there were some hiccups with some of their dependencies missing/broken and eventually, on April 15 all python3.11 packages were gone. There was a smaller issue with python3.11-venv package missing between March 16 and March 30 (Bug #2058821 “python3.11-venv is missing on 24.04” : Bugs : python3.11 package : Ubuntu) but I assumed it was just a temporary bug since all the other packages seemed to still be there.

Now, is this all intentional? I opted to test with Ubuntu daily builds to detect these issues early but until 2 weeks ago (which is past the February 29 feature freeze and not a lot of time to the actual release date) there was no indication that the Python 3.11 packages would be removed from the repositories before the release (probably even later than that since at first, I only saw version incompatibilities which just suggested that repository state may be inconsistent).

Python 3.12 is the default release - that was known - but this is not the first time that multiple versions of Python were available in Ubuntu’s repositories (notably, 20.04/22.04 had the python3.9/python3.11 packages even though python3.8/python3.10 were the default ones) and so nothing indicated that there’s a reason for concern of whether Python 3.11 will make the cut or not (and since the package was available after the feature freeze, I thought I can already assume that it did make the cut).

If this was all planned, could you let me know how I could learn in the future that such changes are planned along with the reason for them? I couldn’t find anything in the source package bugs (Bugs : python3.11 package : Ubuntu) or on the ubuntu-release bugs (Bugs : “Ubuntu Release Team” team) that would indicate that there was a feature freeze exception being made and I assume that removal of a package would be something that cannot just happen after a feature freeze.

Yes it was planned for Python 3.12 to be the only version of Python available in Ubuntu 24.04 LTS.

Note that for Ubuntu 22.04 LTS, Python 3.10 was the default, but the newer Python 3.11 is available in universe. Also note that 3.11 is available only in -updates; it could not have been available in -release because it wasn’t released until months after Ubuntu 22.04 LTS was released.

I agree with the idea that it could be nice for major package removals to also follow the Feature Freeze deadline. However in practice this seems difficult since the removal process could take weeks and it is not possible to finish every detail by Feature Freeze every time. Also, Feature Freeze is satisfied if things are done in -proposed even if they have not yet migrated to -release by the deadline.

I think this is where Python 3.11 was “dropped” and it did happen before Feature Freeze, even though the details took longer: 3.12.1-0ubuntu2 : python3-defaults package : Ubuntu


I tested wifi on the latest noble daily live USB and the same issue.
Decided to swap out my wifi card to a spare I had sitting around and working fine.
It would appear that my new card is an “upgrade” to 64 bits from 32 too.

Same issue here with an HP 240 G7 laptop. I had to use a wired connection to be able to fully download updates today.

My previous wifi card that stopped working was a realtek. Wifi networks would show as normal and then wifi would would vanish within a minute.

We are selling pc’s pre-installed with ubuntu since more then 20 years.
We did not find any oem installer yet.
We will not deliver ubuntu computers with a preconfigurated sudo user and password.
Will there be again a legacy iso like ubuntu 23.10?


The short answer is yes there is an oem mode with the new installer. We need to do some testing internally before we write up some details on how to use it though. We’ll come back soon.

1 Like