Testing Unity Session in 19.04

For me it is showing page not found.

Try now, made public (not cleaned but i’m not worried about that…

As mentioned not really a unity thing. With nautilus .desktops can only be executed in limited circumstances. For instance if you copied to the Desktop folder then they could be marked as trusted & executed from the desktop itself (nautilus may refuse to copy .desktop’s directly to the desktop

Is ubuntu-unity-desktop going to stay with Nautilus or move to Nemo? Ubuntu Budgie had already done that.

1 Like

Then such a functional Nautilus should be removed from Ubuntu and replaced by

or Caja.
@khurshid-alam - what do you think?


In the neighbour thread there is an announce about doing so, but this project is in a very early stage.


I have discovered that you already have Nemo installed with ubuntu-unity-desktop, it maintains Open as Root on desktop and other stuff.
So the last step would be to remove Nautilus from the system. But simple removal is not possible:

$ sudo dpkg -P nautilus
dpkg: dependency problems prevent removal of nautilus:
 ubuntu-unity-desktop depends on nautilus.

dpkg: error processing package nautilus (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 nautilus

$ sudo dpkg -P nautilus-data 
dpkg: dependency problems prevent removal of nautilus-data:
 unity-settings-daemon depends on nautilus-data (>= 2.91.3-1).
 nautilus depends on nautilus-data (= 1:3.31.90-1ubuntu2).

dpkg: error processing package nautilus-data (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 nautilus-data

so we can use quick and dirty method:

# remove packages
sudo apt purge -y nautilus-share nautilus-sendto nautilus-extension-gnome-terminal
sudo apt autoremove --purge -y

# remove nautilus files
sudo rm /usr/bin/nautilus /usr/bin/nautilus-autorun-software
sudo rm -rf /usr/lib/x86_64-linux-gnu/nautilus
sudo rm /usr/share/applications/*autilus*.desktop
sudo rm /usr/share/dbus-1/services/org.freedesktop.FileManager1.service
sudo rm /usr/share/dbus-1/services/org.gnome.Nautilus.service

# remove nautilus-data files
sudo rm /usr/share/apport/package-hooks/source_nautilus.py
sudo rm /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.xml
sudo rm /usr/share/gnome-shell/search-providers/org.gnome.Nautilus.search-provider.ini

# add Nemo to favorites
dconf write /com/canonical/unity/launcher/favorites  "['application://nemo.desktop', 'application://firefox.desktop', 'application://libreoffice-writer.desktop', 'application://libreoffice-calc.desktop', 'application://libreoffice-impress.desktop', 'application://org.gnome.Software.desktop', 'application://unity-control-center.desktop', 'unity://running-apps', 'unity://expo-icon', 'unity://devices']"

Caja is also installable, but it has wrong desktop background and does not allow open GNOME terminal from desktop (but MATE Terminal works normally).

# remove Nemo
sudo apt purge -y nemo nemo-data nemo-fileroller
sudo apt autoremove --purge -y
sudo rm /etc/xdg/autostart/nemo-unity-autostart.desktop

# install Caja
sudo apt install --no-install-recommends -y caja caja-sendto caja-open-terminal mate-terminal

# add Caja to favourites
dconf write /com/canonical/unity/launcher/favorites  "['application://caja.desktop', 'application://firefox.desktop', 'application://libreoffice-writer.desktop', 'application://libreoffice-calc.desktop', 'application://libreoffice-impress.desktop', 'application://org.gnome.Software.desktop', 'application://unity-control-center.desktop', 'unity://running-apps', 'unity://expo-icon', 'unity://devices']"

# add Caja to autostart for current user
mkdir -p ~/.config/autostart
cat << EOF > ~/.config/autostart/caja.desktop
[Desktop Entry]
Type=Application
Exec=caja --force-desktop
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=Caja
Name=Caja
Comment[en_US]=
Comment=
EOF

Both Caja and Nemo have expected view of /usr/share/applications:

nemo_and_caja

Yes, we are already drawing icons using nemo-desktop. Removing nautilus requires more work on unity. For now unity is already pulling nemo. So you can use that if you want.

1 Like

@mc3man

It is a issue with glib 2.59.2 but we now have 2.59.3 in which it was fixed and latest u-c-c most likely compiled against it. Because I can’t reproduce. Can you confirm? Also mention u-c-c version.

Broken here with both 2.59.3 & latest 2.60.0. u-c-c is 15.04.0+19.04.20190209-0ubuntu2
This is re-tested just now twice with 1st.,
Installed the current image (03/05), this has the glib 2.59.2 packages. Updated them manually to 2.59.3 , rebooted
Installed ubuntu-unity-desktop, rebooted, tried - same error
Upgraded to current glib (2.60.0), rebooted, tried, same error

Then 2nd, dumped above install, installed the current pending image which has glib 2.60.0
Installled u-u-d, rebooted, tried, same error…

Also noticed I can’t package build u-c-c locally. By itself not that’s not an indication, on rare occasions some sources are difficult or impossible to locally package build (compiz may be atm one that can’t… maybe u-c-c is another?
But curiously the build fails on info-cc-panel

@mc3man

Your issue is probably this issue. https://gitlab.gnome.org/GNOME/gnome-control-center/issues/285

The isuue is with disk size info on the panel. For me it shows the correct size. Do you have zfs partition ? Does gio mount -l work ?

I compiled u-c-c in the maintainers PPA, and it’s compiling fine against glib 2.60. But I can not reproduce the crash even with it. Please try with it.

Try running unity-control-center -v and paste the error. If it doesn’t give anything significant, we may need a gdb backtrace.

@chanath @walter-garcia Can you reproduce the info-panel (details ) crash in u-c-c (try updating your system first)?

I don’t think this is normal but Firefox Snap (beta channel (if that helps)) unpin every update. I don’t have access to the device running Ubuntu Unity 19.04 at the moment, but I will check couple of other Snaps and see if they unpin after update.

I do have Firefox (beta) Snap installed on my Kubuntu 18.10 laptop, and it doesn’t unpin.

unity-control-center -v
** (unity-control-center:3596): DEBUG: 19:22:48.228: Enabling debugging
(unity-control-center:3596): dconf-DEBUG: 19:22:59.179: watch_fast: “/org/gnome/desktop/media-handling/” (establishing: 0, active: 0)
(unity-control-center:3596): dconf-DEBUG: 19:22:59.181: watch_established: “/org/gnome/desktop/media-handling/” (establishing: 1)
(unity-control-center:3596): GLib-GIO-DEBUG: 19:22:59.221: desktop_file_dirs_lock: Resetting desktop app info dirs from (null) to /home/akoya/.config
(unity-control-center:3596): info-cc-panel-DEBUG: 19:22:59.269: Not allowed to change the hostname
Segmentation fault

U-c-c is coming from the maintainers PPA. Details don’t open, u-c-c just goes off.
Also, logout doesn’t work still.

Your error seems totally different from info-panel. Does avahi-daemon service is running for you ?

I’m having issues with the lock screen. On a long lived session (+12h), the lock screen becomes unresponsive and only switching to a TTY and back makes it work again. Once returning from the TTY, suddenly all keyboard input from before appears. This is regardless of whether I’m using lightdm or sddm.

Happens when resuming from suspend, when it auto-locks after turning off the screen (without suspending), and when locking manually.

I can’t reproduce this. Screen locking time-out has stopped working (some issues with gnome-screensaver) but that’s separate issue. Can you give more detail how to reproduce ?

Yes, I can reproduce the crash. I’ve uploaded my system information at:

https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1820069

I erased the core dump and made the bug public.

The avahi-daemon service is running. What might be the solution to this u-c-c > details going off? How does one correct this problem? Everything on U-C-C works except Details. It simply goes off.

Log out gets stuck still. Lock, suspend works. This is one DE system, so practically no need to logout. But, still it’d be interesting to know why.

Logout does not work for me either. Closing the user session gets into a screen with the background and nothing else and it is stuck there.

It’s pretty hard to reproduce as there are no A B C steps to follow. Simply don’t log out for a day or two and every now and then lock screen and/or suspend your pc.

The screen locking timeout doesn’t affect it - once it starts happening in a session, happens on every screen lock, whether it’s manual, auto or caused by suspend.

Is there any tool I can possibly use or anything I could look at when the problem is occurring on my laptop to help diagnose?

Update:

  • I have uploaded a new u-c-c with the fix for info panel crash. Please check if it is working for you.

  • Logout issue is a systemd issue and will be fixed with systemd-241. For now you can either downgrade to 239 (check above) or download a patched version from PPA. @chanath please give link where we discussed this.

  • Unity now using nemo-desktop and everything is merged. :slight_smile:

  • There will be a updated version for libunity, unity, unity-lens-applications & unity-scope-home against latest vala and glib. This requires testing. I will upload that in separate PPA as that may break thing.

This is what I did.

  • I kept the machine idle for 12 hours.

  • I unlocks, it unlocks. I change the lock delay from power settings, it respects the settings. If I choose lock-screen-after 30s, it works but blanks the screen for 2nd time after I moved the mouse. Mostly graphics/backlight issue.

power-panel

  • I suspend and then repeat step-2, everything works. There was some minor delay (abt 3-4 sec) after resuming when I started typing password. But I guess that’s gsettings delay or dbus related.

  • Though I did see lots of services restarts during this 12 h. Tracker and systemd doing that…and tracker is crashing…so it might have to do something with specific hardware. You can disable some systemd services (like kerneloops, colord, apt related) and check again. Also I gave instruction for minimal install in another thread, you may try that.

  • Low battery notifications and suspend related issues are upower related. I will try fixing those later.