Testing Unity Session in 19.04

It’s probably this issue https://launchpad.net/bugs/520546

1 Like

My cursor will not work with the gui in unity and just starts dragging windows instead of interacting with them. I’m not sure whats making this happen, anyone know why it might be doing this? And perhaps how to fix it?

Is your mouse button sticking? Physically.

Well the mouse works fine out of unity but when I log into unity it can’t interact with any windows. So if I click on something it will only start dragging the window. The mouse can move and press software and some other things but I can’t say use the settings or Firefox or really anything that’s in the form of a window… I really don’t know why it would be doing this

You should create another user and try the Unity session from there, maybe it is something you tweaked in your user’s session.

Good idea! Okay so yeah it seems to probably be something I did in gnome… Hmm I tried disabling the extensions and playing around with window settings although I can’t find anything that makes a difference in unity.

Thanks. Nemo is working well but I see lots of debug logs with it. It is spamming my journal. if I click a window and then click a desktop I see errors like this

window_menu_model_new: assertion ‘BAMF_IS_APPLICATION(app)’ failed
track_menus: assertion ‘IS_WINDOW_MENU(menus)’ failed

Any idea what’s causing this ?

1 Like

Known issue. Since the split of nautilus-desktop as separate binary bamf doesn’t think desktop_window as a valid app. Same for nemo. Can you file a bug against indicator-appmenu ? It will be fixed in eoan.

Hi @khurshid-alam and all Ubuntu Unity7 developers, I ran command line

sudo apt-get install unity-session

on Ubuntu Disco and it works very well. Unity desktop looks great, dash menu works very well, HUD also works, and like you said, transparent dash looks really unique now. I can confirm Unity7 performs quick (and I can feel it quicker than the built-in GNOME 3.32) on Disco Dingo at least on my hardware (Intel Pentium 4GB). It’s awesome, man. You all did good job. Thank you.

7 Likes

In 19.04, I’m getting menus duplicated in the upper bar of Libreoffice, no matter if I attach the menus to the application or to the upper panel. I’m getting this in two installations. I don’t know if this is specific to Unity, I looked around and could not see any report from other desktops, so it should be.

Edit: I found some bug reports on this:
https://bugs.documentfoundation.org/show_bug.cgi?id=124192

2 Likes

Are you getting the global menu but duplicated ? It doesn’t look like a xdg_current_desktop bug (like before) which was fixed in 1.6.2 and 1.6.2 works fine. Issue is happening with more recent versions.

Please file a bug on launchpad too ( if not already there) and may be ping @osomon

1 Like

Yes, I’m getting global menu, but duplicated. If I ask to show the menus in the application they are also duplicated. As I said, this seems to be a common problem in the latest version of LO. Here is the main bug report with a link to the upstream bug:

1 Like

Not sure that the “global” menu is accurate, really just the default LO menu view.
If you disable global menus then the menu is still duplicated in the window deco…

I’d be tempted to place the duped menu issue with LO going to gtk3. If you were to remove libreoffice-gtk3 & install libreoffice-gtk2 then you’d get the expected menu.

Yes, it is a known issue, it happens in different distributions and desktops. There is an open upstream bug that I mentioned above.

Happens as well on MySQL Workbench.

Any solution to this problem? We have the same issue.

The upstream bug is still opened and not a lot of action despite it affects different desktops:
https://bugs.documentfoundation.org/show_bug.cgi?id=124391

1 Like

MySQL workbench has the same problem.

Just for the record, the LO problem with the menus has been fixed and the global menu looks OK again in Unity.

1 Like