Testing unity-session in 18.04

How do I get Evolution to use the indicator-messages?

Edit: Got it.

I would like to report a bug and a fix (workaround) that I noticed with unity on 18.04. Videos on chromium and chrome started tearing recently for me. This is an optimus setup, so it likely won’t affect most people. The root cause is unredirected_match setting in compiz settings manager -> composite. That list by default includes common browsers and media players. However, something has changed recently w.r.t capitalisation and regex, and the strings in that list no longer actually match the respective programs. For chromium and chrome, I had to additionally add !(class=Chromium-browser) & !(class=Google-chrome) to that list (note the capital C in each case). I got these by using the grab tooltip in that field which is very useful.


Great stuff dale. Just one thing though, the link to the unity iso is 404-ing:


Ask @dale-f-beaudoin. It’s his repo. I don’t really have access to http://people.ubuntu.com/

I’ve noticed a regression in unity in touchpad configuration for synaptics. After some recent update to xorg or synaptics, the unity mouse and touchpad settings utility doesn’t work for controlling the touchpad’s speed. The reason I noticed it is that the touchpad feels different (worse to me). I can configure xorg conf files directly, but something seems to have changed.

Maybe the synaptics input package got removed. I had the same issue with my laptop with recent Ubuntu versions, because it’s not installed by default anymore.

Is the package:


installed? If not, just install it and it should work like before.

1 Like

That package was definitely not part of the installation of Bionic. I noticed it immediately after a fresh install because I use a Lenovo Thinkpad and prefer the trackpoint device and HATE the touchpad (a stray movement of my thumb on the surface will send the mouse pointer way off target). First thing I do is disable the touchpad, but I couldn’t because the setting wasn’t there. Once I installed it, I was able to disable the touchpad. Not sure why the package was removed from the default installation because it is still in the repository.

I think because libinput should do the trick now, but it’s not working well for older touchpads.

Would anyone know how to get “Global Menu” support back into Firefox? Looks like this is no longer an option since Canonical dropped support of Unity back in 2018… :worried:

I would note that the current version of Thunderbird DOES have Global Menu support, so it should be possible…

Firefox global menu is working here (Ubuntu 20.04, 19.10). It should work on bionic too.

18.04 should still heve global menu in FF, 20.04 should not as of -
firefox (72.0+build4-0ubuntu1) focal; urgency=medium

  • New upstream stable release (72.0+build4)

[ Olivier Tilloy ]

  • Remove debian/patches/unity-menubar.patch before the LTS release
    to minimize the maintenance effort

@mc3man Yes, firefox now doesn’t uses a menubar but it can still have global menu through unity-gtk-modules.

I guess I’m unaware of how to make that happen…

1 Like

Per Synaptic, I have both unity-gtk2-module and unity-gtk3-module installed, but I definitely do NOT have a global menu in Firefox.

Maybe install unity-gtk-module-autopilot

Installed it, but it didn’t make a difference. :worried:

Maybe apt install gtk3-nocsd

No difference. I see this being discussed in another thread, too. FWIW, Palemoon, the fork of Firefox, doesn’t have global menu either.

1 Like

Hello everyone!
I modified the Yaru theme for Unity. Follow the link: