Testing unity-session in 18.04

Just installed the HWE package and an old problem has popped back up. I can’t disable the touchpad anymore. I attempted to reinstall xserver-xorg-input-synaptics but when I tried I had to include a required package. When I added that to the “apt update” command it implied it was going to REMOVE the unity-desktop. Needless to say, I aborted the install but I would appreciate a resolution to this quandary. I hate having that damned cursor jumping all over the screen if I should position my hand incorrectly…

Did you try to install xserver-xorg-input-synaptics-hwe-18.04 ? That shouldn’t cause any undo removals…

1 Like

I just got that information over on answers.launchpad.net. That worked. Thank you.

GNOME Terminal is useless on Unity session - it does not have keyboard mnemonics - see bug 1785444.

@dale-f-beaudoin Hi! I was thinking of creating a distro with unity as it’s desktop enviroment! Though I am pretty new to all this, and probably the best thing I could use would be respin, I though it would be a good Idea! I kind of had the imagination of the guy who started elementary os, very Naive, but creating in the end a wonderfull operating system, used by many thousands. Though it seems you have this going yourself…

It has become more and more difficult for me to code at the keyboard due to my current health issues. Khurshid has been doing all th heavy lifting as team captain and it is not fair to expect him to do all the work on this. I am currently waiting for a ergo-friendly chair that would reduce some of the RSI I have been experiencing. Anyone can make a unity-respin if they wish. I do have a Canonical License which basically belongs to the team but I am not able to use it atm due to limitations.

If the situation changes where I can contribute more consistently and we can get others to commit then an official distro status is not too far fetch to think about. The other problem is that once we become official them we have a responsibility to maintain and we currently do not have the manpower to do so.


1 Like

Hope you’d find that chair and get to the work you love. Usually doing what you love to do becomes the medicine.

Btw, I think @ccm27 is saying/asking is about creating a respin, for which no license is needed. The respin wouldn’t be be named Ubuntu, but be using Unity that Cannonical doesn’t want/need.

I suppose, you should at least try. Like the elementary guys, maybe you should think of your own repos too.

1 Like

Well I guess If you decided to create the distro, I could help with the setting up a bit :slight_smile: I would love to create a distro system, but I don’t know how much needed that is… (What I mean by “system” is to get the distro going like any other popular ubuntu based distro, like creating a userbase, website, developer doc, e.c.t) @dale-f-beaudoin

I have always dreamed of working on a custom desktop distro, with a different DE :slight_smile: Not that would be qualified to work on the distro itself :blush: @dale-f-beaudoin

Well, @dale-f-beaudoin Good luck fighting the cancer! I have known people with similar conditions, and it’s tough…

@dale-f-beaudoin I would be happy to make a website and userbase if it ever comes to be needed :stuck_out_tongue:

I’ll keep everyone apprised. Still no chair yet.

I had a fresh new install Ubuntu Unity 18.04.2 yesterday, I installed from minimal CD so it should be a “Clean install”.

I found two issues annoying me a lot.

1, Login Screen backgound image won’t change to my user wallpaper automatically , it will keep the “purple default” whatever what i did.

I checked my Home Dir’s permission and Lightdm’s log files with no luck, I dont’t know how to fix it, As i recall this feature shuold work with my Old Ubuntu Unity 16.04.

Yeah I know I can change Login Wallpaper with some “hack-way”,But I don’t like that.

2, I found “Clipboard app” such as CopyQ \ Clipt \ Gpaste \ Didion will block System reboot.

You can check it with these steps:

  • install copyq (or any other Clipboard app which you like) and run.
  • make sure copyq is running (Indicator icon) and working( Logging your clipboard)
  • Click to the right upside corner “Power Icon” and choose “Shutdown system”
  • choose “reboot” or “Shutdown”
  • nothing happened
  • After 30 seconds, System suddely reboot/Shutdown

It seems there is something blocked system’s rebooting. It make take 30 sec for some “Timed out” and countinue rebooting.

I also checked system’s log and found nothing relate to this.

I don’t know if these are bugs or not, May be I should report them to launchpad?

Gnome Software Ubuntu branding (orange shopping bag) is missing / not working. Works ok in Gnome-session.


I’d noticed that from the beginning but just assumed it was a new icon, not a bug.

I truly hope it’s a bug and not a design decision. :slight_smile:

It’s default icon for Gnome Software (vanilla Gnome).

Probably not a bug or a decision. It’s possible that in a ubuntu session the launcher uses or is directed to use ‘/usr/share/ubuntu/applications/org.gnome.Software.desktop’ which has Icon=ubuntusoftware & Name=Ubuntu Software

Solution: drag and drop Ubuntu Software icon from /usr/share/ubuntu/applications/ to the dock.

This has been answered multiple times. Are you using the ppa ? Any way try settings background olugin true

gsettings set org.gnome.settings-daemon.plugins.background active true

This is known systemd issue. It prevents logout if clipboard manager doesn’t exit gracefully. I believe this has been fixed in diodon. At least logout issue. Not sure about reboot though. Something preventing it. You may want to file bug against diodon. Downgrading systemd also an option.

Funny these clipboard managers are mentioned here. Clipit has stopped working in both my bionic desktop and 19.04 laptop - copying/cutting stuff doesn’t work (doesn’t register in clipit, and I can’t paste it either - it’s just not there).