Testing unity-session in 18.04

Has anyone ever tried to change the indicator order in the panel with the file:

/usr/share/indicator-application/ordering-override.keyfile

or:

~/.local/share/indicators/application/ordering-override.keyfile

?

I changed it but Unity doesn’t seem to load it or at least it doesn’t seem to work with mulitload and redshift.

Hello all,

Since 2 weeks I have a problem when updating my Ubuntu Unity 18.04, installed in march with the Ubuntu-Unity iso image dd 2018-02-03 from the Unity maintainers. I get these messages:

“failed to download repository information” and

E: Repository ‘http://ppa.launchpad.net/unity7maintainers/unity7-desktop/ubuntu bionic InRelease’ changed its ‘Label’ value from ‘Ubuntu-Unity-18.04-Testing’ to ‘Ubuntu-Unity-18.10-Testing’
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

I don’t know how to fix this. I am sorry if this is the wrong place for asking support, but I don’t know where else to go since this concerns Unity. I hope you have a solution because I want to stay with Unity forever!

Thank you in advance,

Lisa

PPA name has been changed. Just remove the PPA and re-add it. This should solve the problem. I am going to upload some new fix in the PPA in next weekend. So better wait till then.

Captura de tela de 2018-12-16 11-07-09
Ubuntu Gnome and not Unity help.

I’d be quite happy to get rid of that “option,” only don’t know, which file/folder to delete, so it’d stop showing.

Any idea, which file/folder, guys?

1 Like

It’s built-in to yelp. Previously (16.04) Ubuntu patched yelp to use ubuntu-docs (help:ubuntu-help), no more.
So no way except to remove yelp which has some uses to some…

This is what happens, if I remove yelp,

sudo apt autoremove

[sudo] password for akoya:
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
gnome-user-docs : Depends: yelp (>= 3) but it is not installed
ubuntu-docs : Depends: yelp but it is not installed
ubuntu-unity-desktop : Depends: yelp but it is not installed
Recommends: fonts-indic but it is not installed
Recommends: fonts-kacst-one but it is not installed
Recommends: fonts-khmeros-core but it is not installed
Recommends: fonts-lao but it is not installed
Recommends: fonts-nanum but it is not installed
Recommends: fonts-sil-abyssinica but it is not installed
Recommends: fonts-sil-padauk but it is not installed
Recommends: fonts-takao-pgothic but it is not installed
Recommends: fonts-thai-tlwg but it is not installed
Recommends: fonts-tibetan-machine but it is not installed
Recommends: fwupdate-signed but it is not installable
Recommends: gir1.2-gmenu but it is not installable
Recommends: libreoffice-calc but it is not installed
Recommends: libreoffice-gnome but it is not installed
Recommends: libreoffice-impress but it is not installed
Recommends: libreoffice-math but it is not installed
Recommends: libreoffice-ogltrans but it is not installed
Recommends: libreoffice-pdfimport but it is not installed
Recommends: libreoffice-style-breeze but it is not installed
Recommends: libreoffice-writer but it is not installed
Recommends: unity-webapps-common but it is not installable
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

It wants to uninstall Ubuntu-unity-desktop, when I try to uninstall yelp.
@khurshid-alam, maybe all these be taken out of the meta package, especially yelp.

EDIT: sudo apt --fix-broken install reinstalled yelp, then I manually deleted /usr/bin/yelp and clicking on “Ubuntu Help…” doesn’t open anything.

Actually try leaving yelp but removing
ubuntu-docs, gnome-user-guide, gnome-user-docs
Though the resulting “Help” may be outdated?

(- I somehow thought that the useful unity-scope-yelp needed yelp but it doesn’t…

Thanks. Put back yelp, uninstalled the above. I am actually doing this in 19.04, for I don’t have any 18.04 installs.

Is the repo necessary for a general user, like my dad?

Also, I installed Nemo, but for some reason, I couldn’t change the wallpaper. It worked fine when I did the same thing in 19.04.

All of a sudden my Unity desktop on both of my Bionic machines have become practically unusable and I’m not sure why. Only symptom I can see is the indicator-datetime process is hogging an entire CPU core, and eating up 5 Gb of memory. Not sure why, as I haven’t applied any new maintenance or software over the past week. This started happening yesterday. Both machines are at Bionic 18.01.1. One is a Thinkpad T420 with 8Gb of memory, the other is an HP Pavilion with AMD CPU, and 16Gb of memory. Ideas?

Hello everyone. Finaly i had some time to upgade from 16.04 to 18.04. I removed gdm3 and gnome-shell. I think that Unity is working very good under 18.04. Because the sharing panel was not working I added the Unity7 maintainers ppa. So actually I am on the ppa version.
Of course there some things that are not working:

  1. The minimize on click is making Unity stuck. I need to go to a tty to reboot. I know it is not supported but on 16.04 minimize on click was working. So I have disabled it for 18.04.
  2. The icons on the keyboard indicator on the unity greeter are missing. The icons are present when I lock the screen.
  3. The dual monitor behaviour is strange when the unity launcher is activated on both monitors. A workaround is to put it only on the main display.

Found my answer. Google changed something and now the Calendar is constantly trying to sync with it. I disconnected Google from my online accounts and everything is running normally. I have the calendar and contacts syncing through Thunderbird anyway so I didn’t need Gnome to be doing that too.

1 Like

All people in this forum, both developers and testers, deserve the absolute recognition of the effort they make to maintain the functionality of Unity Interface.

Taking into account the announced prolonged 10-year support for the 18.04 version I consider priority an attempt to “polish” all small imperfections that are still present.

Most of the crucial functionality has been kept, but little imperfections as previously mentioned Help system or say the inability to show username on the toppanel (although the option is turned on) are still present. All this are small things that somehow “ruin” out of the box experience in an attempt to preserve Unity interface as relevant and viable option for wider audience.

Parallel development and testing of future versions (19.04 and up) is definitely needed, but due to the limited resources I certainly think the priority should still be “the ironing” of 18.04 version.

No matter of bug tracker reports, it might be a good idea to make a list of all the minor shortcomings at one place, so that developers and future testers have an easier overview of all the possible glitches they need to test or try to correct.

2 Likes

@khurshid-alam, @dale-f-beaudoin @mc3man, and others

I believe @blue239 is right about 18.04. Better give a good look at 18.04 and keep it going, that is, if Unity 7 with Ubuntu base to succeed. Unity 7 is not going to become better, meaning developed further. As it is, and as a menu, and a DE, Unity is at its best working with 18.04. The future Ubuntus are not going to be as good it was before. It would be best to add newer kernels to 18.04, rather than adding newer Nautilus. Let’s keep Unity at its best.

That so called “10-year support for the 18.04…” has been grossly misinterpreted. 99.99% it has nothing to do with regular desktop users at all…

3 Likes

@chanath @blue239

No matter what version is known as LTS, when 19.04 releases People will install unity and they will find it broken. Also there FTBFS for indicator-sound and other unity components in disco which takes precedence. Without fixing those bug you won’t be able to login unity. So I had to fix those bugs.

Beside I can not land any patch for 18.04 because now everything has to go through SRU. Then it goes into https://bileto.ubuntu.com/. For example, I changed unity-control-center version number. But even something as simple as that could even land. See https://bileto.ubuntu.com/#/ticket/3577. So I had no choice but to fix in disco/19.10 , only then I can make them sru-ed

You can always ask in #ubuntu-desktop (but be polite about it). But keeping up with debian/unstable is more tedious job than you think. Something is breaking every minute.

And We are using trello to gather all related bugs

1 Like

Thanks for the detailed explanation of the procedure for Unity patching.

Now we can see much clearer what are the reasons that remaining minor errors in v.18.04 still exist.
Unfortunately there seems to be a lack of “flexibility” throughout the “system” despite all yours
tremendous efforts.

When we look at how many problems there are in adopting Unity for 19.04 version, somehow
I’am not very optimistic. Anyway I hope I’m wrong and you’ll succeed in achieving everything
in 19.04 cycle and further.

I hope can solve this problem if any one want to make a new version Unity package

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1750273

On Ubuntu 18.04 unity ,this can be solve by add this ppa

https://launchpad.net/~arter97/+archive/ubuntu/unity

I want to install the least amount of ppas into an iso. Users can do this on their own. As fixes come down, that can be commited to the unity packages but I have no idea as to time frame.

I appreciate your time and input.

regards…

1 Like