Testing unity-session in 18.04

Yes sorry, forgot to mention that.

I only found the hard way and took me ages to diagnose why unity settings wasn’t working.

I tried the same and had the same problem. Sorry again.

Ah don’t be sorry, this was ages ago back when they changed it (was it in 17.10 maybe?)

Unity settings in 18.10

10

Finally installed Bionic on a physical laptop (Lenovo Thinkpad T420) and installed the Unity Desktop. I found a couple of strange behaviors:

  1. I cannot disable the touchpad. When I open the “Mouse and Touchpad” settings, there are only entries for the mouse. I can’t STAND the Touchpad as I’m ALWAYS accidentally touching it and making the cursor jump all over the screen. How can I disable it?
  2. I noticed the Bionic does not have an /etc/rc.local file. I created one to disable the bluetooth on start-up. Oddly enough, when I boot the computer I can see the bluetooth icon indicating it is disabled but as soon as Unity completes initialization, bluetooth is enabled again. How do I stop that??

Thanks in advance

  1. Install the xserver-xorg-input-synaptics package;
  2. You should try to remove the bluetooth manager from Startup Applications in Unity.

Thank you for the quick response. You helped me fix BOTH issues.

Just a thought, but shouldn’t xserver-xorg-input-synaptics be included with the other packages installed alongside Unity Desktop?

Glad to help!
Well, I think it’s not included anymore since 17.04 or 17.10, if I’m correct…

ctr+alt+t to start terminal doesn’t work in unity session for Nvidia driver. With nouveau it works, but it stops working after installing the Nvidia driver

Graphic card Nvidia GT560M, driver 390.87

It works in gnome shell. And works in unity if logout, log into gnome shell and then log back into unity.

P.S same for print screen

P.P.S Shortcuts work now after switching to Nvidia-340.107. Not sure why 390.87 appears to work with gnome shell and on unity except for some keyboard shortcuts.

Hmmm. There is something wrong with unity session in 18.04 afterall. I just installed 16.04 on same machine with same nvidia-driver 390.87 (from graphic driver ppa) and all the shortcuts work.

Keyboard shortcuts problems are not unity specific. Xorg is involved. See this thread for xorg. See bug #1188569 and read my comment

Hi,

Not sure if it is the same issue. I noticed that ctrl+alt+T in unity has not been as responsive since 17.10, that is probably related to the bug you post. But in this case the issues are very much related to the Nvidia driver used. For noveau and Nvidia-340.107, no problem with shortcuts (save the a bit laggy ctrl+alt+t since 17.10) With Nvidia390.87, cltr+alt+T and printscreen not work in Unity but work in gnome shell

What is the output of

gsettings get org.gnome.settings-daemon.plugins.media-keys terminal

&

update-alternatives --display x-terminal-emulator ?

For me it is<Control><Alt>t but for some it is <Primary><Alt>t, Nvidia still messing things…

Ctrl+Alt+T opens the Terminal, doesn’t it? Printscreen and this works with Unity. It did in 18.04 and now in 18.10. I don’t have 18.04 any more, it had moved to 18.10. I have only Intel graphics, though.

It is Control + Alt t In fact I tried creating custom shortcut for gnome-terminal in settings, still not work.

It works on intel machine . On this Nvidia machine it works for noveau and nvidia-340.107, but not for nvidia-390.87 .

I found the root cause. Unity uses legacy keygrabber code depending on xdg env variable DESKTOP_SESSION. But since artful DESKTOP_SESSION is “unity” and not “ubuntu”.

The fix is in unity7-desktop ppa.

https://code.launchpad.net/~unity7maintainers/+archive/ubuntu/unity7-desktop

In 18.10, add the ppa (ppa:unity7maintainers/unity7-desktop) and upgrade unity-settings-daemon and libunity-settings-daemon. Then restart.

Now all shortcuts works as expected. (except the issue with xorg)

Note: The ppa also has the fix for sharing panel.

I will update the ppa for bionic later.

Update: It is also updated for bionic.

3 Likes

There is any other workaround for this? I just install unity desktop using ubuntu server 18.04.1 and can’t find a way to sync with my nexcloud