Testing unity-session in 18.04

I think would like application unity 8 maybe help ubport i see ubuntu file manger, ubuntu music app, dekko and ubuntu terminal.

As big of a Unity 8 fan as I am, I don’t think adding Qt dependencies in the Ubuntu desktop should be an option. Otherwise, we would probably be using Dolphin right now, as Dolphin seems more compatible with Unity 7 than the current Nautilus (it works with both Global Menu and LIM) and I’ve seen it running under Unity 8 too with LIM (though Unity 8 is a Qt desktop). I thought what we are doing here is testing Unity 7 with the default apps in the Ubuntu default .iso and hunt for bugs / glitches.

All the Unity 8 apps are great, I might help Ubports after we make 18.04 Unity a good, non-broken LTS. Even now, I’m currently ultra part-time tester here.

1 Like

Gentle Reminder:

This thread is for Unity 7 testing toward near-term (18.04) deployment.
Lets all try to stay on-topic in this thread.

Other topics, while interesting and worthwhile to dicuss, are a distraction in this thread.
Please open a new thread for discussion of future Unity 7 concepts, or Unity 8 concepts.


I was testing the latest build from Dec. 27 /17 on a touch device Acer mobile laptop. It worked perfectly with workspaces enabled and i could drag apps through the screens but then it booted into modesetting and now compiz workspaces will lock up. Otherwise it works very well with standard desktop.

I’m seeing almost no issues to date with unity in 18.04 though it’s still early.
One issue is likely not just on unity though more easily exposed. It’s that some menu dropdown options are light until moused over, can be seen in ccsm pretty easily. But I’ve also seen in default 18.04 like in a debconf popup about which version to keep…

What is an issue is that alt+print does not work properly, here it either prints the entire desktop or the hud command box.
I’ve a local fix by integrating gnome-screenshot -w as a compiz command, binding command to alt+print & disabling alt+print in gnome-settings-daemon.
A more proper fix would be good.

Just a reminder… we can now install unity with;

sudo apt-get install ubuntu-unity-desktop

which is now the meta in universe.

I’m not sure that unity-session is still available in universe. I’ll check.



I believe you filed a bug on this ?


The old issue is back. The new bug is this:


  1. press and hold Print Screen
  2. press and hold Alt
  3. release Print Screen (and then Alt)

This seemed to work for me, but it shouldn’t be necessary.

This could be systemd issue. What happens you disable the “Magic SysRq Key” using sudo sysctl -w kernel.sysrq=0. Does it work for you?

This also has something do with 1683383 (key press vs key release) where Ubuntu removed 5 years old patch from xorg.


The keybinding deal works, here it’s just press & hold print, press & hold alt, release print
Thw sysrq one does not.

what has disappeared is some or all notifications. Most obvious is mouse over volume indicator, then use scroll wheel to raise or lower volume. No notify overlay…

I can’t reproduce this. Is notify-osd installed? If it is try to restart the process.

My Bionic Unity with your ppa bionic-prop works pretty well with Nemo, and without Nautilus (uninstalled). Unity Tweak is there and with full Compiz eye-candy. Hope you’d keep that ppa upgraded. Thanks! :slight_smile:

That works, seems notify-osd is no longer on the image & not a recommend of unity.

The hope is that Andrei puts out bionic packages in his nemo3 ppa, I think he will.
Then on a personal level the appearing/disappearing xdg-folder quicklists entries bother me. If not solvable I’ll have a personal ppa version but not likely to have a ‘competing’ ppa for nemo.
For the moment I’ll keep it up, just added a few things
nemo-media-columns using pyPdf2
unity with slight changes, changelog

  • Add back systray icon support
  • Set spread all windows, window group, to crtl+alt+z
    • single hand usage
  • Set notify-osd as recommend

nemo without #12 patch, switched default .desktop icon to user-home, renamed to File Manager english only I suspect

1 Like

Hi. Im testing ubuntu-unity-amd64.iso (http://people.ubuntu.com/~twocamels/archive/), all is fine, not crash, etc (only a minor issue con WPS office and the libpng12 dependency). But it is working on low graphics mode, not blur on dahs or lateral panel (transparency), the windows not move when you drag it (only a orange transparency), etc. I tried to descativate the low graphics mode on compiz setting but the option has gone. Is it normal? (maybe the developer desactivate the full blur for some reason)?! I have a intel core i3 4150 Captura de pantalla de 2018-02-08 16-10-19|690x374

Thanks from Mexico.

Low graphics means your graphics is not supported. The iso uses a broken mesa. Update your system and try again.

Edit: Thanks, I solved the issue, I just went to the appearance menu on configuration menu and activate the graphics effects.

Hi, actually I updated the system but nothing, the system is on low graphics mode yet :frowning: . What iso is the official?

I have to go into the appearance settings and there is a setting under the second tab to enable the nice effects, on 16.04 I don’t have to do this, unsure why this version defaults to the low version.

Also why is the left dock a weird colour? It wasn’t like that in 16.04?

@dale-f-beaudoin Just wanted to check where is best to raise issues like the color of the dock above? Is this the right place? Can’t wait for this to be released :slight_smile: Going forward will GTK3 themes and icon sets e.g. Numix still work on this via unity-tweak-tool as this project/Ubuntu/themes/icons themselves evolve…?


This is the place.

Check “about this computer” and if you see llvmpipe then your graphics is not supported as with 16.04.