Testing Ubuntu 20.04 LTS & official Ubuntu flavors

What about it? I don’t see anything strange …

I’ve been testing 20.04 since yesterday and noticed the virtual desktop switcher overlay image is really small. A lot smaller than in previous versions of GNOME.

I don’t particularly like it, but either way, don’t know whether this is a technical issue or just a design decision?

Sorry everyone, me again. Just two other observations:

  • I don’t see the regular Ubuntu Software store anymore; is it replaced with the Snap-store altogether? Again, I don’t know if this is a design decision or a technical issue.

  • Are the stock GNOME icons for core GNOME apps being replaced with Yaru icons again? The Nautilus icon has been replaced with the Yaru icon again. I thought this went against the arrangements that were made with the GNOME community? …

3 Likes

The smaller virtual desktop switcher overlay is probably Yaru.

Ubuntu Software is officially replaced with the snap-store. Is ubuntu-software going to be remove for snap:snap-store?

3 Likes

Well, we’re still pre-beta release. :wink:

Piper won’t update on Focal.

Gnome-weather is super slow to show the weather info. I wonder if it should be recompiled to pick up “something”:

We had that once and it was fixed by just updating to the final gnome-weather version. But an upgrade to 3.36 is impossible because there is no 3.36 version of gnome-weather (not even changes on gitlab master). I would give it a try to just recompile it.

1 Like

Potentially @jbicha came to the rescue and updated libgweather to 3.36.

Entpacken von libgweather-common (3.36.0-1) über (3.34.0-1) ...

Probably that is the “something” that a gnome-weather recompile would have to pick up. @seb128, could you try to trigger a recompile?

I’m experiencing heavy load on my system now. I don’t now what was updated lately but the fans go crazy when GDM is loaded. When I login, the system is completely unresponsive and I can’t start any application. Didn’t notice that behaviour today morning.

Hmm. Everything is smooth here with all current updates installed.

Hi, I am experiencing a weird USB issue on cold boot - I’ve built a new Ryzen 3900x with an extra PCI-Express card with USB that I use for PCI passthrough to a VM on the machine. With a cold boot the USB card is nowhere to be seen (dmesg, lspci, etcetera). If I do a shutdown -r now and wait a bit for the reboot, everything works like fine.

Relevant hardware:

What I have already found or tried:

  • Upgraded bios
  • Other PCI slot
  • demsg and lspci search

Does anyone have any idea where to look further to get to the root cause?

Any extension’s settings doesn’t open from Gnome Tweaks, or from https://extensions.gnome.org/ in Ubuntu 20.04 with GNOME Shell 3.36.0.

Checked with Arch Linux (GNOME Shell 3.36.1). Any extension’s settings open from https://extensions.gnome.org/ , but doesn’t open from Gnome Tweak.

(Of course, this problem doesn’t appear in Fedora 31 and OpenSuse Tumbleweed, as they have GNOME Shell 3.34.4. In them both Gnome Tweak work.)

Settings don’t work in some extensions because gnome-shell-extension-prefs is called, to enable settings, but this app isn’t installed default. That’s the case in e.g Dash to panel and Openweather. Fedora 32 had the same problem some days back.

1 Like

Agreed, once I installed ‘gnome-shell-extension-prefs’ the settings worked. Strange that it isn’t a dependency of either app. I’ll let @chanath file the bug, I know he prefers to. :wink:

Bug #1868932 was filed about a week ago but has yet to receive any official acknowledgement.

May be filed against the wrong package or perhaps what we users are seeing is just part of work in progress. :confused:

1 Like

@stephen-d-allen
Just informing.
All of them, Arch, Fedora, OpenSuse devs know that their users would surely use the gnome extensions, so everything needed is already installed, whereas Ubuntu tries to keep the users from using extensions. Those, who’d use extensions would install the missing gnome-shell-extension-prefs and get everything going. :slight_smile: It was there, but got uninstalled after an update, btw.

1 Like

Thanks @paulw2u. I wonder if the extensions tab will be removed from Gnome-Tweaks? I had thought that the ‘extensions’ app was replacing that functionality in Tweaks.

Beta is on Thursday. Everyone could help out, so please do!

And as stated as fossfreedom and I believe is mentioned but not enough-if you recieve a bug, please, please use ubuntu-bug to make an actual report instead of listing down what happened in QA, otherwise nothing will change. Directions are on QA page.

And yes, if anyone is wondering Ubuntu Cinnamon ISO will be out Thursday.

I have created an bug report regarding this https://bugs.launchpad.net/snap-store/+bug/1870184 please go to the bug and click on it effected me button so that it gets higher priority to the developers. Thanks. :slight_smile:

If you’re experiencing WiFi performance with Intel WiFi drivers being slow, remove backport-iwlwifi-dkms. The performance is back to the way it should be with it gone.