Results of testing 3rd party applications on 64-bit only eoan (19.10)

Good idea. Done.

Sparx Systems Enterprise Architect
UML modelling tool. Requires i386 libraries (and Wine…). Source:

CodeWeavers CrossOver
Commercially supported Wine. Requires i386 libraries. Source:

1 Like

2 posts were merged into an existing topic: Dropping 32 bit support (i.e. games support) will hurt Ubuntu. Big time

I don’t use Steam nor Wine, but to also gain experience with 64-bit only, I did this on my 19.04:

sudo apt remove "*:i386"
sudo dpkg --remove-architecture i386
sudo apt-get update 
sudo apt-get upgrade

… nothing was removed. Is that correct?
I will do a reboot, and check again.

@jonkers install libc6-i386 - you’re seeing the same thing I saw with braid. This is expected.

And Community can’t do that why?

Hmmm. It seems my tests are incorrect; on a normal, untouched 64-bit system (so: able to run 32-bit progs) I was neither able to run the 32-bit hello-world-program. It appeared I had to do this first:

sudo dpkg --add-architecture i386
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

… and after that the 32-bit program worked.

I will remove my other two comments.

Ah, now I understand your comment. Thank you.

As i posted elsewhere In some enterprise settings there is the need for an impact printer and one of the few companies making one that doesnt cost an arm and a leg (looking at you Oki and your Epson PCL compatible printers) Is Lexmark. The downside is their printer driver for something like the 2590+ is NOT 64bit compatible nor is it CUPS compatible. It uses its own print manager that is basically a glorified java machine. This depends on a 32bit instance of Oracle Java as it didnt play nice with IceTea or OpenJDK. This with the fact that only an RPM is provided for the printer and thus needs to be extracted and manually installed on non RPM based system. No Alien will not work, i tried. Wine will not work with the printer and the windows driver at all leaving the world’s most affordable impact printer out of the loop for those in the enterprise setting if this removal of 32bit compatibility is put through.

Driver Source:

Hi popey when you use a bottle to set the arch for wine does that work without the 32bit binary? If it does that might be the way around the issue.