Nvidia state in Ubuntu


I reported my Ubuntu (Jammy and now Lunar) experience here:

The Wayland statement is quite rude but even X11 one is not really good. Particulary annoying, I cannot use my laptop with an external monitor without jerkiness/glitches using hybrid graphics (quite problematic when using in a hall with students all day) (yes I know, Legion laptops have a big power brick too).

Well @vanvugt @3v1n0, that’s hard to know what to do, for an user like me. I know that any-bug-should-be-reported :slight_smile: and Nvidia drivers are not free but at least I’d like to know what is known from desktop team, what is GS/Mutter fault or Nvidia. For Nvidia it seems better to report in their Linux forum ?

I already reported in launchpad this one:

(Thanks again Marco for g-c-c display settings I can now apply all in a row!)

1 Like

There are some known issues you should be aware of:

Hybrid X11: https://launchpad.net/bugs/2011817 (the issue is Intel here, not Nvidia)
Hybrid Wayland: https://launchpad.net/bugs/1970291
Discrete Wayland: https://launchpad.net/bugs/1970389

This is why Nvidia systems will be offered X11 by default in Ubuntu. And upstream hides the Wayland option completely if the Nvidia driver is detected. The full list of Nvidia Wayland issues is here.

Please continue to report new issues as bugs.

1 Like

Also since you’re using 23.04 please be aware that performance is currently reduced while I rewrite triple buffering to support GNOME 44. The first release candidate patch was completed last night so I expect triple buffering to return to Ubuntu 23.04 within the next week.


Ok I realize that I already suscribed these bugs.
There’s one point I do not understand: if I use Nouveau in an hybrid Wayland session, there are severe issues I wrote about but GNOME desktop animations are smooth.

I filed another (security, classical) issue:

I’m trying again Nouveau/Wayland using latest 6.2…-19 kernel.

  1. it runs smoothly
  2. it has some obvious bugs (with monitors, at least)
  3. GNOME Shell is much more responsive than using Nvidia-525 (or 530 latest) / Wayland (eg. launching Nautilus, GS Prefs, etc.). I feel like having another laptop! :face_with_monocle:

Some resume from sleep issues too, but I ran into it with Nvidia drivers too…

Well, that’s quite complicated atm with Nvidia Hybrid to find a combo that is ok.

While testing non working VLC snap (bug reported), I noticed X11 hybrid session to be quite good now, using latest 530 drivers from graphics PPA. Absolutely not the ugly roughly 0.3 FPS I got some time ago in Lunar.

If you’re using hybrid X11 and disable the laptop screen then you might have hit bug 2009767 before. That should be fixed in the latest upstream 530 driver and will also be fixed in the next 525 update.

still useful nowadays in Ubuntu with 525-530 series ?
I believed it’s not but I often read such a workaround.

nvidia_drm.modeset=1 is the default now so you shouldn’t need to set it anymore…

If you change the value to zero then it will definitely break Wayland. Xorg should be fine with either value (though it might behave differently?).

It seems that the severe artifacts with some windows in Wayland dGPU Nvidia session have gone.
I suspect this in Mutter 44.1 update (I do use Mantic)?

I noticed that creating a 2nd Firefox private window (deb from mozilla ppa) makes FF sluggish and unusable, using dGPU Nvidia Wayland session. I had this bug a long time ago, afaicr.


  • Fall back to the default, not the unknown color space [Sebastian W.; !2915]
  • Fix resizing windows via keyboard [Florian; !2908]
  • Fix possible screen freeze after resume with multiple monitors [Daniel; !2933]
  • Fix anchor position when dragging window [Carlos; !2942]
  • Fix applying XSettings to decorations on X11 [Marco; !2948]
  • Allow clipped redraws for headless backend [Salman; !2775]
  • Improve screencast support [Georges; !2804]
  • Fix focus-on-click for server-side decorated windows [Carlos; !2954]
  • Fix initial fullscreen state of server-side decorated windows [Carlos; !2961]
  • Fix feedback loop triggering bursts of excessive CPU load [Robert; !2823]
  • Enable modifiers by default on non-native backend [Robert; !2972]
  • Check EDID for supported sink Colorimetry [Sebastian W.; !2919]
  • Fix artifacts in titlebars on some hardware [Carlos; !2976]
  • Fix map transitions for X11 windows on wayland [Carlos; !2975]
  • Fixed crashes [Jonas Å., Sebastian K., Carlos, Michel, Daniel, Robert;
    !2932, !2930, !2945, !2956, !2962, !2968, !2967, !2960, !2963]
  • Plugged leaks [Sebastian K., Jonas Å.; !2922, !2926, !2957]
  • Misc. bug fixes and cleanups [Daniel, Ivan, Emmanuele, Simon, Jonas D.,
    Jonas Å., Chris, Florian, Corentin, msizanoen1, Sebastian K.; !2918, !2904,
    !2928, !2929, !2900, !2856, !2944, !2935, !2947, !2949, !2951, !2940, !2953,
    !2964, !2934, !2902, !2971]

Hi Daniel,

Do you have managed to solve https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/6146#note_1768458 upstream?

In Mantic, I still get this dGPU gnome-shell thread using a on-demand session.
The proposed workaround:
export __EGL_VENDOR_LIBRARY_FILENAMES=/usr/share/glvnd/egl_vendor.d/50_mesa.json
in profile is safe and a good one?
It works to remove this dGPU thread.

Anyway the background: I get a very bad power level using my laptop (Legion Intel + RTX 3070 + kernel 6.3, on-demand) and Nvidia (at least 525, 530, 535) drivers.
I know I can reach ~8W (using Nouveau) when I get ~20W (using Nvidia).

And I notice one bug, using Nvidia dGPU mode and Wayland session (only this combo):

  1. open Firefox (I use Mozilla ppa’s deb)
  2. open a new FF private window
  3. only after enter/exit overview this window becomes responsive

Against which package should I report?