New Desktop Installer Preview Build

Tried a QA-test type of install on

  • hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

disk contains QA-test installs of impish,

  • lubuntu (originally full disk install)
  • lubuntu (install alongside; so auto-resize)
  • ubuntu mate (I forget; equivalent of install alongside/auto-resize)

Install shows 3 partitions sda1, sda2 & sda3

I selected sda1 & it offered ‘ext4’ & pre-selected format; mount-point was empty (intention being to replace one install with a new install using this ISO).

I left it ext4, unclicked format, & set mount point to “/”

I cannot hit OK though (it’s grey), only cancel.

Switching the format to no-format still only lets me cancel.

My intention was to replace one the prior installs (with no format; I added some MP3 files & clementine package to play them on) post-install thus the no-format first attempt.

Trying the same process with the other partitions results in the same; ie. I cannot hit OK being allowed only to CANCEL. No messages are shown on screen, I cannot continue; only cancel.

ISO 2021-10-10 (downloaded from


Thanks for testing the new installer!

We should probably add some notes about the current status and known limitations, partitioning being one of those. We currently only handle creating partitions on a newly formated disks and using existing partitions.

Checking your post again, that’s the wrong url and ISO you tested, there has been a new build but the location changed since impish is a stable serie now, the unversioned one is the for the new Ubuntu serie


I would also like to test the latest ISO - can you post the correct link? I only find the canary Impish ISO.

thanks in advance…

You can download the latest ISO from (instead of


Tested latest ISO from (21.10.2021)
Box used for testing:
Dell [ Optiplex] MT 7060, i7-8700, 32 GB RAM, Intel HD Graphics 630, Intel i219 GB Ethernet, Samsung NVMe 256GB hd

Comments - UEFI+secure boot - full disk install - all went well - below times taken with stopwatch -
Boot to desktop - 2 min 46 seconds (very slow) the install 2 min 30 seconds after selecting user etc -

For comparison I also installed on the same box Impish released ISO -
boot to desktop - 1 min 8 seconds - install 4 min 32 seconds

1 Like

We are mostly interested in automated desktop provisioning. With the new installer sharing the subiquity back-end with the server installer, will we be able to use similar cloud-init styled syntax to provision desktop hosts using this new desktop installer, too?

If so, the more desktop-specific issue of configuring Nvidia + Secureboot at install time ( which is currently possible manually in your current desktop installer ) would be a big win for us.

Thank you for your work on this project!


I think the installer could benefit from having more graphics like the older one does.
It could be off putting to new linux users who are used to things looking nice if the installer is a lot of
black text on white background.

same box as last time

  • hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

ISO 2021-10-21

I selected sda3 & formatted it ‘reiserfs’ for / & it accepted it, and continued. Whilst inputting my username etc. I got a problem detected message, I clicked OKAY and it closed.

I continued completing details & continued. I get the slideshow now as if install is occurring… though message lower right on the picture reports

“Something went wrong \n\n Please restart the machine”

then five lines of dmesg type logs (mkfs) type commands.

I followed prompts to report message when it appeared; but it doesn’t open firefox; instead I get a text editor with some <html><head><title>OpenID transaction in progress</title>...


  • the slideshow continued until I gather it got to the last slide; so it looked like install was still taking place. Yes it said “Something went wrong \n\n Please restart the machine” but that was easily missed (I missed it for a time) being red text on purple background…
  • opening a text editor with & some code (for (var=0;i<elements...elements[i].style.display... isn’t very helpful; with a OPEN top left & “SAVE” on the top right; the title “fb544e6-3569-11ec-b…?field.title=install+crashed+with+CalledProcessError” isn’t helpful.
  • the white text below the slideshow was very readable in contrast, but it only showed mkfs commands & stopped. A message ‘install aborted’ would have been noticed if here.

Looking at terminal; the error I believe is media … no check completed successfully (in journalctl) but instead "Check finished: errors found in 2 files! which could very well mean the program code I ran itself is flawed; this feedback invalid/unhelpful anyway.

Anyway - I could select one of the partitions; and go to start install (further than last time)

1 Like

Right, I noticed that as well and I think it’s probably something to fix in ubuntu-bug triggered by the lack of browser alternative since we are using firefox as a snap instead of a deb.


Hi @jcampbell - the plan is to use the same autoinstall / cloud-init syntax for ubuntu-desktop-installer. That autoinstall feature is temporarily disabled right now because there is some enabling work for ubuntu-desktop-installer that is not yet done and required to support autoinstall.

Nvidia + secure boot is in plan for the 22.04 cycle - we have work tasks for ubuntu-drivers handling, and for providing the backend for key enrollment to support Screen 7 - Configure Secure Boot.


some more play on a testbox [ISO 2021-10-21]

  • hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

it still has three partitions; sda1, sda2 & sda3

sda3 is likely corrupt (failed install was attempted to it last time), but sda1 & sta2 were RC install of impish and I believe still good. .

I select JFS, format & / as mount point for sda3; alas … I had what felt like weird behavior so used Go Back to try and explore… I couldn’t re-create it though and I won’t describe what I saw until it occurs again…

I did however EXIT the installer after selecting ERASE DISK and INSTALL Ubuntu (just exploring looking for the weird behavior, and as erase disk isn’t what I wanted [I’m a user; we do strange things, change our minds etc]), where I did what I suspect most users would do… hit to RED CROSS top right to close the program.

On re-starting the installer here, (tried twice), and on both I got

sda1 1MB
sda1 ext4 75GB

my real partitions are not shown !!

If I load gparted it instead shows

/dev/sda1 ext4 17.87GB
/dev/sda2 ext4 28.72GB
/dev/sda3 extended 27.94gb
unallocated (what is likely rubbish; failed install last time)
gparted did give an error “Libparted Error - Invalid partition table on /dev/sda - wrong signature on it”

That error maybe new; OR the result of last failed install las time; so I’m not worried about it… My intention was to just install into sda3 with format thus fixing any potential issues in that partition.

sda1 & sda2 should be untouched

I’ve clicked no acceptance of changes.

I also tried again with sda3 and selecting other formats; if I exited the program (using X top right), when I re-entered the program it would say sda3 was whatever format I’d last selected & not what I’d actually attempted to use/format it last time which is what I’d expect (unknown would be acceptable to me; not what I last picked in the canary installer but didn’t proceed with).

Sorry - this will be confusing & messy.

Summary - on exiting program; & starting installer; it appears

  • to remember settings that were last selected, but not actually utilized (ie. no format occurred that I’m aware of)

  • twice on re-entry it had a very different map of my drive to what I get from gparted & not what I expect.

Now it’s possible it did start formatting; or the disk does have errors; on rebooting it - I’m not getting grub again (just grub rescue); however sda3 was my last install (with ubiquity & failed canary installer; and all I touched today) so that doesn’t surprise me… entering a few commands (into grub rescue) & I can boot a Lubuntu/sda1 as expected… (I’d expect the same for sda2 too)… update-grubcorrectly detects itself (sda1) & sda2 (21.10) but not sda3 (corrupted; but that’s where I was playing so mess is expected there).

addendum: update-grub & grub-install /dev/sda gets errors I’ve not seen before (embedding not possible; blocklists.…) I’ll assume (given prior error) partition table has errors & start again on this box.

I then did a clean install to box; no issues.

On reboot was going to do the next install (install alongside in calamares, or auto-resize; but option doesn’t yet exist)…

exited canary-installed; used gparted to shrink install; the re-started installer… selected new area & selected JFS for /, but i was unable to click FORMAT the partition. As there is no fs there; I’d expect it to be auto-tagged; but I cannot click format… On clicking OK the format column is checked - ie. it does what I want; but will users be worried they couldn’t select ‘format’ when in the area (it wasn’t actionable - would be best if something to indicate a format needs to occur given I changed fs maybe).

this install started & progressed before problem detected & opening of text editor instead of firefox… (the contents in text editor fed to firefox manually)

@guiverc - thanks for the detailed analysis. I think the fix for this won’t be so bad. We have multiple cases now where packages that need to be installed at install time aren’t in the package pool - ‘jfsutils’ in this case. I’m already looking at fixing the pool for a different problem.

Tried canary build (jammy now) 2021-11-01 on

  • sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)

I cannot select a keyboard layout. I have none to choose from? I can use the “Detect Keyboard Layout”; but other than that my go back.

System problem keeps popping up; still opening the text editor, with close button exists on installer…

On exiting & restarting the installer I do get a list of keyboard layouts this time? so I can accept English(US).

I’ll reboot & try this again… (I wonder if I accidentally touched the wrong language at first screen; I tend to use this device for screen QA-test & can mis-touch with my fat fingers).

On restarting system; starting the installer I get the English(US) option offered. No system problem detected so far this boot, and install is progressing - so better this time.

this progressed and crash :frowning:

on restart of system, it fails to boot (vaio failed to start & offer to boot recovery or BIOS setup)

The error at the end of the installation is probably the one being worked on there, it fails to install some deb packages probably because the system was offline and those are currently missing from the ISO

1 Like

This sounds a lot like the issue where the installer fails to connect subiquity still exists. I have reopened the issue for further investigation.

Thanks for the reminder. I opened a ticket for this a few days ago when it was first reported.

I repeated my last install with wifi connected (pinged my ISP to confirm it was up)…

Possibly still the same issue even with wifi available as (1949424 last time)

I may have started the installer BEFORE connection was made; (I’d entered key & it was connecting as I clicked installer icon; not waiting…) so could it have detected no wifi & set a flag to say no internet during installer setup? I did the CtrlAltT & ping of my ISP prior to selecting fields (ie. language, keyboard etc) in installer; so can’t confirm wifi was connected when I clicked start installer.

Thanks, let’s see what the subiquity maintainer say, reading the log the apt source don’t have an online mirror enabled and it ends up failing the same way as during offline installation because of missing deb packages

Updated my canary ISO, wrote to thumb-drive & tried to install on

  • sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)

boot ISO, connect wifi (hidden wpa2, 5ghz)
ctrl+alt+T to open term & ping ISP, 3 replies so ^C

start installer, go through process…
after entering the user data (me, sysname, password)

I instantly get a "install completed, reboot to use your 22.04.

This was instant install… way too quick in my opinion. I accepted the green message & installer exited

I expected box to reboot; it didn’t… so I restarted installer.
On re-starting installer; it’s at the first Keyboard layout screen again, with NO options available; just “Detect Keyboard Layout” and “Go Back”.

system problem detected - same as last time I gather

likely obvious; but failure to boot system on restart

what is the difference between the iso canary impish and that of jammy? which one should i use?