New Desktop Installer Preview Build

Installing in Virtual box directly from the ISO
I agree. That is the method I use when QA Testing new Ubuntu.
When I flash a USB I use Etcher. It checks the check-sums for a correct flash.
Etcher works on all OS’s.
Thanks for your post.

Instead of downloading the canary ISO I can install ubuntu-desktop-installer on a partition with Jammy, is that okay too?
Edit: so i may use the installer to install on a different partition of same PC.
Edit: installed … started: after 1St screen the screen ‘Keyboard layout’ is empty and does not allow to select the keyboard. … abandoned.

1 Like

Installed from canary ISO: Ubuntu 22.04 LTS “Jammy Jellyfish” - Alpha amd64 (20211126)
with ubuntu-desktop-installer 191
manual partition on a preformatted partition
INSTALL SUCCESFUL also if at end install I see an error message…
Screenshots and logs here:

1 Like

The resolution issue I mentioned in #38 has been filed under

On a question from @kbar, it was re-run, re-occurred & thus filing (on lp for filing on ISO tracker)

1 Like

Ubuntu 22.04 Jammy
Ubuntu amd_64 QA Test on new daily build: 2021127.
Bug 1952515 critical.
Gnome-Shell Crashed
Invalid core dump /tmp/apport_core.k657r8ti is truncated.
Manually started apport in terminal.
Bug 1952515
Unable to reproduce bug. Tested 3 times total, 1failed; 2passed.
Bug report invalid.

QA Testing AMD_64 Desktop: Daily Build/ 20211127
3 Tests on Live: 1 fail - 2 pass.
1 Test on Install w/ ZFS: pass.
1 Test on Install Entire Disk: pass.
1 Test on Install LVM & Encryption: pass.
1 Test on Install Manual Partition: pass.
Ubuntu 22.04 Jammy is looking good for AMD Desktop.

Another daily QA-test install (jammy canary) on

  • hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

My notes can be found here where the install worked :slight_smile: however I needed to run the installer twice to achieve install.

First time it disappeared (window closed) with no traces found, no errors in /var/crash/ or nothing that provided me with clues in dmesg. (after looking for clues but not finding any; ie. delay) I re-started the installer hoping for clues, and it started again (at first language selection screen) & completed this time.

I did note (in my comments) the first time the installer window didn’t have viewable borders; but this test box can have issues with GNOME/KDE with graphics (nouveau) so I was ignoring that as unrelated to the installer (in my opinion). On the second start (first session) that issue wasn’t apparent; but I don’t believe that’s anything useful.

Repeated install later in day… same graphic glitches occur, and they appear in screenshots…

On install; I got to see the slideshow start this time before the installer window closed without message… so the issue was filed & added to both attempts (this second session was recorded as fail)

Though second session was marked as failure (on, it may have succeeded (window closed without message) as I didn’t see the commands (df -h etc in CLI history`) when I rebooted which possibly means the install completed (overwriting prior install) despite install window having closed as box was left running for some time as I entered details into launchpad…

On booting install I noted

  • timezone is set to UTC, not my AEST (DST),
  • language set to US (mm/dd/yy not local dd/mm/yy)
1 Like

Hi everyone from the Ubuntu community and team, I’ve tried the new installer several times on VM, the first iso that came out and the latest version and I want to say what I think, to sum up what I think, I think the best installer currently is the one of Pop!_os, if this installer looks like it will be great.

I’ll tell you the problems I found in the interface, I want to help because it needs to have a nice and friendly design for new users:

1 - I thought the letters were very small and not centered, as “Welcome” should be bigger and be in the center.

2- the window is very large, at low vm resolutions it is very difficult to configure because the window is cut off.
3- it would be good to add animated illustrations in the installation to make it more user-friendly like in Windows 11 and Pop!_os
4- Being able to hide the installation code lines like in Pop!_os
5- “Access to everyone” can be prettier and better show the new features of the system, although a guided presentation of the system in the beginning of use after installation is essential.
6- Lack of rounded edges, I have it because it’s just beta and it was in vm but I hope they fix it in the final version.
7- “who are you?” it has to come after the installation if possible, because then ubuntu already installed would be perfect for the pc that will soon be sold to a new user.

About the (3) “it would be good to add animated illustrations in the installation to make it more user-friendly like in Windows 11 and Pop!_os”

About the (4) Being able to hide the installation code lines like in Pop!_os

Install QA-test on (jammy canary daily )

  • sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)

I don’t consider that box slow (it’s just annoying to me) but I noted the following

After accepting user values & next/continue, the window changed to what really looks like a crash dump; it was the messages appearing in the whole of the window though; and soon (~half-sec later) the slideshow started and reduced the full size messages to only a strip at the bottom. this isn’t very user-friendly/ideal I suspect.

It impacts nothing, but it’s not very polished in experience (desktop users are mostly consumers)

the install failed again but reported on tracker; point here is my 2c on user-experience that doesn’t belong in bug report

Addendum: did another install to

  • hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

where the same effect is seen (window becomes all log-messages before slideshow draws over top portion) but on this install/box it’s quickly replaced… on this box box it’s only a fraction of the time when contrasted to sony-vaio


QA Testing Jammy 22.04 LTS
I was unable to get the installer to start installing to the hard drive.
It is OK here… How did you start the installer. I have tried Command line…
Changing permissions for root as live user. Three days installer starts… goes off…No install. I have even looked at the inspect Q…nothing out of the ordinary… Other than The developers not having the ‘hook installed to start the installer’ when the logo is selected to install the OS to the HDD during manual partitioning. We Both agree …
QA Testing. results. Daily build 20212113 Canary Ubuntu 22.04 LTS
Hope before April 2022 they fix the installer. Tested the live boot of Canary Ubuntu Awesome x2 times.
I failed with your bug report 1951349

1 Like

Awesome work QA Testing for Ubuntu 22.04 LTS & Launchpad …!.!

Installer slideshow slide: ‘Make the most of the web’ says:
web applications … like Facebook or Gmail … can be pinned to your desktop …
but this seems impossible in recent Ubuntu releases after 20.04.


Just a quick confirm - tested 2 bare metal machines - QA Test results. Daily build 20212114 Canary Ubuntu 22.04 LTS and also received the same failures as reported above . Bug 1951349.


You are doing an awesome job QA testing Ubuntu Jammy 22.04.
Keep up the good work.
Thank You

1 Like

Finally had a complete errorless install.
ISO daily Jammy Canary Ubuntu 16-12-2021 machine tested Dell optiplex 7040

Tested 2 further boxes with one success and one failure.

See results here :


Ubuntu canary install from ISO Ubuntu 22.04 LTS “Jammy Jellyfish” - Alpha amd64 (20211215)
ubuntu-desktop-installer 0+git.f2a3bf7 2021-12-14 (214) 119MB classic
install failed with ‘install failed crashed with CalledProcessError’
crash not sent with message
The problem cannot be reported
This problem report is damaged and cannot be processed
PermissionError(1,‘Operation not permitted’)

After line 30 of /var/log/installer/ubuntu_desktop_installer.log
I see a lot of messages (loop?) like:
2021-12-15 15:24:43.468804 DEBUG connect_to_internet: Update devices: [WifiDevice(vendor: Qualcomm Atheros, model: QCA9377 802.11ac Wireless Network Adapter, state: activated)]

Screenshots, log and crash here


One issue I’ve reported before (I don’t know if ^ here or just in bug reports), is the closing of the install window & thus feedback to the user just ends…

I just did an install on old hp dc7700…

  • entry of user details
  • install window flips to messages that still reminds me of a crash dump with messages scrolling up the smallish window on the screen at first quickly then slower
  • 1-2 secs later slideshow is drawn (I know it’s the slideshow as I was waiting for it, but if this was a new user they wouldn’t know as it was on screen only a fraction of second)
  • installer window closes… thus no feedback from that point on.

I can open a terminal & using top see that rsync is in progress which I’d expect for an install; but I’d expect a end-user to click the install icons (dock or desktop) again which re-start the installer and don’t connect to the install-process in progress. I sit & type in bug report… and only reboot when I see evidence (disk led, top) that the install has completed, but no feedback is provided by installer.

This install worked (as I waited); but the closing window is still occurring, thus feedback ends.


Instalei a versão 22.04
ele destruiu meu trialboot (Ubuntu XP Win10)
Bootrepair nao conseguiu recuperar e nao consegui depois de unmeras tentativas voltar o grub anterior.
resultado. tive que refazer instalacao 21.10 do zero e dias de computador parado.