`multipass networks` command

Same issue in my case, running on Pop!_OS 20.04:

  • as the instance does not have access to the Internet (DNS resolution works fine, though)
  • tried also to use this LXD, as being Linux specific (and only? option)

So, installed LXD:

$ sudo snap install lxd
[sudo] password for dxps: 
lxd 4.15 from Canonical✓ installed
$ 
$ sudo lxd init
Would you like to use LXD clustering? (yes/no) [default=no]: 
Do you want to configure a new storage pool? (yes/no) [default=yes]: no
Would you like to connect to a MAAS server? (yes/no) [default=no]: 
Would you like to create a new local network bridge? (yes/no) [default=yes]: 
What should the new bridge be called? [default=lxdbr0]: 
What IPv4 address should be used? (CIDR subnet notation, “auto” or “none”) [default=auto]: 
What IPv6 address should be used? (CIDR subnet notation, “auto” or “none”) [default=auto]: 
Would you like the LXD server to be available over the network? (yes/no) [default=no]: 
Would you like stale cached images to be updated automatically? (yes/no) [default=yes] 
Would you like a YAML "lxd init" preseed to be printed? (yes/no) [default=no]: 
$ 
$ sudo multipass set local.driver=lxd
$ 
$ sudo snap connect multipass:lxd lxd
$ 

And then:

$ sudo multipass set local.driver=lxd
$ sudo snap connect multipass:lxd lxd

Unfortunately, the result is the same:

$ multipass networks
networks failed: LXD object not found
$

The same error is thrown when trying to multipass lauch-ing with the --network flag.

Any idea, please?
Thanks.

Hi @dxps, could you please open a bug report and fill in the details here? What does lxc network list say? Thank you.

1 Like

Hi folks,

I wrote down the steps to get it working because maybe some of you are having the same problem.

Instructions for running multipass on a bridge network

I would be happy to help you.

Hi folks,

I have created a new operating procedure that runs in Multipass 1.7.0.

https://gist.github.com/ynott/09dd668d47a523fd42e2781e7138680b

If you have any suggestions for this document, feedback is welcome.

2 Likes

It works for me on Ubuntu 20.04.4 LTS Desktop, but it fails on Ubuntu 22.04.1 LTS Server:

$ multipass launch --network eno1 
Multipass needs to create a bridge to connect to eno1.                          
This will temporarily disrupt connectivity on that interface.

Do you want to continue (yes/no)? yes
launch failed: Could not create bridge. Could not reach remote D-Bus object: The name org.freedesktop.NetworkManager was not provided by any .service files

and after installation of network-manager:

$ multipass launch --network eno1 
Multipass needs to create a bridge to connect to eno1.                          
This will temporarily disrupt connectivity on that interface.

Do you want to continue (yes/no)? yes
launch failed: Could not create bridge. Failed DBus call. (Service: org.freedesktop.NetworkManager; Object: /org/freedesktop/NetworkManager; Interface: org.freedesktop.NetworkManager; Method: ActivateConnection): No suitable device found for this connection (device br-eno1 not available because profile is not compatible with software device (mismatching interface name)).

With:

$ multipass networks
Name     Type      Description
docker0  bridge    Network bridge
eno1     ethernet  Ethernet device
mpbr0    bridge    Network bridge for Multipass

$ snap list multipass lxd
Name       Version        Rev    Tracking       Publisher   Notes
lxd        5.0.0-b0287c1  22923  5.0/stable/…   canonical✓  -
multipass  1.10.1         7689   latest/stable  canonical✓  -

I guess it’s related to that Ubuntu server uses systemd-networkd and not network-manager to control the network interfaces by default. And just installing network-manager does not enable it.