Mir-kiosk on a raspberry pi3 with Ubuntu Server 18.04

Thank you @ogra, i have seen that, i just have to wait :upside_down_face:.
I have to setup a Kiosk and i wanted to use a snap based system, at this point i have to give-up using Ubuntu and wait for accelerated GL.
thanks very much to everyone for the support.

Hi @menarcarlos,

Hope you are doing great!

I am trying to achieve the same as what you achieved using the Ubuntu server. Went through all conversation and steps but still, it is not working for me.

At the end of your conversation you have mentioned that you will share the document for that, can please share it with me that would be very helpful for me?

it might be more helpful if you described what you tried in detail, what failed and if you give us the exact errors we can help you along :slight_smile:

1 Like

Hi @ogra,

Thanks for the quick reply!

I resolved the issue by configuring wpe-webkit-mir-kiosk in daemon mode. Now it is working fine.

1 Like

I’d recommend using Ubuntu Frame rather than mir-kiosk. It does everything mir-kiosk does and more while being easier to configure.

1 Like

I have installed Ubuntu server in raspberry pi 3B+, please help me to configure it in Access point mode(hotspot). If possible please share docs or link.

i have never tried this on Ubuntu Server so your mileage may vary but you could try to use my Ubuntu Core AP setup:

If I use Ubuntu frame then I can skip the steps mentioned above(i.e. installation and configuration of mesa-utils library )?

I don’t think there was ever any need to install mesa-utils, but any configuration of the OS needed by mir-kiosk will also be needed by Ubuntu Frame.

1 Like

Thanks @alan_g.

I have one more question, how to set the hostname for the ubuntu server and ssh it via hostname instead of IP address. Every time it is hard to find the IP address.

2 posts were split to a new topic: Does Ubuntu Server 20.04 support GPIO?

2 posts were split to a new topic: Ubuntu Frame with WPE on Raspberry Pi 4