Keepassxc with firefox-snap?

On Ubuntu 22.04 after my last update Firefox got replaced by a snap version.

How do I connect the keepasxc snap with the firefox snap?

1 Like

I’ve been using Firefox snap for quite a while now. Until recently, it was all OK with opening URLs in Firefox right from KeePassXC, which is also snap. A couple of days ago, a brand-new version of KeePassXC has been released, and it is great except for the appeared issue with inability to open URLs. So it looks like this is not a Firefox-snap-related issue, and rather associated with KeePassXC.
And yes, the issue is quite annoying, though it’s not critical.

Seems like it could be something that could be fixed, since it was working before. Maybe bring it up at Snapcraft Forum.

Since firefox snap also the Gnome-shell addon do not work.
Does someon know, will the limitation with the third party apps like keepasxc and gnome-shell addon be solved or should I go back to firefox from repository?

How could I replace firefox from Snap back to a deb version?

You could try adding the Mozilla ppa.

I’m not able to find it. Do you have the correct address?

Seems like they have ppa for Firefox Beta nowadays.

I’m on Jellyfish that’s beta enougth for me. I would prefer a normal firefox release.

1 Like

For the record. If Firefox do not work with KeepassXC on Jellyfish. I have to look for a new Linux/Distribution.

For the Record the DEB pakage “webext-keepassxc-browser” is useless now. It do not work with Snaped Firefox.

it will, once the firefox with the native messaging protocol fix has landed in the next few days (like discussed in various firefox threads in forum.snapcraft.io and described at length in the 22.04 release notes)

3 Likes

I installed Webext-Keepassxc-browser on 22.04 LTS.
It refreshed the Firefox snap and installed.
I am not having any problems with Firefox at all.
I did notice that the package has no bug reports.

Didn’t work for me. How do I know that Firefox is using webext-keepassxc-browser deb package version and not the previous version that I had installed from the addons.mozilla.org site?