Introducing early access to the Steam snap!

And if you run snap connections steam They appear manually connected?

If that is the case, maybe it’s the Linux side of gaming or like @lucyllewy say pressure-vessel Games are not supported :confused:

This is the result:

mario@mario:~$ snap connections steam

Interfaz Enchufe Ranura Notas
audio-playback steam:audio-playback :audio-playback -
audio-record steam:audio-record :audio-record manual
bluez steam:bluez - -
content[gtk-3-themes] steam:gtk-3-themes gtk-common-themes:gtk-3-themes -
content[icon-themes] steam:icon-themes gtk-common-themes:icon-themes -
content[sound-themes] steam:sound-themes gtk-common-themes:sound-themes -
desktop steam:desktop :desktop -
desktop-legacy steam:desktop-legacy :desktop-legacy -
fuse-support steam:fuse-support :fuse-support manual
gsettings steam:gsettings :gsettings -
hardware-observe steam:hardware-observe :hardware-observe manual
home steam:home :home -
joystick steam:joystick :joystick manual
mount-observe steam:mount-observe :mount-observe manual
network steam:network :network -
network-control steam:network-control :network-control manual
opengl steam:opengl :opengl -
personal-files steam:dot-local-share-steam :personal-files manual
process-control steam:process-control - -
removable-media steam:removable-media :removable-media manual
screen-inhibit-control steam:screen-inhibit-control :screen-inhibit-control -
shared-memory steam:shared-memory :shared-memory -
steam-support steam:steam-support :steam-support -
system-observe steam:system-observe :system-observe manual
wayland steam:wayland :wayland -
x11 steam:x11 :x11 -

Could you format the text to see it better? At first glance it seems that you are missing the snap connect steam:process-control Since it’s doesn’t say “manual”. But maybe you already have it connected in this case It’s as far I can help you since At this point I don’t know what more can be done with the snap :frowning_face:

On the subject of ProtonUp, it would be probably useful to either make the Steam Snap compatible with the ProtonUp-Qt flatpak or appimage, or to develop an alternative GUI app for ProtonUp either bundle into the Steam snap or as a separate companion snap. Because while some people have no issues using CLI for those sort of things, others prefer GUI. Notably newcomers to Linux would tend to associate a smooth experience with having a GUI based option.

I have no preferences on the subject but I suppose that given the current stance Canonical has over out of the box flatpak integration, either a native deb option or a snap (or bundled in the Steam snap) would be the more coherent approach.

1 Like

Capcom Arcade Stadium with Street Fighter 2 is free on Steam for a limited time if anyone wants to try it with Proton.

My apologies if I sound like a hater or salty. I posted this issue on the GitHub repo about a month now, but didn’t receive any answer from anyone. Also, I haven’t seen any updates to the project, so I’m wondering if this has been discontinued ( I hope not )

Could someone please help me with this issue of steam snap not finding the native libraries ( eg, or please ask me to provide more information if you need. Thank you so much.


I was already going to ask the same thing, there are several reports on GitHub and no activity has been perceived. I suppose they must be very busy with other things, but it would be good to know that this excellent initiative is not in abandonment.

Hey folks, just to reassure you, we’re absolutely committed to the Steam snap for the long term :slight_smile: and we’re actively working to improve it.

We’ve got a couple of PRs in flight that we’re prioritising landing at the mo.

I’ll check in with the team on these specific issues, but keep them coming in the meantime and appreciate the engagement!


I’ve added some suggestions to help track down what’s happening in the Github issue. My suspicion is that this is a 32-bit vs. 64-bit issue. The libraries it is complaining about are available in the Steam snap, but only 64-bit versions.

The weird part is that Steam also downloads and unpacks a “steam-runtime.tar.xz” that contains copies of these 32-bit libraries that I would have thought the game would see. We can definitely add the extra libraries to the snap though.

1 Like

As a follow-up, the game in question was 64-bit, so my initial guess that this was a 32-bit vs 64-bit issue was incorrect.

The problem turned out to be that the game’s launcher shell script resets LD_LIBRARY_PATH, so none of the extra libraries provided by the snap or even Steam’s own steam-runtime were visible. On the bright side, it means that the failure is specific to one game (or a class of games that are doing the same thing) rather than it being in some generic code path. It’s still something we should fix.

So the fix will likely involve getting the snap to run without the help of LD_LIBRARY_PATH. I’ve got some ideas about how to achieve this, but need to experiment a bit more.


Looks to be working fine! But i encountered one little bug or annoyance: in Settings, the left side selection excludes the “Steam Play” section and i had to go to Shader Pre-Caching one (as it is the bottomest that can be seen, and from that pressed arrow down key to get to Steam Play settings (to choose Proton etc.).

Thanks alot for this sandboxed Steam snap! Much appreciated!

1 Like

Nice work, but can we have a way to easily migrate games downloaded by the .deb package ?

1 Like

@kenvandineis working on a tool to help with this transition. More details to come!

How come Steam Snap thinks I only have 40GB storage?


Thankfully I got an extra SSD that I can use, but I just find that weird.

$ snap connections steam
Interface               Plug                          Slot                            Notes
audio-playback          steam:audio-playback          :audio-playback                 -
audio-record            steam:audio-record            -                               -
bluez                   steam:bluez                   -                               -
content[gtk-3-themes]   steam:gtk-3-themes            gtk-common-themes:gtk-3-themes  -
content[icon-themes]    steam:icon-themes             gtk-common-themes:icon-themes   -
content[sound-themes]   steam:sound-themes            gtk-common-themes:sound-themes  -
desktop                 steam:desktop                 :desktop                        -
desktop-legacy          steam:desktop-legacy          :desktop-legacy                 -
fuse-support            steam:fuse-support            -                               -
gsettings               steam:gsettings               :gsettings                      -
hardware-observe        steam:hardware-observe        -                               -
home                    steam:home                    :home                           -
joystick                steam:joystick                -                               -
mount-observe           steam:mount-observe           -                               -
network                 steam:network                 :network                        -
network-control         steam:network-control         -                               -
opengl                  steam:opengl                  :opengl                         -
personal-files          steam:dot-local-share-steam   -                               -
process-control         steam:process-control         -                               -
removable-media         steam:removable-media         :removable-media                -
screen-inhibit-control  steam:screen-inhibit-control  :screen-inhibit-control         -
shared-memory           steam:shared-memory           :shared-memory                  -
steam-support           steam:steam-support           :steam-support                  -
system-observe          steam:system-observe          -                               -
wayland                 steam:wayland                 :wayland                        -
x11                     steam:x11                     :x11                            -

System info:

  • Ubuntu Unity 22.10
  • 5.19.0-21-generic

Edit: I just realized that it might be a ZFS thing?

$ sudo df -h /
Filesystem                Size  Used Avail Use% Mounted on
rpool/ROOT/ubuntu_t4tk5n   40G  8.4G   32G  21% /

$ lsblk /dev/vda
vda    252:0    0   128G  0 disk 
├─vda1 252:1    0   512M  0 part /boot/grub
│                                /boot/efi
├─vda2 252:2    0     2G  0 part [SWAP]
├─vda3 252:3    0     4G  0 part 
└─vda4 252:4    0 121.5G  0 part 

$ sudo df -h 
Filesystem                                        Size  Used Avail Use% Mounted on
tmpfs                                             795M  2.3M  793M   1% /run
rpool/ROOT/ubuntu_t4tk5n                           40G  8.4G   32G  21% /
tmpfs                                             3.9G  252M  3.7G   7% /dev/shm
tmpfs                                             5.0M  4.0K  5.0M   1% /run/lock
rpool/USERDATA/root_3guali                         32G  1.2M   32G   1% /root
rpool/ROOT/ubuntu_t4tk5n/srv                       32G  128K   32G   1% /srv
rpool/ROOT/ubuntu_t4tk5n/usr/local                 32G  256K   32G   1% /usr/local
rpool/ROOT/ubuntu_t4tk5n/var/lib                   38G  6.5G   32G  17% /var/lib
rpool/ROOT/ubuntu_t4tk5n/var/mail                  32G  128K   32G   1% /var/mail
rpool/ROOT/ubuntu_t4tk5n/var/spool                 32G  128K   32G   1% /var/spool
rpool/ROOT/ubuntu_t4tk5n/var/games                 32G  128K   32G   1% /var/games
rpool/ROOT/ubuntu_t4tk5n/var/log                   32G  184M   32G   1% /var/log
rpool/ROOT/ubuntu_t4tk5n/var/snap                  32G  2.2M   32G   1% /var/snap
rpool/ROOT/ubuntu_t4tk5n/var/www                   32G  128K   32G   1% /var/www
bpool/BOOT/ubuntu_t4tk5n                          671M  451M  221M  68% /boot
/dev/vda1                                         511M   14M  498M   3% /boot/efi
rpool/ROOT/ubuntu_t4tk5n/var/lib/NetworkManager    32G  256K   32G   1% /var/lib/NetworkManager
rpool/ROOT/ubuntu_t4tk5n/var/lib/apt               32G   96M   32G   1% /var/lib/apt
rpool/ROOT/ubuntu_t4tk5n/var/lib/AccountsService   32G  128K   32G   1% /var/lib/AccountsService
rpool/ROOT/ubuntu_t4tk5n/var/lib/dpkg              32G   53M   32G   1% /var/lib/dpkg
/dev/sdb                                          492G  131G  336G  29% /media/SGExDsk
tmpfs                                             795M  372K  794M   1% /run/user/1000

Steam just raw-launches native Linux games in what’s called the “scout” runtime, which is basically where it sets LD_LIBRARY_PATH (and a bunch of other variables) to its own pinned libraries. In ~the future~ we should probably containerize all games in their own Snaps (I think flatpak Steam already does this with flatpak containers).

E: Just realized this was months ago, the point still stands.

Glad to see steam snap making progress. (Thank you devs <3)


Installed Steam (Early Access) on Lunar. The installation worked OK. Could login to my account with the QR-code.
Installed CIV VI, wich worked OK. CIV VI launches in two steps, first CIV VI starts to run and then you get a pop up where you have to click PLAY. This pop up never happens. However it launches OK with with the Windows version in Proton and the eval command found on the site gamingonlinux.
To install and run CIV V works OK.

Is it supposed to be buggy on Wayland?
I’m trying this out on KDE Neon 22.04, and it’s constantly freezing

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.26.80
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.7
Kernel Version: 6.0.6-76060006-generic (64-bit)
Graphics Platform: Wayland
Processors: 8 × AMD EPYC-Milan Processor
Memory: 7.8 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 (nvidia-driver-525-open 525.60.11-0ubuntu0.22.04.1)
Manufacturer: QEMU
Product Name: Standard PC (Q35 + ICH9, 2009)
System Version: pc-q35-6.0

Hi all. Are the efforts only on steam inside snap or are they for deb packages (outside snap) too. My question is because, if the point is to address gaming on Linux and bring about the same effect Ubuntu had on the Linux community when it came out, breaking the barrier of the idea of Linux on the desktop, then this second huge idea wouldn’t it be better to first address the needs and issues that are typically found when gaming on Linux without being limited to snaps.

Not only not limited to snaps, but also start with steam but also grow from there to other venues like wine related optimizations, cross collaboration with teams that have worked on pushing gaming on Linux (eg: feral interactive, proton or lutris to name a few).

Organize what are the main concerns and needs. Classify the typical common issues (at the software or hardware level), and proceed from there. Just an idea about how to actually go with the idea of gaming in a way that actually affects the whole Ubuntu community as a whole and propagates to other distros as well, since the point is gaming on Linux.

I’ve been using the Steam snap for a while now and it is working well. I have a high DPI display on my laptop, and I would like to scale the Steam Client UI if possible. I’m not sure how to set environment variables within the snap. I think I could use ‘snap --shell’ to pipe in an env var, but I am not sure the command to start the steam client (‘steam’ doesn’t seem to do it - many errors).

I found a reference to GDK_SCALE as the env var I need to change.

1 Like