Intel RST Issues

I can also confirm that this method of switching to AHCI doesn’t work in my case.

I’m using Alienware m15 R2 with two SSDs:
PC601 NVMe SK hynix 512GB

Configured at purchase with Intel Precision Raid, RAID0 (Stripe).

Every time I change it to AHCI, even after registry editing and booting in safe mode, the laptop just refused to boot.

Does 2 SSDs always have to be configured in RAID mode? Then why Ubuntu is not able to support Intel RST driver?

NVME drives are not backward compatible with AHCI. BTW, when you say, configured at purchase, what do you mean by that?

1 Like

I purchased the laptop pre-installed with Windows 10, and the SSDs are already configured as RAID.

I cant seem to do the

I created a drive and I’m using the UEFI-powered computer.
please could you help?

Hi there!
I’ve been trying to follow your guide, but in the BIOS menu, I can’t change the hard disk controller type to AHCI.
I’ve been trying to install ubuntu in my laptop, but intel optane has been giving me a lot of trouble. I’ve tried following this guide: but got stuck at changing to AHCI. Tried to install it anyways but it prompted me that I’ve got RST enabled

The model is: hp laptop model 14-cf0005la
Do you know of any solutions? I can try taking pictures of the BIOS but obviously they won’t be quite pretty.

1 Like

@jessearmand Do you know how the RAID was configured? Did you (or whoever set it up) need to load drivers from a thumb drive, or something similar? BTW, if you break RAID0 (stripe), you might not necessarily be able to use the data, as it is spread over two devices.

@mohmeeee Can you please provide more information? If the command does not run or throws an error, it means you’re probably not on the right volume, right folder, or perhaps there is no such file there.

@saroxan Unfortunately, I don’t have any immediate workaround that I can suggest. Every vendor has its own implementation, and sometimes, laptops have limited sets of options available in their BIOS menus. If that is so, you are out of luck. One thing that can sometimes help is to upgrade the BIOS to a new version if available. And please make sure you have a data backup in place.

@igorljubuncic Thanks, it does seem like I’m out of luck. I’ve downloaded the latest BIOS updates, and tried basically everything I could. Thanks again, I think I’ll have to try with a VM.

I have fixed the error

@igorljubuncic I suppose it’s configured with Intel Rapid Storage Technology:

I can see the RAID configuration is there, exactly as what is displayed in the BIOS:

Now, I’m curious. Is this the only way to configure 2 NVMe SSDs? or is there a better way? How does Ubuntu storage controller works?

@jessearmand Typically, when you configure RAID, this is done in BIOS, or you manually load a driver during the operating system installation. The user interface part allows you to see what has been configured, and perhaps make some adjustments, but it relies on the driver in the operating system, and how the operating system (Windows in this case) supports the underlying platform capabilities.

When you ask about the ways to configure the SSD - it really depends what you need. For example, stripe configuration in this case gives you a single “larger” disk to work with, and perhaps some data read performance improvement. But overall, in most cases NMVe drives are fast enough that you will not be bottlenecked on the disk operations to begin with. I can’t really think of a typical desktop workload that would push the disk bus to the maximum with NVMe drives.

Ubuntu - and for that matter - any operating system really - work the same way. If you have the needed driver functionality loaded into memory (either it’s part of the kernel or an additional module), then the operating system can make direct use of storage commands, which can lead to optimized usage (performance, data integrity, etc).

For instance, you could use a generic Windows driver for SSD, or you could use the drivers provided by the vendor. In some cases, the latter may give you additional functionality - this isn’t necessarily something you will see as a user, or interact directly. We’re talking about the storage functions.

Now, Ubuntu:

Depending on the type of hardware you have, and the filesystem configuration in use, Ubuntu will use different drivers to interface with the storage. You can check with drivers are loaded into memory with the lsmod command.

Then for instance, you will see drivers like this (just an example):

ahci - which is sata low level driver
dm_crypt - module for encryption/decryption (say if you use it)

Some drivers are necessarily loaded early in the boot process - these are bundled in the initrd file. You can check what’s contained inside one by extracting it.

Copy a file from under /boot, say:
unmkinitramfs /boot/initrd.img-something ~/initrd/

Then, change into the ~/initrd/ and see what’s contained there. You will see a nice tree of drivers, grouped by their functionality - crypto, fs, virt, drivers/ata, drivers/video, drivers/md (this is raid), drivers/usb, etc.

So this can give you a rough indication of what you can expect when you boot Ubuntu on a piece of hardware. The drivers are of course loaded in the right sequence - from low-level drivers, then filesystem, etc.

I hope this gives you a little more understanding of what goes on under the hood.

when, in the BIOS, I set the hard disk controller type to ACHI the BIOS tells me this change will delete everything in the drivers, will this compromise windows or just my files?

@mbett It is impossible to know from just that message. I would assume the worst and make sure you have the necessary data backup - personal files and a full system image.

Then, in my case it will best to clone my storage before I reinstall everything. As I don’t see any clear way for Ubuntu to read the existing RAID configuration. Then it will probably be better to just use 2 separate SSDs as separate disks.

Also, what does AHCI implies here in case of NVMe, I’m still not clear on this part. Why does the BIOS is using SATA, while it’s a PCIe interface. It puzzled me that OEM vendors have no information or have not updated their default installation method.

@jessearmand I really can’t say anything about specific implementations by vendors. Personally, I would use separate disks, and have a system imaging and data backup setup in place.

I followed this tutorial, however, at the end the “ren BCD BCD.bak” didn’t work. I didn’t know how to proceed and turned the computer off. Now, even the Windows Recovery doesn’t seem to work, when starting up the computer I just get ‘preparing automatic recovery’, but nothing else happens.

First, thanks for this help ! I tried several times to follow your guide. I have managed to follow it until the command prompt part. But apart from going to the diskpart and assigning letter C to the OS partition, every command I did failed. For example, when trying the “bcdboot” part, the “cd boot” command does not work. In case I got it wrong, I tried it in every volume but C, but it never did work and always displays a message error in the fashion of “no such directory”.
Besides, I have changed value data to 0 in all files you indicated in the Registry Editor. But when checking them after reboot, they had changed back to what they were earlier. Is there anything we should do to make the changes are saved ?

The same happened to me. Get back into your bios and switch “AHCI” back to “RAID on”. I was able to boot normally after that. I am not in any way experienced though.

My computer seems to be a UEFI-powered computer. Command prompt does not find the “cd” file.

I looked up the file and it has 0 bytes (see screenshot). Could that be the problem? If yes, how do I fix it?CD%20File