How to install Ubuntu Server on your Raspberry Pi

It doesn’t appear that you have added this to the tutorial.

But anyway, I can’t get any GUI running on my Pi4. I followed the tutorial and tried both kubuntu and lubuntu with the same exact thing happening for both. (Ubuntu 20 installed just fine) Super frustrating but thank you for responding on here regularly. Definitely leaves me with some level of confidence that I’ll find a solution soon.

1 Like

Well the password field won’t actually show what you’re typing. Just type in the password and hit Enter. Also, in my experience you shouldn’t have to wait more than a moment, or at all.

1 Like

glad it was not only me.
I started to feel a bit lonely and stupid.

Please see my post on the Ubuntu MATE board at:

https://ubuntu-mate.community/t/problems-with-advanced-network-configuration-for-wired-connection/21755

As presented in Martin Wimpress’ Youtube series “Desktopify Ubuntu…”, I believe this is an issue common to all desktops added to Ubuntu Server on a Raspberry Pi, and it would be useful to add the solution to the tutorial.

2 Likes

One suggestion I had was that after showing how to enable a desktop it might be worth showing how to enable VNC aswell.

1 Like
wifis:
  wlan0:
  dhcp4: true
  optional: true
  access-points:
    "home network":
      password: "123456789"

Note: If your network name has a space in it, you need to add quotation marks around it.

Save the file and extract the card from your laptop. During the first boot, your Raspberry Pi will automatically connect to this network.

When/if you use windows notepad, use space to instead of “TAB” to format lines. TAB gives an error on boot “/t” on the line where you used it.

1 Like

And it didn’t work directly, I had to connect a screen/kbd and login.

All info was ok in netplan and I restarted the service:
sudo systemctl restart netplan-wpa-wlan0

And now it had worked after a reboot also.
Btw, mac address is: ubuntu 192.168.1.13 DC:A6:32:05:6F:F7
Not the B8:27:EB: as in the install guide.

I’ll hope this will help some people or if just had some unluck…

1 Like

Suggested change to step 4:

Reference: https://askubuntu.com/questions/1240016/asking-for-log-in-when-ive-not-set-one#1240016

2 Likes

The newer Pi 4 uses a different range of MAC numbers. Your tutorial recommends identifying my Pi using this query:

arp -na | grep -i "b8:27:eb"

Pi 4 MAC addresses start with DC-A6-32 (for example, see, http://standards-oui.ieee.org/oui.txt)

Hi danyer,

Sorry for the delay in replying to you, I must have missed your notification, this change has been made, thanks for your suggestion.

1 Like

Hi, I really appreciate the detailed tutorial, thank you. I am having difficulty with setting the WiFi password by editing network-config, however. When I boot the pi it sets up the user OK but the WiFi never comes up. I know I didn’t make a mistake with the password or anything as I copied it directly from my Mac keychain. I can’t even use any utils like ifconfig as I don’t have network to install them with apt-get… are there any known issues with netplan?

1 Like

Rebooting really helped with the ubuntu/ubuntu login and also with the apt update (then reboot) and apt upgrade.

So, Ubuntu Server is certified on Raspberry Pi 4, very good, but have the authors of this tutorial checked to see whether the desktops mentioned, xubuntu, lubuntu, and kubuntu actually work?
So far I have tried xubuntu, which mostly worked, and lubuntu which will not boot. Xubuntu had an issue with the installed screensaver causing the system to lock up after two minutes of idle-- that was fixed by uninstalling the screensaver and installing a different screensaver (sorry don’t remember which now) . No luck with getting the nm-applet to work to configure wi-fi from the desktop though. So I decide to try lubuntu with sddm desktop manager. This did not boot, the process hangs without error after the snap stuff has started. So I am going to try kubuntu desktop and see if I have better luck. Anyone else gotten am successful desktop to work mostly or entirely?

1 Like

Like @maktheyak - I have a new Pi4 with a fresh Ubuntu 64bit, and editing the network-config does not produce a working WiFi connection once I’m booted into Ubuntu on the Pi. The Network details I entered are definitely correct, but I can’t ping or apt update because there’s no network connection.

I’m using a BT Home Hub, and I’m using quotation marks around both the Wireless Network name and Password. I’ve also tried it without the quotes.

1 Like

Following the tutorial, configuring the Network as written, logging in, and setting a new password all work - but the WiFi does NOT work at that point. Strangely, reboot to get right back to the same point… results in a working WIFI. Suggest this troubleshooting step is added, or if this is a bug - that it gets fixed.

Also; sudo apt update at this point errors with a lock warning. It appears there’s some background process that stops me from following these instructions without error.

1 Like

Perhaps add the normal /default Ubuntu Desktop to the list of options? standard ubuntu desktop is not listed as “a flavour” and I had to know to do an apt search for “ubuntu-desktop” to find the gnome based default to install.

2 Likes

Is the problem with the cloud-init? Why is the new image trying to access the cloud?

The installed desktop is not starting. the last three lines on the HDMI monitor are by cloud-init and no desktop or terminal prompt.
Configuration:
Pi 4B
Ubuntu 20.04 server 64 bit
kubuntu desktop
network-configuration file set for local wifi
able to ssh into Pi
How to access desktop?

Has anyone tried this with the 2020.06.15 bootloader?

Current text:

Note: If your network name has a space in it, you need to add quotation marks around it.

I omitted the quotations because my network name (SSID) does not have any spaces. It does have a dash in it. Anyway, the wifi was not able to connect. I puzzled for some time and finally decided to just try adding quotation marks. So I had to shutdown and re-edit the file, then it worked.

The example shows quotation marks. So I recommend deleting the note or changing it as follows:

Note: network name must be enclosed in quotation marks.

1 Like

For Wi-Fi with Ubuntu 20.04 on Raspberry Pi 4B I’ve found I needed additional configuration as WiFi doesn’t come up on first boot. My solution, which includes minor changes to the network-config and user-data, is documented here: https://github.com/DavidUnboxed/Ubuntu-20.04-WiFi-RaspberyPi4B.