Foundations Team Updates - Thursday 7 Sep 2023

Previous week’s status can be found at Foundations Team Updates - Thursday 31 Aug 2023


Note: I will be off for the next couple of weeks to attend DebConf and some adjacent parental leave.




  • 360
  • travel prep
  • DebConf presentation



  • Investigated LP # 1892340 on openjdk-lts(11) and raised an upstream backport request PR#2121.
  • Currently working on updating the outdated debian/copyright files #970517




  • Work on deficiencies of upstream U-Boot for the VisionFive 2 board
    • target boot devices
    • set device-tree name in dependence of board revision identified by EEPROM
    • integration of spl_tool functionality into mkimage


  • 8.2306.0-2ubuntu2 is finally merged after trouble with autopkgtests on armhf

live installer

  • Add missing device-trees for VisionFive2 via debian-cd
  • Fix soft time out on Unmatched board using kernel command line argument sysctl.kernel.watchdog_thresh=60 set in debian-cd
  • test installation with 6.5 kernel: a bug in the efivar package came up LP #2034705


  • Relaxed Netplan validation for tunnels. Netplan enforces that both “remote” and “local” IP parameters are used for tunnels. The parameter “local” is not really required. It was affecting Netplan-everywhere. When a tunnel was created without the “local” parameter the connection creation would fail (PR#407)

  • Working on a fix for netplan apply when the loopback interface is managed through Netplan. apply is taking the interface down but NM is not bringing it back (PR#408)

  • Continued the investigation of an issue related to the Netplan’s generator. It’s causing a race condition due to the fact we are calling udevadm from the systemd generator. Also created a PoC to replace the generator with a regular system service. More details here, here and here.



  • worked on APT security repository being accessed through <CC> instead of
    • PR 1790 to address it going forward in the installer
    • need to work on a plan to fix the issue on existing installs
  • fixed crash when a network interface (i.e., Wi-Fi or ethernet) disappears before or during the install. PR 1789
  • fixed UI crash when accessing help menu after creating a bond: PR 1786
  • fixed Wi-Fi interface not listed in dry-run mode. PR 1785
  • fixed forwarding of some server exceptions to the client in HTTP request handlers. PR 1782
  • fixed incorrect order of lower layers when spawning an overlay to fetch list of third-party drivers or OEM meta-packages. PR 1780
  • brainstorming about installation of codecs when subiquity goes for an offline install. No clear plan yet.


  • fixed deb822 sources stanza generation when no suite is configured. MP 450893

Ubuntu Packaging Guide

  • reported sphinx-doc/sphinx Issues #11673
  • attended weekly Ubuntu Packaging Guide meeting
  • added commonly shared links for all articles
  • writing articles:
    • explanation/upstream-and-downstream (Done :heavy_check_mark:)
    • explanation/package-model (Done :heavy_check_mark:)
    • explanation/development-process.rst (WIP :construction:)
    • explanation/releases (Done :heavy_check_mark:)
    • explanation/archive (WIP :construction:)
    • explanation/launchpad (Done :heavy_check_mark:)
    • explanation/main-inclusion-review (Done :heavy_check_mark:)
    • reference/architectures (Done :heavy_check_mark:)
    • reference/git-ubuntu (WIP :construction:)
  • still need to clean up the commit history


  • debugging .NET 6/7 mantic arm64 failure (WIP :construction:)
  • ms smoke-test integration spike (WIP :construction:)
  • attended weekly .NET Partners Sync


  • attended MIR Meeting


  • Finished the removal of kinetic results from the autopkgtest database on one of the web workers.
  • Cleaned up a couple of autopkgtest runs which had failed due to a lack of disk space on a cloud worker unit.

ISO Tracker

  • Reviewed an MP adding FDE test cases to ubuntu-manual-tests for the ISO tracker.


  • Testing of and meetings regarding FDE install of Ubuntu.
  • Tested mantic daily-legacy install with LVM and BIOS and did not encounter any issues.
  • Reported bug 2034305 regarding gnome-initial-setup not launching Ubuntu Software.
  • Fixed up the rls- (and other reporting cronjobs) so that they now run successfully on a server in PS5.
  • Submitted a firewall MP allowing http and https access to the above server.
  • Tested booting daily-live and daily-legacy media in “safe graphics mode” - both fail to do anything useful.
  • Upgraded my desktop to Mantic and then got stuck in emergency mode. The failure to boot completely was due to an MD device being renumbered.


  • Short week due to holidays

+1 week

Remaining bits from the +1 week:

  • jdupes: Fails to build on i386, because it introduces a new dependency: libjodycode. I asked on #ubuntu-release to add libjodycode to the list of packages that we build on i386.
  • stegseek: 0.6+git20210910.ff677b9-1 fails to build, because libjpeg62-turbo-dev is not available on Ubuntu. I changed the build dependency to libjpeg-turbo8-dev and uploaded 0.6+git20210910.ff677b9-1ubuntu1 to Ubuntu.
  • pytrainer: 2.2.1-1 has a broken dependency on python2, because dh-python replaced the shebang /usr/bin/env python by /usr/bin/python2. Enforce /usr/bin/python3 as shebang, uploaded that as 2.2.1-2 to Debian unstable, and synced to Ubuntu.
  • zict: zict 3.0.0-2 test_stress_different_keys_threadsafe hangs on ppc64el (LP #2033759). This behavior can be reproduces by running the test suite only on one core (on ppc64el and amd64). So I reported it upstream:
  • pytorch-vision: FTBFS with ffmpeg 6.0. Opened LP #2033761 for it and linked the Debian bug.
  • python-gsd: 3.0.1-3 was not built on s390x. This was an intentional change in the Debian package, because upstream does not support big-endian systems. So I asked the archive admins to remove the python-gsd s390x build from mantic:
  • python-libnacl: 2.1.0-1 failed to build due to a recent poetry-core breaks poetry. Since poetry 1.5.1+dfsg-4ubuntu1 is now in mantic, I retried the build successfully.
  • python-socks: The autopkgtest fails for 2.3.0-1, because it needs the tiny_proxy module (LP: #2033899). So I packaged that module as part of the Debian Python Team. python-tiny-proxy got accepted a few days later and I opened a FFe sync request (LP: #2034120) and uploaded python-socks 2.3.0-2 to unstable and synced to Ubuntu.


  • dcfldd: Doing more debugging on the test failure and nailing it down to -O3 on ppc64el (excluding lto and amd64) (LP: #2033405)
  • isc-dhcp: Uploading 4.4.3-P1-2ubuntu5 to remove initramfs-tools integration from isc-dhcp-client (LP: #2024164) and fix the autopkgtest.



  • Rebased and split (some) livecd-rootfs fixes
  • Finished udev rule replacements for GPIO, I2C, SPI; UARTs still proving a pain
  • Investigating ubuntu-image issues with raspi jammy builds
  • Worked on GPIO changes to upstream lg-gpio switch
  • Testing libcamera 0.1 compatibility (v1 and v2 modules so far)
  • Pi meetings
1 Like


Ubuntu ROCK


1 Like
  • subiquity
    • support the work to merge the canary and desktop isos into a single ISO
      • PR: #1783 - test and merge apt-related Subiquity changes
      • PR: #1781 (LP: #2028889) - min size recommendations update - fix different recommendations between TPMFDE and classic offerings when they aren’t actually all that different
      • all the testing and livecd-rootfs reviews
    • PR: #1787 (LP: #2034270) - fix CI breakage related to a disk of size 1MiB
    • investigation on getting info from rsync useful for a progress bar. I have a proof of concept. --info=progress2 is part of it, but it’s not that simple due to the %complete jumping around.
    • document the translations process and start doing so
    • no pr yet (LP: #2026225) - have a working build of livecd-rootfs changes needed to allow installing arbitrary kernels for the desktop iso. Required for OEM and if someone opts into a specific kernel. Ready for branch rebase + MP.
    • LP: #1961079 - rebase branch and rebuild test snap for customer, it aged out
  • investigate LP: #2034606 - failures to install with multipath, also were blocking Subiquity CI. This turned out to be an unfortunate packaging bug where the initramfs scripts weren’t executable on multipath-tools. Root cause found by mwhudson, he uploaded, fix confirmed.
  • start 24.04 discussions
1 Like

Short week with public holiday Monday


  • +1 maintenance, will send details on ubuntu-devel tomorrow
  • Prepping systemd upload with two bug fixes


  • Travel prep
  • 360s
1 Like


  • Update Go 1.21 FIPS support.
    • Rebase the patches, now derived from Microsoft’s fork. (add sha3; switch to
    • Upload deb package in PPA.
    • New 1.21-fips track in Go snap.
  • Update Go 1.19.13, 1.20.8, 1.21.1 release.
    • Upload to Debian unstable and sync to Ubuntu.
    • Upload to Go snap.
1 Like

I’m not even supposed to be here today


  • full SRU day on Friday


  • Work on livecd-rootfs autopkgtests to address flakiness that was delaying migrations
  • Supporting the merge of the canary desktop image into mainline, which has now landed!
  • Miscellaneous cleanup of livecd-rootfs code


  • SecureBoot cross-vendor weekly meeting


  • Reviews of specs


Out tomorrow

1 Like

I did a whole bunch of grub2 uploads in Debian to fix regressions reported in unstable, some more grub2 regression fixes, and helped @mkukri get started.

I had planned to work on software-properties deb822 support some more but ultimately did not get around to it much.


this was/is my first week at canonical, and as a foundations team member.

i’ve spent most of my time so far learning about the packaging process, and the various tools that go along with it.




  • mp implementing a custom 500 server error message
  • mp for duplicate github request fix
  • working on MP reviving old unit tests
  • amendment to validate_args function I introduced recently
  • Updated and deployed the charm twice to production

Also, welcome @mkukri !

1 Like