Foundations Team Updates - Thursday 1st September 2022

Last week’s update is available at Foundations Team Updates - Thursday 25 August 2022

1 Like

20.4.5 point release

  • Testing RISC-V images

PolarFire Icicle Kit

  • Testing images with different versions of HSS firmware


  • Fix a bug with EFI system partition detection


  • Started on rebasing RISC-V related patches for upstreaming
1 Like


  • Further review of cloud-init PR
  • Merged all unmerged branches together and started building images
    • Have been testing on Raspberry Pi images
    • This showed some issues that I added to the miscellaneous cleanup PR
    • The rest of the issues were able to resolved by changes to the image definition file, as we hoped!
    • After resolving these issues I ran through all of the ISO tracker test cases for Raspberry Pi images to confirm they are working correctly
  • Created a PR to fix compatibility with snapcraft v7 credentials
  • Started discussion about kernel and initrd sourcing for special snowflakes such as the Raspberry Pi
    • Began implementing a possible solution that was proposed in the email thread


  • Helped @waveform with failing dbus autopkgtest
  • Sponsored resulting dbus change
  • Reviewed many take home tests
  • Candidate interviews
  • Filled out engineering promotion application
1 Like




  • candidate take-home test & interview
  • prepare 360 self-review
1 Like
  • subiquity
    • PR: 1386 - complete PR fixing issues related to editing partitions and when to set the wipe value
    • PR: 1396 - remove duplicate copy of jsonschema from snap
    • PR: 1397 - fix kname lookup that was blocking from returning all OS prober results, as explained in u-d-i issue 1084
    • PR: 1399 - quick PR to a feedback item on PR: 1392, so that we can merge these and start a feature freeze branch
    • PR: 1402 - some changes for more kind terminology
    • PR: 1403 - cleanup on snapcraft file
    • Review PR: 1390, 1392, 1394, 1398, 1400
    • Start stable branch for work targetting Kinetic
    • Focal ISO testing
  • casper - successful pmem experiments for chain-booting to a different kernel in the netboot environment
  • ubuntu-desktop-installer
    • (LP: #1988042) - Suggest client side fix for random startup error
  • curtin
    • MP: 428926 (LP: #1987236) - reduce an error about s390x z-specific devices being missing to a warning.
  • update-notifier - investigate autopkgtest failure of update-motd. recent change may cause update-motd to return non-zero depending on partition config. Open LP: #1987703 and matching MP 428940, merge, upload, migrated.
  • oz: syncpackage to merge with Debian
  • Candidate packet reviews
1 Like
  • Proposed migration:
    • cross-toolchain-base / kmod / procps, retried tests and uploaded initramfs-tools with an update from Debian for depmod from kmod 30
    • requested removal of python3-pyfai and python3-freesas binaries on riscv64 (LP: #1979297) to allow migration of pyfai
  • Provided additional info for [MIR] lib*-perl for lintian 2.115 (LP: #1980662), libfreezethaw-perl and libhtml-tokeparser-simple-perl now complete, awaiting security review of libwww-mechanize-perl and libmldbm-perl
  • Noticed the recent sync of autoconf-archive dropped some patches, pinged the Debian maintainer and got that resolved, sync’d the fixed autoconf-archive
  • Still taking inventory of packages with configuration files in /etc
  • Tested new Lintian release including a fix for Debian bug #993613, merged and uploaded lintian
1 Like



  • siridb-server vs libuv1 (LP 1987558)
    • Tracked down the issue to be a NULL dereference, although it was unclear how the new libuv1 revealed this bug. I sent the patch upstream, and the Debian maintainer grabbed my patch before I got a sponsor in Ubuntu. The packaged synced from Debian and unblocked libuv1.
    • Fixed a follow on issue in pcre2 that caused siridb-server FTBFS on ppc64el (LP 1987850)
  • nodejs vs libuv1 (LP 1987693)
    • Pulled upstream patches to apply against nodejs 16.14.2+dfsg1-1ubuntu3, but then nodejs 18.7.0+dfsg-1ubuntu2 in -proposed built successfully and contained the same patches. This has since migrated and unblocked libuv1.


  • u-r-u upgrade bug triaging
  • Jammy SRU for systemd-hwe (LP 1981599)
    • Verified that systemd-hwe is in jammy-proposed
  • Merged python-pecan from Debian (LP 1987701)
1 Like

The Ubuntu QA Team’s update can be found at Ubuntu QA Team Weekly Status Update


  • socket-activated sshd has landed in kinetic release. So far no users complaining about the behavior after upgrade.
  • work to support introducing ubuntu-unity as an official flavor


  • managed retries of various autopkgtests failing with the new glibc. Removed llvm-toolchain-12 and revdeps as requested. Patched wcc for new ldd output. Got glibc migrated on Friday by hinting away the remaining failures (pygai, lxc).
  • kodi-inputstream-adaptive: new version has incomplete endianness detection, blocked NBS library transitions so fixed and forwarded to Debian
  • worked on driving the haskell transition to completion; hindered by very poor ghc performance on the buildds (and only there)


  • opencv
    • removed pytorch and reverse-dependencies
    • removed python3-ffcv on riscv64 to let ffcv migrate (new ffcv build-depends on numba which isn’t available)
    • tomopy ftbfs on ppc64el because of skimage binary skew which is now fixed
    • uploaded vitis-ai to rebuild against current opencv, missed before because it’s arm64-only; but it ftbfs on a rebuild, and ftbfs again after patching to ignore possibly-uninitialized variables. This is an Ubuntu-specific package, so bumped the upstream version and made a few changes to get it building again.
    • removed os-autoinst and reverse-dependencies
  • openexr
    • openexr-viewers ironically fails to build with new openexr. Removed.
    • aqsis ftbfs. Removed.
    • openvdb build failure fixed in Debian unstable. Merged.
    • vips blocked by ruby-vips autopkgtest regression; real regression, have not had time to investigate.
  • benchmark
    • no-change rebuild of ros2-performance-test-fixture, wrong dep only on armhf
  • nodejs
    • no-change upload of the only revdep of libnode93, node-shiny-server.
  • rocksdb
    • no-change upload of the single remaining revdep, balboa
  • qemu
    • only reverse-recommends; removed
  • ldc
    • worked through the reverse-dependencies; the D stack is in very poor shape in Debian unstable, had to submit several bug fixes and remove several packages
  • fmtlib
    • Removed opendht which ftbfs in Debian and Ubuntu
    • Removed ensmallen which was removed from Debian testing and blocking armadillo, a dependency of gnss-sdr
    • Tried to reproduce the gnss-sdr riscv64 build failure locally and could not, so retried the package build in launchpad and it failed. Reproduced in a riscv64 VM locally but could not make sense of the cmake horribleness in trying to detect lapack; so rather than trying to figure out why it was failing, just overrode cmake to prefer pkg-config for liblapack detection. Then got a new build failure about missing symbols, which maybe was the root cause of the first failure. Still investigating.
1 Like
1 Like

I am on +1 rotation this week, but still had to do “core” tasks that were time-critical or “crimes of opportunity”.


  • Investigated lxc FTBFS against glibc 2.36.0. I backported the patches, but we’re still hitting a ppc64el build failure caused by -O3. The root cause of the failure still remains to be found.

  • Packaged, uploaded and verified update 2022c to Kinetic, Jammy, Focal and Bionic (LP: #1986984)

  • Did yet another Nvidia-related install check


  • Uncovered a bug when parsing routes for the same interface from different sources, worked on reliable reproducer and detailed diagnostic. (LP: #1988444)
  • Investigated a netplan set reported on IRC by a community member

+1 rotation

  • investigated node-mqtt vs mosquitto, turned out to be a flaky

  • node-fast-safe-stringify/arm64 -> internal 30s timeout on tests that take < 5s on Debian, turn out to take 40+s on Ubuntu. Worked around by explicitly setting a bigger timeout, but would be worth looking into a bit more.

  • presage: ported to C++17 to fix FTBFS

  • lua-cliargs/lua-system/lua-say: follow-up on Bryce Harrington’s work back in July on the Lua ecosystem, those packages just needed to be triggered with each other to migrate in bulk from -proposed.

  • rust-pyo3-macros: retriggered riscv64 build, was waiting for another rust package to build

  • rust-object: investigated s390x autopkgtest regression, turned out not to be a regression and not easily fixable, hinted by tumbleweed

  • busco: needs hinting, see hints-ubuntu MP

1 Like
  • Merged a couple of grub patches into the devel git branch
  • Found issues in VPN and NetworkManager OpenVPN support
  • Setting up servers and preparing to benchmark stuff (and initial benchmark)
1 Like